two important issues

Discussion in 'HOWTO-Related Questions' started by Chad, May 7, 2007.

  1. Chad

    Chad New Member

    #1

    I'm trying to move files to my usb flash drive but it keeps telling me no permission.

    How do I create a folder on my usb drive via command line AND drag/drop via places > usb?

    chad@Secured:~$ sudo mkdir /media/Backup
    Password:
    chad@Secured:~$ sudo chmod a+w /media/Backup
    chad@Secured:~$ sudo mount /dev/sdb1 /media/Backup
    mount: /dev/sdb1 already mounted or /media/Backup busy
    mount: according to mtab, /dev/sdb1 is mounted on /media/Backups

    #2

    How do I upgrade my hardware drivers in Ubuntu 7, and yet how do I know IF I need to upgrade? I'm specifically referring to network, graphics. Sound is not working (5.1) via my SB Live 24 bit external, as dozens others are having this issue here

    http://ubuntuforums.org/showthread.php?t=402650
    http://ubuntuforums.org/showthread.php?t=419166

    For one thing, my display is not as bright in linux as it is in Vista. Not sure why.

    My networking always shows up as "restricted driver".

    #3

    Also, any way to do a complete Ubuntu system snapshot even if it is only a small partition created in Vista? For example, in Vista you can do the whole computer snapshot which I've done, took 2 DVD's. I'd like to do the same only on the Ubuntu partition. If possible, would I be able to restore that snapshot and entirely wiping out any current partitions on my laptop?

    Specs:
    Sony Vaio FE770G Laptop
    Core 2 Duo 1.83GHz
    2GB Memory
    Creative Soundblaster Live! 24-bit External USB
    Intel 945GM / 950 Chipset (graphics)
    Intel PRO/Wireless 3945ABG Network Connection
    Intel PRO/100 VE Network Connection
    15.4" Widescreen (1280x800)
    Intellipoint Wireless Laser 6000 Mouse
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What filesystem do you use on your USB drive? If it's NTFS: Linux cannot write to NTFS partitions unless you install ntfs-3g (take a look here: http://www.howtoforge.com/ubuntu_edgy_eft_ntfs_ntfs_3g
    http://www.howtoforge.com/the_perfect_desktop_ubuntu7.04_p6 )

    Take a look at the tutorials in this section: http://www.howtoforge.com/taxonomy_menu/1/34
    Something like Ghost4Linux, dd, or SystemImager should work for you.
     
  3. Chad

    Chad New Member

    Trying to install systemimager from this link (auto script) but it won't work
    http://wiki.systemimager.org/index.php/Quick_Start_HOWTO#Download_the_required_packages

    Code:
    chad@Secured:~/systemimager$ ./install -v --download-only --tag stable --directory . systemconfigurator \ systemimager-client systemimager-common \ systemimager-i386boot-standard systemimager-i386initrd_template \ systemimager-server \ systemimager-bittorrent systemimager-flamethrower
    Using pre-existing package list: ./stable.list
    Downloading: http://dl.sourceforge.net/sourceforge/systemconfig/systemconfigurator-2.2.9-1.noarch.rpm...done!
    
    ERROR: package " systemimager-client" does not exist in ./stable.list
    
    
    I also installed ntfs-3g via Synaptic, then rebooted. I still get the same error "do not have permission" to write to usb.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    If you're on Ubuntu, you should try and follow these instructions: http://wiki.systemimager.org/index.php/HOWTO_Install_from_sources_on_a_Debian_system


    Did you modify /etc/fstab?
     
  5. Chad

    Chad New Member

    Thanks for the help.

    Can someone please help me upgrade my drivers, or at least find out HOW I should know when new drivers are available?

    I also want to know why my linux is not as bright/saturated (gamma?) as Vista. I want to make sure my setup is on 32bit, not 24bit. How can I figure this out?

    chad@Secured:~$ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)

    I have a Sony Vaio laptop with 1280x800 widescreen
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If the drivers are available in Ubuntu, you can get the latest updates with:

    apt-get update
    apt-get -u upgrade

    or with the update application that shows when updates are available in the task bar.

    If your drivers are third party drivers that you download from other websites then ubuntu, you will have to check these websites for updates manually.

    But if your drivers work fine, you normally do not need to update them.
     
  7. Chad

    Chad New Member

    Ok, but here's the thing that concerns me. My intel wireless driver shows up as "restricted driver". What does that mean and how do I correct that?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Restricted driver maens, that the driver is not released as open source by intel. It does not mean that is resticted in functionality like a trial version or that it is not the optimal driver for your hardware.
     

Share This Page