Tutorial: The Perfect Server – Ubuntu 11.10 [ISPConfig 3] pureftpd issue

Discussion in 'HOWTO-Related Questions' started by madlars, Jan 18, 2012.

  1. madlars

    madlars New Member

    Hello,
    when I try the "/etc/init.d/pure-ftpd-mysql restart" command
    I get this error message: "Starting ftp server: /usr/sbin/pure-ftpd-wrapper: invalid configuration file /etc/pure-ftpd/conf/tls: No corresponding directive"

    It's driving me insane I've been trying to figure it out all day.
    for as far as I can tell I did it exactly as in the guide.

    CHEERS! Lars.
     
  2. Rescue9

    Rescue9 HowtoForge Supporter

    What are the results when you run as root: cat /etc/pure-ftpd/conf/TLS
     
  3. epretorious

    epretorious HowtoForge Supporter

    I followed the instructions in Step 16 ("Install PureFTPd") of "The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]" and have confirmed that PureFTPd is working correctly:

    Code:
    [eric@ispconfig-1 ~]$ grep -B1 -A2 -i tls /etc/pure-ftpd/pure-ftpd.conf 
    # This option can accept three values :
    # 0 : disable SSL/TLS encryption layer (default).
    # 1 : accept both traditional and encrypted sessions.
    # 2 : refuse connections that don't use SSL/TLS security mechanisms,
    #     including anonymous sessions.
    # Do _not_ uncomment this blindly. Be sure that :
    # 1) Your server has been compiled with SSL/TLS support (--with-tls),
    # 2) A valid certificate is in place,
    # 3) Only compatible clients will log in.
    
    TLS                      1
    
    [eric@ispconfig-1 ~]$ sudo /etc/init.d/pure-ftpd restart
    Stopping pure-ftpd:                                        [  [COLOR="Lime"]OK[/COLOR]  ]
    Starting pure-ftpd:                                        [  [COLOR="Lime"]OK[/COLOR]  ]
    
    [eric@ispconfig-1 ~]$ sudo /etc/init.d/pure-ftpd status
    pure-ftpd (pid  1888) is running...
    
    +------+---------+-------+------+-------------------------------------------+
    | PID  |  Login  |For/Spd| What |                 File/IP                   |
    +------+---------+-------+------+-------------------------------------------+
    Please include the relevant portion of the PureFTPd configuration file.
     
  4. madlars

    madlars New Member

    If I run that command it says it could not find the file.
    If i run it without the "cat" on the command it says :
    bash: /etc/pure-ftpd/conf/TLS : Toegang geweigerd <<means access denied.
     
  5. madlars

    madlars New Member

    Ok I will try those instructions, how do i get to the configuration file?
     
  6. epretorious

    epretorious HowtoForge Supporter

    Sorry - I just realized that there is a fundamental difference between the way that Ubuntu/Debian packages PureFTPd+MySQL and the way that Centos/RH packages PureFTPd+MySQL:
    1. There is no pure-ftpd-mysql init script in Centos/RH, and;
    2. There is no pureftpd-wrapper script in Centos/RH.
    Code:
    [eric@ispconfig-1 ~]$ ls -al /etc/init.d/pure*
    -rwxr-xr-x. 1 root root 1524 Mar 15  2011 /etc/init.d/pure-ftpd
    
    [eric@ispconfig-1 ~]$ ls -al /usr/sbin/pure*
    -rwxr-xr-x. 1 root root  21844 Mar 15  2011 /usr/sbin/pure-authd
    -rwxr-xr-x. 1 root root   3283 Mar 15  2011 /usr/sbin/pure-config.pl
    -rwxr-xr-x. 1 root root   7614 Mar 15  2011 /usr/sbin/pure-config.py
    -rwxr-xr-x. 1 root root 216500 Mar 15  2011 /usr/sbin/pure-ftpd
    -rwxr-xr-x. 1 root root  34984 Mar 15  2011 /usr/sbin/pure-ftpwho
    -rwxr-xr-x. 1 root root  18156 Mar 15  2011 /usr/sbin/pure-mrtginfo
    -rwxr-xr-x. 1 root root  20692 Mar 15  2011 /usr/sbin/pure-quotacheck
    -rwxr-xr-x. 1 root root  24812 Mar 15  2011 /usr/sbin/pure-uploadscript
     
    Last edited: Jan 18, 2012
  7. madlars

    madlars New Member

    Yes, the instructions you followed are somewhat the same, but just the part im having trouble with is different from your version.
     
  8. epretorious

    epretorious HowtoForge Supporter

    The first command will produce more concise output. The second command requires less typing:
    Code:
    grep -B1 -A2 -i tls /etc/pure-ftpd/pure-ftpd.conf 
    ...or...
    Code:
    cat /etc/pure-ftpd/pure-ftpd.conf
     
  9. madlars

    madlars New Member

    same message as before "file or folder does not exist"
     
  10. epretorious

    epretorious HowtoForge Supporter

    Sorry - I should have adjusted for the Ubuntu/Debian way of doing things.

    Please include the directory listings of /etc/pure-ftpd/ & /etc/pure-ftpd/conf and the contents of the files /etc/pure-ftpd/conf/pure-ftpd.conf & /etc/pure-ftpd/conf/TLS.

    REFERENCE
    The Perfect Server - Ubuntu 11.10 [ISPConfig 3] - Page 4
     
    Last edited: Jan 18, 2012
  11. madlars

    madlars New Member

    I dont know how to do that, im totally new to linux and using these commands, but teh file /etc/pure-ftpd/conf/TLS contains "1" in the first line without the quotes.

    I just found out that I can copy paste the commands from the tutorial via ssh (PuTTY)
    so I'm gonna try setting it up again (on another hdd just in case) using ssh.

    Ill let you know if it worked.
     
  12. epretorious

    epretorious HowtoForge Supporter

    Please include the directory listings of /etc/pure-ftpd/ & /etc/pure-ftpd/conf and the contents of the files /etc/pure-ftpd/conf/pure-ftpd.conf & /etc/pure-ftpd/conf/TLS.
     
  13. madlars

    madlars New Member

    Hey!

    I dont know how to give you that, but I already fixed it myself.
    I installed it again on another hard disk and this time I copy and pasted everything using an ssh client. everything works as it should. thanks for your help though!

    CHEERS! Lars.
     

Share This Page