Turn off defang?

Discussion in 'Installation/Configuration' started by AZMel, Jan 6, 2006.

  1. AZMel

    AZMel New Member

    I am running with postfix. How do I turn off the defang on mime attachments?

  2. falko

    falko Super Moderator ISPConfig Developer

    Disable "Mailscan" in ISPConfig for each user.
  3. AZMel

    AZMel New Member

    Thanks :cool:
  4. sn3f3ru

    sn3f3ru New Member

    But what if I do want it to do a virus scan, just not to change the file extensions?

    How can I do that? Or is it possible?

    Because the tooltip says:
    Enables the virus scanner for this mailbox. Extensions of suspicious attachments (e.g. .exe-files) will be renamed so that they cannot be opened by double-click.

    I want the virus scan to remain on, just to stop renaming the files.

    Thank you.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Dont mix up the Mailscan and antivirus options.

    Virus scan is not connected to Mailscan at all. Virus scan is a separate checkbox and can be enabled / disabled independantly.
  6. tijn_tux

    tijn_tux New Member

    Is there a way to config mailscan? like, i want .exe files renamed, but .doc files not..

  7. falko

    falko Super Moderator ISPConfig Developer

    You can modify the template files /root/ispconfig/isp/conf/html-trap.rc.master and /root/ispconfig/isp/conf/local-rules.rc.master.
  8. tijn_tux

    tijn_tux New Member

    Ok :)

    One little Q: does the master template auto-update all the users? or do i have to copy it?

    ps. for the users with the same problem, the line is in html-trap.rc.master and the line number is 522

  9. falko

    falko Super Moderator ISPConfig Developer

    You must make a modification for each user in ISPConfig so that the changed template will be copied to the users' home directories.

Share This Page