Trying to replace exim with postfix

Discussion in 'Server Operation' started by garg, May 20, 2008.

  1. garg

    garg New Member

    Hello,
    I installed Ubuntu 8.04 using the howto forge perfect server tutorial. I also installed request tracker 3.6 using apt-get. It installed fine but it ended up installing exim.

    Now when I try to install postfix, it gives me the following:

    Code:
    [email protected]:/# apt-get install postfix libsasl2-2 sasl2-bin libsasl2-modules procmail
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libsasl2-2 is already the newest version.
    libsasl2-modules is already the newest version.
    The following extra packages will be installed:
      db4.6-util
    Suggested packages:
      mail-reader postfix-cdb postfix-ldap postfix-mysql postfix-pcre postfix-pgsql resolvconf
    The following packages will be REMOVED:
      exim4-base exim4-config exim4-daemon-light
    The following NEW packages will be installed:
      db4.6-util postfix procmail sasl2-bin
    0 upgraded, 4 newly installed, 3 to remove and 0 not upgraded.
    Need to get 0B/1556kB of archives.
    After this operation, 201kB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Preconfiguring packages ...
    dpkg: exim4-base: dependency problems, but removing anyway as you request:
     exim4-daemon-light depends on exim4-base (>= 4.69).
    (Reading database ... 26826 files and directories currently installed.)
    Removing exim4-base ...
     * Stopping MTA                                                                                                                                       [ OK ]
    Removing exim4-config ...
    dpkg: exim4-daemon-light: dependency problems, but removing anyway as you request:
     rt3.6-clients depends on exim4 | mail-transport-agent; however:
      Package exim4 is not installed.
      Package mail-transport-agent is not installed.
      Package exim4-daemon-light which provides mail-transport-agent is to be removed.
     request-tracker3.6 depends on exim4 | mail-transport-agent; however:
      Package exim4 is not installed.
      Package mail-transport-agent is not installed.
      Package exim4-daemon-light which provides mail-transport-agent is to be removed.
    Removing exim4-daemon-light ...
     * Stopping MTA                                                                                                                                              /sbin/start-stop-daemon: warning: failed to kill 4318: No such process
    invoke-rc.d: initscript exim4, action "stop" failed.
    dpkg: error processing exim4-daemon-light (--remove):
     subprocess pre-removal script returned error exit status 3
    Errors were encountered while processing:
     exim4-daemon-light
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    It seems as if exim is listed as a dependency for request tracker. Is there a way I can remove it as a dependency so I can uninstall it and replace it with postfix?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What happens when you add the request tracker package to the
    Code:
    apt-get install postfix libsasl2-2 sasl2-bin libsasl2-modules procmail
    line?
     
  3. garg

    garg New Member

    Thanks for the reply!

    I actually wasn't able to try that :(. I removed request tracker and then did /etc/init.d/exim start and then apt-get exim4 remove and then I installed postfix and courier using the howtoforge perfect setup.

    Then to install request tracker I did aptitude install request-tracker3.6 and it set it up just fine. The apt-get remove requesttracker3.6 did not remove the config file or the database. Now I just have to figure out how to get it to listen on pop3 so request tracker can accept and send emails.

    thanks!
     
  4. make-fun

    make-fun Member

    Hi folks,

    I'm also getting in trouble with Exim and don't seem to get it to work…

    Each time I try to install Postfix it has issues with exim4-daemon-light & exim4-base…
    Code:
    apt-get install postfix libsasl2-2 sasl2-bin libsasl2-modules procmail
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Reading state information... Fertig
    libsasl2-2 ist schon die neueste Version.
    libsasl2-2 set to manually installed.
    sasl2-bin ist schon die neueste Version.
    libsasl2-modules ist schon die neueste Version.
    procmail ist schon die neueste Version.
    Vorgeschlagene Pakete:
      postfix-cdb postfix-ldap postfix-mysql postfix-pcre postfix-pgsql
    Die folgenden Pakete werden ENTFERNT:
      exim4-base exim4-config exim4-daemon-light
    Die folgenden NEUEN Pakete werden installiert:
      postfix
    0 aktualisiert, 1 neu installiert, 3 zu entfernen und 0 nicht aktualisiert.
    Es müssen noch 0B von 1160kB Archiven geholt werden.
    After this operation, 926kB disk space will be freed.
    Möchten Sie fortfahren [J/n]?
     j
    Code:
    Vorkonfiguration der Pakete ...
    (Lese Datenbank ... 41531 Dateien und Verzeichnisse sind derzeit installiert.)
    Entferne exim4-daemon-light ...
     * Stopping MTA                                                                                                 /sbin/start-stop-daemon: warning: failed to kill 3807: No such process
    invoke-rc.d: initscript exim4, action "stop" failed.
    dpkg: Fehler beim Bearbeiten von exim4-daemon-light (--remove):
     Unterprozess pre-removal script gab den Fehlerwert 3 zurück
    dpkg: exim4-config: Abhängigkeitsprobleme, aber entferne es auf Anfrage dennoch:
     exim4-base hängt ab von exim4-config (>= 4.30) | exim4-config-2; aber:
      Paket exim4-config soll entfernt werden.
      Paket exim4-config-2 ist nicht installiert.
      Paket exim4-config, das exim4-config-2 bereitstellt, soll entfernt werden.
     exim4-base hängt ab von exim4-config (>= 4.30) | exim4-config-2; aber:
      Paket exim4-config soll entfernt werden.
      Paket exim4-config-2 ist nicht installiert.
      Paket exim4-config, das exim4-config-2 bereitstellt, soll entfernt werden.
    Entferne exim4-config ...
    dpkg: exim4-base: Abhängigkeitsprobleme, aber entferne es auf Anfrage dennoch:
     exim4-daemon-light hängt ab von exim4-base (>= 4.69).
    Entferne exim4-base ...
     * Stopping MTA                                                                                                 /sbin/start-stop-daemon: warning: failed to kill 3807: No such process
    invoke-rc.d: initscript exim4, action "stop" failed.
    dpkg: Fehler beim Bearbeiten von exim4-base (--remove):
     Unterprozess post-removal script gab den Fehlerwert 3 zurück
    Fehler traten auf beim Bearbeiten von:
     exim4-daemon-light
     exim4-base
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    I'm trying this in an testing enviroment and used the "update-manager-core package" on a fresh 6.06. The upgrade would only start with a "do-release-upgrade -d", but other than that it went smooth…

    Anyone an idea?

    Cheers
     

Share This Page