trying to install roundcubemail

Discussion in 'Installation/Configuration' started by ressel, Dec 23, 2009.

  1. ressel

    ressel Member HowtoForge Supporter

    Hello I'm trying to install roundcubemail on my centos 5, and i have followed the guide i have found here on the forum, i have used this setup:

    Can anyone help how i can fix this?
    Code:
    ###########################################
    #This is basically a modified version of /etc/apache2/conf.d/phpmyadmin.conf
    # RoundCube default Apache configuration
    
    Alias /roundcube /usr/share/roundcube/roundcubemail-0.3.1
    
    <Directory /usr/share/roundcube/roundcubemail-0.3.1>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    
    # Authorize for setup
    <IfModule mod_php4.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    </Directory>
    #########################################
    
    when i try access i get following error:
    Forbidden
    You don't have permission to access /roundcube on this server.

    owner: root:root
    chmod 755

    [Wed Dec 23 14:30:15 2009] [error] [client xxx.xxx.xxx.xxx] client denied by server configuration: /usr/share/roundcube/roundcubemail-0.3.1
     
  2. maced0n

    maced0n New Member

    Try this:

    chown apache:apache -R /usr/share/roundcube/roundcubemail-0.3.1
     
  3. ressel

    ressel Member HowtoForge Supporter

    Sad but true, no change
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the outptu of
    Code:
    ls -la /usr/share/roundcube/roundcubemail-0.3.1/
    ?
     
  5. ressel

    ressel Member HowtoForge Supporter

    Here is the output:
     
  6. maced0n

    maced0n New Member

    mv /usr/share/roundcube/roundcubemail-0.3.1/index.html /usr/share/roundcube/roundcubemail-0.3.1/index.html.bak
     
  7. ressel

    ressel Member HowtoForge Supporter

    done, and no change.
    still error 403.
    Forbidden

    You don't have permission to access /roundcube on this server.
     
  8. maced0n

    maced0n New Member

    This is probably a SELinux issue.

    It's best to move your roundcube files in your /var/www/ directory and make appropriate changes in apache configuration.

     
    Last edited: Dec 24, 2009
  9. ressel

    ressel Member HowtoForge Supporter

    I have tried copy the files to /var/www/roundcube/

    [Thu Dec 24 17:38:41 2009] [error] [client 85.81.104.178] client denied by server configuration: /var/www/roundcube/roundcubemail-0.3.1
    [Thu Dec 24 17:38:41 2009] [error] [client 85.81.104.178] client denied by server configuration: /var/www/roundcube/roundcubemail-0.3.1

    Code:
    ###########################################
    #This is basically a modified version of /etc/apache2/conf.d/phpmyadmin.conf
    # RoundCube default Apache configuration
    
    Alias /roundcube /var/www/roundcube/roundcubemail-0.3.1
    
    <Directory /var/www/roundcube/roundcubemail-0.3.1>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    
    # Authorize for setup
    <IfModule mod_php4.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    </Directory>
    #########################################
    
     
  10. maced0n

    maced0n New Member

    Try with this configuration

     
  11. ressel

    ressel Member HowtoForge Supporter

    i must say, thank you very much.

    What a nice Christmas present.

    now it gives roundcube

    CONFIGURATION ERROR

    main.inc.php was not found.
    db.inc.php was not found.
    Please read the INSTALL instructions!


    so now i will try install it.
     
  12. ressel

    ressel Member HowtoForge Supporter

    Hello,

    What to do, the installer says following:

    Version: NOT OK(PHP Version 5.2.0 or greater is required 5.1.6 detected)

    and im not able to click next.

    im using Centos 5.
     
  13. ressel

    ressel Member HowtoForge Supporter

    i changed a bit in check.php in installer folder, and now everything is working :D
     
  14. maced0n

    maced0n New Member

    As you can see here "http://trac.roundcube.net/wiki/Howto_Requirements" roundcube 0.3 requires PHP v 5.2.1 or greater.

    You can find instructions on how to upgrade the PHP 5.1.x packages in CentOS 5.x to PHP 5.2.x. here:

    http://wiki.centos.org/HowTos/PHP_5.1_To_5.2
     

Share This Page