trying to grt cURL working corectly

Discussion in 'Server Operation' started by wxman, Jul 6, 2009.

  1. wxman

    wxman New Member

    I'm running a Linux Ubuntu 8.04 server, and one of my applications I'm working on requires cURL. When I tried to install the app I get an error saying that it needs cURL to run. If I do a curl -V I get:
    Code:
    curl 7.18.0 (x86_64-pc-linux-gnu) libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.1
    Protocols: tftp ftp telnet dict ldap ldaps http file https ftps
    Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz
    If I check php.ini it's not listed. I tried manually adding extension=curl.so to php.ini and restarting apache and got this in the log:
    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/curl.so' - /usr/lib/php5/20060613/curl.so: cannot open shared object file: No such file or directory in Unknown on line 0
    I'd love to hear any ideas, because I've run out of them.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please install php5-curl:
    Code:
    aptitude install php5-curl
     
  3. wxman

    wxman New Member

    That was the first thing I tried. I get this:
    Code:
    Building tag database... Done
    The following packages are BROKEN:
      php5-curl
    The following packages have been automatically kept back:
      libcompress-raw-zlib-perl linux-libc-dev
    The following packages have been kept back:
      base-files
    0 packages upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
    Need to get 25.0kB of archives. After unpacking 123kB will be used.
    The following packages have unmet dependencies:
      php5-curl: Depends: php5-common (= 5.2.4-2ubuntu5.6) but 5.2.9-0.dotdeb.2 is installed.
    Resolving dependencies...
    The following actions will resolve these dependencies:
    
    Remove the following packages:
    libapache2-mod-php5
    php5
    php5-imagick
    
    Downgrade the following packages:
    php-pear [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    php5-cgi [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    php5-cli [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    php5-common [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    php5-gd [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    php5-mcrypt [5.2.9-0.dotdeb.2 (now) -> 5.2.3-0ubuntu1 (hardy)]
    php5-mysql [5.2.9-0.dotdeb.2 (now) -> 5.2.4-2ubuntu5.6 (hardy-updates, hardy-security)]
    
    Score is 467
    
    Needless to say I didn't continue. Unless I don't understand the warnings, it looks like that install would mess things up.
    I'm running 64bit 8.04. Could it be a problem with my sources list?
    Code:
    # deb cdrom:[Ubuntu-Server 8.04.2 _Hardy Heron_ - Release amd64 (20090121.1)]/ hardy main restricted
    deb http://archive.ubuntu.com/ubuntu/ hardy main restricted
    deb-src http://archive.ubuntu.com/ubuntu/ hardy main restricted
    
    ## Major bug fix updates produced after the final release of the distribution.
    deb http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted
    deb-src http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    deb http://archive.ubuntu.com/ubuntu/ hardy universe
    deb-src http://archive.ubuntu.com/ubuntu/ hardy universe
    deb http://archive.ubuntu.com/ubuntu/ hardy-updates universe
    deb-src http://archive.ubuntu.com/ubuntu/ hardy-updates universe
    deb http://archive.ubuntu.com/ubuntu/ hardy multiverse
    deb-src http://archive.ubuntu.com/ubuntu/ hardy multiverse
    deb http://archive.ubuntu.com/ubuntu/ hardy-updates multiverse
    deb-src http://archive.ubuntu.com/ubuntu/ hardy-updates multiverse
    
    ## offered by Canonical and the respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu hardy partner
    deb-src http://archive.canonical.com/ubuntu hardy partner
    
    deb http://security.ubuntu.com/ubuntu hardy-security main restricted
    deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
    deb http://security.ubuntu.com/ubuntu hardy-security universe
    deb-src http://security.ubuntu.com/ubuntu hardy-security universe
    deb http://security.ubuntu.com/ubuntu hardy-security multiverse
    deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse
     
    Last edited: Jul 6, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    aptitude update
    and try again.
     
  5. wxman

    wxman New Member

    I've done that many times already using different sources. I also tried using apt-get update, apt-get. Still the same results.
     
  6. wxman

    wxman New Member

    I was finally able to fix this. It ended up that I accidentally installed the wrong version of one of the php libraries. I think it happened when I turned on a dotdeb source to try out one program. I think when I did that, I updated php5-common without knowing it. The only way to fix it was to uninstall php5-common and all associated with it. Then I reinstalled all the php5 files over again from the correct sources. At least that worked for me.
     

Share This Page