troubleshooting HORDE installation

Discussion in 'Installation/Configuration' started by Ovidiu, Mar 23, 2006.

  1. Ovidiu

    Ovidiu Active Member

    I am trying to install horde from tar.gz, but I stumbled upons these probs (results from the test.php)

    how can I fix this?
     
  2. till

    till Super Moderator

    Where do you install horde? In a website or in the ISPConfig webserver on port 81?
     
  3. Ovidiu

    Ovidiu Active Member

    I do install in a normal website, using the usual apache2 (from the debian install guide provided on howtoforge) not in ispcfg webserver..

    and btw I just locked myself out: after installing the user is horde and the password is horde, I went to configuration (webbased) and selected authentication method: horde.... if I go to horde and try to login wiht horde/horde I get this:


     
    Last edited: Mar 23, 2006
  4. till

    till Super Moderator

    First. The modules that you listed are not nescessary, they where only enhancements for your horde installation.

    The php mcrypt module is available in most linux distributions. If you use debian, you can search for it with:

    apt-cache search mcrypt

    The mime magic module might be also available as php module from your linux distribution.

    The memcache module might be installable with the pear installer that comes with PHP, but i never tested it.
     
  5. Ovidiu

    Ovidiu Active Member

    apt-get install php4-mcrypt

    gave me already installed, so why is it still listed as missing?

    pecl install memcache

    went strait through but still in the list I posted and finally

    apt-cache search mime magic

    gives me:

    libfile-type-perl - determine file type using magic structure
    libapache-mod-php4 - server-side, HTML-embedded scripting language (apache 1.3 module)
    libapache-mod-php5 - server-side, HTML-embedded scripting language (apache 1.3 module)
    libapache2-mod-php4 - server-side, HTML-embedded scripting language (apache 2.0 module)
    libapache2-mod-php5 - server-side, HTML-embedded scripting language (apache 2.0 module)
    libfile-mmagic-perl - Perl module to guess file type
    php4-cgi - server-side, HTML-embedded scripting language (CGI binary)
    php4-cli - command-line interpreter for the php4 scripting language
    php5-cgi - server-side, HTML-embedded scripting language (CGI binary)
    php5-cli - command-line interpreter for the php5 scripting language

    and the relevant ones (in my opinion) give me this

     
  6. till

    till Super Moderator

    You can try to install mime magic with pear.
    Dont forget to restart your webserver afterwards.
     
  7. Ovidiu

    Ovidiu Active Member

    ok, I got some steps closer, no I am stuck here while configuring:

    whatever change I make that involves some DB I get this error:

    to be more precise, now I cannot even get to the login screen of horde:

    thats only an excerpt but I think its enough. I use Debian 3.1 with the install guide provided by howtoforge, using php4
     
    Last edited: Mar 24, 2006
  8. till

    till Super Moderator

    Check with phpinfo() if the PHP mysqli extension is installed.
     
  9. Ovidiu

    Ovidiu Active Member

    thx, you can view the result here: http://mail.web-designerz.de/horde/testt.php

    unfortunately I cannot handle that question you had - there is nothing about mysqli... I googled around last night and all similar posts on the net were dealing with php5 - if I do apt-cache search mysqli I only get 2-3 packages, if I try and install one of them apt-get will also install php5 which I don't want...

    any suggestions?
     
  10. till

    till Super Moderator

    As far as i know there is a php 4.1 mysqli extension in available in ext/pear.

    By the way. You are getting now these errors why I never used the horde framework for programming. ... Sorry, i know this dont help you with your problem, it's just a personal comment :)
     
  11. Ovidiu

    Ovidiu Active Member

    thx, I do not usually take personal offense when searching for help :)

    I tried this but need help understanding:

    I understood I need MDB2_Driver_mysqli, tried installing but it says I need php 5 ? I have 4 and want to keep it...

    I am going to try this now:

    pear install MDB2 - that was ok

    if I try again with pear install MDB2_Driver_mysqli it gives me the same error as above except for the MDB2 part

    ###edit###

    please help!
    I am stuck. I treid uninstalling DB, then I get an DB.php not found error, if I reinstall it (always restarting apache) I get the error from above: DB Error: extension not found

    [Zeile 388 von /var/www/webmail/web/horde/lib/Horde/Prefs/sql.php]
     
    Last edited: Mar 24, 2006
  12. falko

    falko Super Moderator

    mysqli is available for PHP5 only.
     
  13. Ovidiu

    Ovidiu Active Member

    wel, yes, so what to do? horde does not need php5, why do I keep getting these errors? any clue?
     
  14. Ovidiu

    Ovidiu Active Member

    well, never mind. I figured that all out. I went seevrall steps further now I am configuring IMP...

    still there is only one step missing from the perfect install of horde :) fileinfo...

    I tried: pecl install fileinfo and it gives me this:

    I have checked - I have libmagick6 installed, a reinstall does not help. any clue how I can pass to pecl the right path to the magic files, as it seems it cannot find them?
     
  15. till

    till Super Moderator

    I'am sure libmagick != libmagick.

    libmagick is the library from the imagemagick package. I'guess the fileinfo package needs a library for filetype detection which is named libmagic.

    I dont know which package includes libmagic, but maybe the post helps you anyway :)
     
  16. Ovidiu

    Ovidiu Active Member

    you guys are great :)

    I did a apt-cache search libmagic and found the culprit: libmagic-dev

    apt-get install libmagic-dev
    pecl install fileinfo

    and its done :)

    btw. if someone wants to try and install horde/imp combination, I can give help. I just succeeded in installing horde perfectly :) solved every needed/optional component install...

    now I am busy configuring IMP and then I will continue with the rest of the apps...
     
  17. Ovidiu

    Ovidiu Active Member

    ok, here is the next challenge: if I click on webmail settings I get this error:

    It just appears above the menue, I can still work... I googled around and all I foudn is that I might have not defined a protocol in the servers.php

    I looked at the indicated lines and they all are concerned with pop3 which indeed I did not define inside my servers.php because I use IMAP, here is my servers.php:

    btw. quota does not work too :-(
     
  18. falko

    falko Super Moderator

    I can't find base_protocol in servers.php...
     
  19. Ovidiu

    Ovidiu Active Member

    I googled again for: Notice: Undefined index: base_protocol in horde

    and one of the results contained this:

    but the original page is gone, thats all I found.
    So I will try and find another hint.

    I thought I am done, yet I have still some errors:

    ###edit###
    anyone using gollem as a filemanager? if so what backend do you use? I would liek to provide file access for my users, I mean access to their files on the server and need some help doing so. If that is not possible with the existing structure of ispconfig then I will give them access to a vfs in a mysql database.
     
    Last edited: Mar 26, 2006
  20. falko

    falko Super Moderator

    I'd then replace
    Code:
    'protocol' => 'imap/notls',
    in servers.php with
    Code:
    'base_protocol' => 'imap/notls',
    Maybe it works.
     

Share This Page