Troubles with ISP Config 3 and more

Discussion in 'ISPConfig 3 Priority Support' started by tonytroy, Mar 23, 2014.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Reboot the server after you changed the hostname.

    Please check the mail log file:

    cat -n 200 /var/log/mail.log
  2. tonytroy

    tonytroy Member

    I did change the hostname and reboot the server but I can't see if it worked because now the websites are not reachable. It looks like the domain's not answering, I think of a DNS issue, when i try a dig mydomain.tld, the question section answers nothing ( IN A ). i added the DNS on ISP Config and the file created on /etc/bind looks like this "pri.mydomain.err", with my old configuration I had something more like this "db.mydomain.conf", is that a problem ? Plus, the named.conf.local is empty, on my old server this file contained the call to the file "db.mydomain.conf". With this actual configuration, I don't see the call to this file so I think the zone is not defined.
    Right now, I don't know what to do to make it work....

    I tried a lot of things but the websites are down :(

    I have some errors/warnings :

    By the way : I saw the website conf, documentroot is in /var/www/$USER/web. how can I change it to /home/$USER/web (or www) ? Because when I was setting the server, I gave all the disk space for /home so I think I'll have size trouble quickly.
    Last edited: Mar 24, 2014
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that bind rejected the zone due to errors. a common error is that you did not define a-records for the ns records. This is required when you use a subdomain of the same zone as ns records.

    Send me the .err file as pm, so I can tell you whats missing.

    Thats ok.

    No. the path /var/ww is required as this path is statically compiled into apache suexec for security reasons. Wwebsites on Debian and Ubuntu are always in /var/www and not in /home. Thats not ispconfig specific. The /home partition is not used on a server as all mail, web and www data is in /var. /home is the partition that is used for the user directories on Desktops. But we can solve that with a bind mount later, first solve your dns issue.
    Last edited: Mar 24, 2014
  4. tonytroy

    tonytroy Member

    Again, thx a lot for your time and helpfull advices.
    PM sent.

    For the emails, I've tried again and I can't receive any message, even if I send it to myself from SquirrelMail.
    Do you have any clue to solve this problem ?
    I can send mails, but cannot receive any.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Chec the mail.log for errors:

    cat -n 200 /var/log/mail.log

    it miht still be related to your wrong hostname. Please check the files /etc/mailname and /etc/postfix/, if you find your domain anywhere there, then replace it by the new hostname and restart postfix.
  6. tonytroy

    tonytroy Member

    Thank you for your help with the DNS, it works now :)

    For the email, I'm having the same problem, I can send but not receive.

    I tried cat -n 200 /var/log/mail.log, I paste you the last lines but I don't see any error :

    I've received emails from MAILER-DAEMON (in my gmail account, with which I send email to [email protected]) => Diagnostic-Code: X-Postfix; unknown user: "contact". Maybe it's a clue, but I can't figure it out.

    And can you tell me more about bind mount for giving all the disk space to / instead of /home ?
    Last edited: Mar 25, 2014
  7. tonytroy

    tonytroy Member

    I tried send me an internal email with squirrelmail (from [email protected] to [email protected]) and I didn't received it.

    I took a look at the dbispconfig DB on the mail_user table and I saw that emails are supposed to be in /var/vmail/$DOMAIN/$USER/Maildir.

    I looked at every files in all directories, but found nothing.

    Then I tried a "grep -rl 'bla bla bla' *" in /var/ and I found an email I sent in /var/lib/amavis/tmp/amavis-someID/email.txt

    So amavis might be the one that create the problem. I'm gonna take have look around the web to solve this problem, but if someone has any knowledge on how to fix this, hit me :)
    Last edited: Mar 25, 2014
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Which errors do you get in the mail.log file? There must be new message appeared in the mail.log file while you send the message in squirrelmail.
  9. tonytroy

    tonytroy Member

    I edited my previous message, i found an email sent from my gmail account in /var/lib/amavis/ (but never received in my squirrelmail mailbox)

    This is what cat -n 20 /var/log/mail.log return :

    This line is strange

    because the hostname declared for my server is zenserver.serverdomain.tld, not zenser.serverdomain.tld

    [Edit] I changed the zenser.serverdomain.tld in /etc/postfix/ Tried to send an internal email but still don't work.[/Edit]
    Last edited: Mar 25, 2014
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The domain mydomain.tld must still be somewhere in /etc(/postfix/ or in /etc/mailname. Please check again.
  11. tonytroy

    tonytroy Member

    mydomain.tld is set for mydestination in /etc/postfix/, it looks like this :

    For each domain I add for emailing in ISP Config, I have to add manually the domain in the mydestination ?

    In mail.log there is this line :

    Is this normal that after the @ there is "www.mydomain.tld" . It's not supposed to be just "mydomain.tld" ?
    Last edited: Mar 25, 2014
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The domain may not be set there. Please replace it with your server hostname and restart postfix.

    No. Emails that you want to use for sending and receiving emails may not be listed in the mydestination line. You add the domains in ispconfig only.

    Thats ok.
  13. tonytroy

    tonytroy Member

    Thx till.

    I also have mydomain.tld in in /etc/mailman as DEFAULT_EMAIL_HOST and DEFAULT_URL_HOST.

    Do I have to replace it by my server hostname ?
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please replace them there as well.
  15. tonytroy

    tonytroy Member

    Now I can send and receive emails :)

    Thx a lot for your help till !

    For the free disk space problem, I saw some tutorials about mount bind + fstab, it's a sort of symlink doesn't it ?
    Is it possible to give to the / all the free space from /home instead of doing this ? (because it doesn't look easy).
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, its a sort of symlink.


    But the bind mount is not complicated.

    1) Stop apache, postfix and dovecot.
    2) run:

    mkdir /home/www
    mkdir /home/vmail
    chown vmail:vmail /home/vmail
    mv /var/vmail/* /home/vmail/
    mv /var/www/* /home/www/

    then edit the file /etc/fstab and add these 2 lines:

    /home/www /var/www    none    bind,nobootwait,_netdev    0 0
    /home/vmail /var/vmail    none    bind,nobootwait,_netdev    0 0

    mount -a

    checl with ls, that the files and folders are visible in /var/www and /var/vmail again and then start postfix, apache and dovecot.
    Last edited: Apr 2, 2014
  17. tonytroy

    tonytroy Member

    thx till, i did this (replacing mkdir /var/www by mkdir /home/vmail and mv /var/www/* /var/www/ by mv /var/www/* /home/www/) and it worked perfectly !

    Thanks a lot for your help, eveything's working now :)
  18. tonytroy

    tonytroy Member

    Hi, it's me again :)

    When I go to websites quota on ISP Config, all websites are using 20Ko. Is it because of the mount bind configuration ?
    Do I have to replace something in the system > server configuration to see the real used space ?

    One other thing : Is it possible to disable a client's website backup ? (just for one client)

    Last edited: Mar 27, 2014
  19. tonytroy

    tonytroy Member

    After a new check on the ISP Config 3 manual (which is great btw), I moved ",usrjquota=aquota.user,,jqfmt=vfsv0" to the home partition and then :

    If fixed my problem, now I can see the real used space, BUT, the soft and hard limits have changed to "unlimited"... I'm gonna check how I can fix it, but I someone's got a solution, i'm taking :)
    Last edited: Mar 27, 2014
  20. tonytroy

    tonytroy Member

    I fixed it by replacing /var/ for /home/ in system > server configuration > web AND directly in the website configuration > options > open_basedir PHP

    Hope that cand help someone (even if I think I'm the only one who put all the diskspace in the /home/ partition...)

    Any idea of how I can disable the website's backup for a customer (or a website) ?

Share This Page