Troubles with ISP Config 3 and more

Discussion in 'ISPConfig 3 Priority Support' started by tonytroy, Mar 23, 2014.

  1. tonytroy

    tonytroy Member

    Hi there,

    I've just followed this quite great tutorial and i thank how to forge for that cause it saved me a lot of time, but everything is not working properly :

    My OS is Debian Wheezy, the webserver works perfectly, but i have 2 problems :

    1. ISP Config => 403 Forbidden

    I'm not anymore to reach the ISP Config 3 web page, i have a 403 Forbidden error. I watched the apache2 logs and i found this
    Symbolic link not allowed or link target not accessible: /var/www/ispconfig
    So i searched the web and tried to add Options +FollowSymLinks after the line <Directory />, then restart apache but it didn't work.
    I also tried to add the user ispconfig in the www-data group, but still not working...

    Can you help me on that ?

    2. ISP Config & mysql

    I'm really interrested on making work a mail server, so i also followed this tutorial (thx again), but at the end, when i saw i have to do this
    'database' => 'ISPCONFIG_DATABASE',
    i get to phpmyadmin and realised that i haven't any database named ispconfig.

    What did i missed ? Have i to create a database for ISP Config 3 ? Is there a ready-to-use script somewhere ?


  2. tonytroy

    tonytroy Member

    Well well well..

    It seems I was too in "rush mode" and i didn't see it, but i do have a database for ISP Config, so i changed the name of the DB on conf.php (in the horde directory), but when i join the horde web page I can't login. Do you have any idea ?

    An for joining the ISP Config Web page, things have changed lightly : Now i don't have everytime the 403 Fordbidden, juste once on two try (approximately), even when i'm logged in, when I refresh a page I often get the error..

    Help would really be appreciated ^^

    Last edited: Mar 23, 2014
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The database name is "dbispconfig" and it exists already, if you have ispconfig installed.

    is your imap account working when you use another webmail client like squirrelmail? Please check the mail.log file for errors.

    Please check the apache error.log for the detailed error message. And do you have the apache module mod_evasive installed?
  4. tonytroy

    tonytroy Member

    Hey till,

    thx for your answers !

    I changed the horde configuration, adding dbispconfig as the database and now I can login on the horde interface.
    => I try to send an email to a gmail account of mine, it worked.
    But when I tried to answer to this email from my gmail account, i didn't received anything.
    I just need to make horde able to receive emails and i think i'm good, any idea to solve it ? (mail.log didn't give a clue)

    For the 403 error, I've installed and enabled the mod_evasive module, it looks like it fixed this problem, thx a lot :)

    Plus : When I try sending an email from SquirrelMail, I always get this error :

    Not really a problem because horde is able to send emails, but i'm curious with that problem and found nothing on the web..
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your domain has a DNS MX record that points to the hostname of your server (or to a subdomain, that points to your server)?

    Please post the content of the file:

  6. tonytroy

    tonytroy Member

    I don't know how to check that. I configured a bind file for the domain and when i try this command from another server :

    host -t MX mydomain.tld

    I get this answer

    mydomain.tld mail is handled by 10 mail.mydomain.tld.

    I also tried this

    nslookup type=mx mydomain.tld

    And I get

    Server: mydomain.tld

    ** server can't find type=mx: REFUSED

    This might be bad..

    Content of /etc/postfix/

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    please change the line:

    #submission inet n - - - - smtpd


    submission inet n - - - - smtpd

    and restart postfix. then try to send from gmail again.

    Redarding DNS: Check your dns record here:
  8. tonytroy

    tonytroy Member

    Changing solve the SquirrelMail sending problem, thx again for your help :)

    For MX, intodns said :

    I also tried and i had some errors :

    If you want, I can send you the content of the db file (bind conf for my domain) via MP, or paste it here if it's not touchy.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    add a dns a-record for mail.mydomain.tld that points to the ip addressof your server.
  10. tonytroy

    tonytroy Member

    How can I do that ? Do I have to create a specific line on the bind configuration ?
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Why do you edit the bind config manually instead of using the dns functions in ispconfig. Or is there no ispconfig instaled on your dns server?
  12. tonytroy

    tonytroy Member

    I did install ISP Config a few days ago, I created the bind file before that.

    And to be honnest, I don't know how to use ISP Config for now. Can I delete the db file and do the job with ISP Config ? Or Just create the config in ISP Config without deleting the db file ?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig should always be installed on a empty system, otherwise your manually created config can interfere with the one created by ispconfig which might cause problems. So its not easy to predict what the best option is as your manual changes might cause the ispconfig dns to fail, so you should consider to add the a-record to your zone file manually for now. A A-recos looks like this:

    mail 86400 A
  14. tonytroy

    tonytroy Member

    Ok I'll try this (the DNS may take a while to be flushed, the tld is .fr). Again, thx a lot for your help, it was really useful.

    For now, I'm gonna study the ISP Config documentation, I think I have a lot to learn with it to make my life easyer :)

    I have a last question : For each website I add on my server, I create an user. When I put a CMS with this user via a FTP Client (filezilla) and try to install it, I always have the same rights problem => Some files need to be own by the user to be modified, some others need to be own by www-data to be executed.
    Is there any way to let the user be the only owner of the files and have www-data able to act with those files ?
    Most of professionnal hosters (like hostgator) must have a specific configuration because I don't have the problem with them, only on my server...
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You must use wrong settings in the website, for websites that run a cms use these setting as described in the manual:

    1) php mode: php-fcgi or php-fpm. Never use mod_php,mod_php may only be used by php scripts that do not need o write to the filesystemlike email contact forms. for all other scripts, cms systems, blogs, etc. use php-fcgi or php-fpm
    2) enable the suexec checkbox in the website. Thats important!
    3) all files in the web folder of the site must be owned by the web user and client group of that website. This is automatically the case when you upload them by ftp. If you upload them as root user on the shell, then you have to chwon them to the correct user.

    If you follow the above steps, then there are never any user modifications nescessary. Especally you may never chown files to www-data as this will open security holes and will prevent that the cms is working correctly.
  16. tonytroy

    tonytroy Member

    I tried to set fcgi instead oh mod_php following this tutorial but I wasn't able to do it.

    Plus the whole configuration I did manually and that don't fit, I choose to re-install debian and follow your tutorial for perfect web server with wheezy.

    I'll try everything you told me using ISP Config and I'll tell you if my problems are solved :)

    Anyway, thanks a lot for your time and your answers. You did save me a lot of time !
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    This guide you linked above is incompatible with ipconfig and not required anyway, so dont try to use that! Just ensure that you installed your server exactly as described in the perfect server guide, then all functions will work out of the box and you just have to select the correct php mode in the website settings (the correct settings are the default btw.).

    The reintall is a good idea!
  18. tonytroy

    tonytroy Member

    OK so I re-install Debian Wheezy, follow exactly the perfect server tutorial and everything worked well.

    Now I can access to ISP Config admin panel, I created a new website (worked fine) and added a seo redirection : mydomain.tld => www.mydomain.tld
    The redirection doesn't work, I also tried to resync but mydomain.tld still show the "it works" page.

    Other major problem : I created an email account based on the domain, logged-in to SquirrelMail client and try to send an email => received after a while.

    I also tried to send me an email from a gmail account, never received either.

    /var/log/mail.log =>
    Did I missed something ? This time I followed the tutorial letter by letter :/
    Last edited: Mar 24, 2014
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the page show "It works"? then it is nt a page from that ispconfig website. There are several reasons for that:

    1) Wrong hostname. The hotsname of the server has to be something like server1.mydomain.tld. if you would use mydomain.tld instead, then you would not be able to use mydomain.tld as website. so check that you used a subdomain as hostame.
    2) Wrong IP address. If the wrong ip address is selected in the website settings, then apache is not able to show the website.

    That message is ok and not related to your gmail problem. If you are able to send and receive with squirrelmail, then the local mailsystem is ok. So the reason for your problem with gmail is most likely the dns record of your domain. have you tested it with intodns, is it error free now?
  20. tonytroy

    tonytroy Member

    Hi till, thx for your quick answer :)

    For the "it works" page, i did not set a sub domain.. Can I change it using the method on page 3 of the perfect server tutorial ? Will ISP Config still work after that ?

    For the email problem : I never received an email with squirrelMail, I just can send. I also tried to send an email to the adresse created with ISP Config but I didn't received it.

    Is there any ssh command that show if the sending protocol (maybe imap or smtp) is rightly configured ?

Share This Page