Troubles While Installing ISPConfig3 via Serial Console in SolusVM VPS Control Panel

Discussion in 'Installation/Configuration' started by Shyuan, Jun 28, 2012.

  1. Shyuan

    Shyuan New Member

    Hi guys,

    I got a VPS (openVZ virtualisation + solusVM VPS panel). I have my VPS installed with debian squeeze now. I tried to set up ISPConfig3 via SolusVM's Serial Console but just can't get through it. I skipped the first 2 pages on this tutotial (http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3-p4) because i don't setup the server. Not sure if I am wrong to skip those, but even if i don't skip i don't think i can do anything with it. Also, some commands return errors especially from step 11 onwards.

    I can't find any tutorial that teaches us how to install ISPconfig3 directly in VPS. Since howtoforge teaches us how to install it from scratch (ie installing server on vmware), there are quite a number of different things to do. I am confused. I am just a beginner. Would be very much appreciate if someone could help me out.

    Besides, is there any support provided to help installing it?

    Cheers.
     
    Last edited: Jun 29, 2012
  2. till

    till Super Moderator

    The tutorials work for VM installations as well. Just connect to the basic debian system with ssh and then start with step 7 of the guide:

    http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3-p3

    Pleases ee ispconfig.org support page:

    http://www.ispconfig.org/ispconfig-3/support/
     
  3. Shyuan

    Shyuan New Member

    Hi Till,

    Thank you for your response. Somehow I managed to install it successfully. However I saw this at the end of the tutorial section 20:

    May I know where do I do this? is it via console? Thank you.
     
  4. falko

    falko Super Moderator

    Yes, you do it on the command line of the host system.
     
  5. Shyuan

    Shyuan New Member

    thank you! :)
     
  6. Shyuan

    Shyuan New Member

    Hi,

    I installed ISPconfig3 successfully but in the middle and at the end, I have the following three issues that is not working/installed quite properly. Not too sure if they are important.

    First: In the middle of Step 13, I opened the file to edit, but there are only two lines of codes in the file whereas the tutorial shows there are quite a number of lines of codes. I do not have the line where you can add "usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0"

    [​IMG]

    Second: In step 18, when i execute the command "apt-get install squirrelmail", it shows the below. I chosen "Manual Symlink Setting" though. Is that okay? If it's not, where can I change to the Finnish ones?

    [​IMG]

    Third: In step 20, I did the command line for VPS openVZ, in my case my container ID is 184, I amended the container ID, then i paste exactly the same thing into console, but it returns whole lot of results as per attachment below.

    [​IMG]

    May I know if they are important that must be correctly done? Or I can ignore them? Thank you!
     
    Last edited: Jul 6, 2012
  7. falko

    falko Super Moderator

    What's in your /etc/fstab?

    Do you use OpenVZ? Did you run the commands on the OpenVZ host (not inside the container)?

    What's the output of
    Code:
    which vzctl
    on the host?
     
  8. Shyuan

    Shyuan New Member

    my /etc/fstab:

    Code:
    proc  /proc       proc    defaults    0    0
    none  /dev/pts    devpts  rw          0    0
    As for your question:

    I dont think I am doing at the correct place then. Because I did that step in the serial console located in my solusvm container.

    Also, I think I have to do this "which vzctl" on the host like you said. Which I don't think I have the access to the host you mentioned. But I tried doing that in serial console, it returns nothing.

    What I owned is a VPS account from a hosting company. Not too sure a VPS account holder can do those?
     
  9. falko

    falko Super Moderator

    No, in this case you cannot access the host. But did you test if PureFTPd is working? Maybe you are lucky and the right capabilities are already set on the host.
     
  10. Shyuan

    Shyuan New Member

    Hi Falco, i am not yet to try that out. But will do it soon as recently i am very busy ;) no time to test out the control panel. but thanks for reminding, will let you know again! :)
     

Share This Page