Troubles: OpenLDAP SambaDomain Controller Ubuntu 7.10

Discussion in 'Installation/Configuration' started by linuxbox2003, Jan 24, 2008.

  1. linuxbox2003

    linuxbox2003 New Member

    Hi, I have just installed Ubuntu 7.10 server (64 bit version) and I have installed OpenLDAP and Samba in order to make a good PDC server by LDAP authentication.
    I have installed all the software and libraries needed according to the howto and this is the problem that I have: all seems to go right but, when I reboot the system after the procedure to tell the server to use LDAP as one of the options to authenticate users, I am unable to login and the system don't accept any command.

    The only way to restore the system is to boot from a live cd and restore the pam.d directory and the nsswitch.conf file as the original.

    When I try to check if the server is alive (ping IP address) and login using a pc client I have this situation:

    - ping OK
    - ssh (doesn't answer)
    - webmin (doesn't answer)

    I make the entire installation procedure two times but I have the same result
    I suspect that some library is corrupted (I am sure that the howto works fine)

    I hope someone can help me !!!
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs?
  3. linuxbox2003

    linuxbox2003 New Member

    No, any message in my logs .... :(
    I tried many changes in pam.d files and in nsswitch.conf according to various treads read around the web about ubuntu-ldap authentications but the only way to login is the original with username and password of the local user and not for the ldap user.
  4. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately I'm no LDAP expert... :(
  5. linuxbox2003

    linuxbox2003 New Member

    OK !! IT WORKS !! :D

    ... but only if I don't reboot the server ...

    I have to investigate ..... probably there is a service that doesn't start at boot :confused:
  6. vcc

    vcc New Member


    I have the same problem.

    How do you solve your?

    Best regards
  7. yimkc

    yimkc New Member

    How do you enable the function without restarting the server?:confused:
  8. vcc

    vcc New Member

    After the end of the configuration and before the reboot I can add users and login with that users.

    After the reboot i can not login with any user

    Seems to me something does not start at the boot but I don't know what
  9. alshira

    alshira New Member

    Vista login in domain

    When i tried to join a Vista PC in domain show the following message:
    The join operation was not successful. This could be because an existing computer account having name "name_of_machine" was previously created using a different set of credentials. Use a different computer name, or contact your administrator to remove any state conflict account. The error was: Access id Denied

    Thanks for the help that you can bring me.
    Edit/Delete Message

Share This Page