trouble with web pages

Discussion in 'Server Operation' started by meomike2000, Nov 22, 2008.

  1. meomike2000

    meomike2000 New Member

    trouble with ip tables

    here is my setup. i have setup two servers. on one i have set up by the perfect server how-to-ubuntu-8.04 server , ( i will call this one ) the other is ubuntu 8.04 server also but it only has dns (bind9) installed ( i will call this one ). i have one static ip from my isp. the dns setup of both servers makes the master for my domain and the slave. has 2 eth ports, one configured with static ip from my isp and the other for my internal network.
    also on the internal network i have 1 client that i use for admin purposes. this client can use all functions on the servers ie. web pages, ftp, mail, etc.... and the client and both servers can reach the internet just fine. i have enabled forwarding, and i have added this to my /etc/rc.local file as instructed per how-to:

    #!/bin/sh -e
    # rc.local
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    # In order to enable or disable this script just change the execution
    # bits.
    # By default this script does nothing.

    sysctl -w net.ipv4.ip_forward=1
    /sbin/iptables -P FORWARD ACCEPT
    /sbin/iptables --table nat -A POSTROUTING -o eth1 -j MASQUERADE
    #/sbin/iptables -A POSTROUTING -j MASQUERADE

    exit 0

    this is my first setup. it works perfect on my internal network.
    also i did not install ispconfig on this system.

    any help with this would be very much appreciated,
    and tia....

    Last edited: Nov 23, 2008
  2. marpada

    marpada New Member

    Last edited: May 13, 2011

Share This Page