Trouble with Installation.

Discussion in 'Installation/Configuration' started by cjkeeme, Aug 3, 2005.

  1. cjkeeme

    cjkeeme New Member

    After completing the ISPconfig install I don't believe it happend correctly. This is the error I receive after the installation is complete.

    "Do you accept the licence? [y/n]y

    Checking the syntax of the httpd.conf...
    [Wed Aug 03 08:51:52 2005] [warn] NameVirtualHost [HIDDEN IP] has no Virtual
    Syntax OK
    The syntax is ok!

    ########## INSTALLATION ##########

    Preparing files. Please wait a moment...
    cp: cannot stat `/home/admispconfig/ispconfig/lib/': No such file
    or directory
    cp: cannot stat `/home/admispconfig/ispconfig/users': No such file or directory
    cp: cannot stat `/home/admispconfig/ispconfig/adminmail.txt': No such file or di
    All prerequisites are fulfilled.
    Here we go...

    Warning: main( failed to open stream: No such file or directoryin /home/cjkeeme/Documents/install_ispconfig/install.php on line 624

    Warning: main(): Failed opening '' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/cjkeeme/Documents/install_ispconfig/install.php on line 624

    Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /home/cjkeeme/Documents/install_ispconfig/install.php on line 634
    Could not connect to db
    Restarting some services...
    which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    [Wed Aug 03 08:51:54 2005] [warn] NameVirtualHost [HIDDEN IP] has no VirtualHosts
    ./setup2: line 831: [: ==: unary operator expected
    ./setup2: line 849: /etc/init.d/ispconfig_server: No such file or directory
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    egress:/home/cjkeeme/Documents/install_ispconfig #"

    There is no uninstall option as outlined in the installation guide and there all seems to be many files missing from the home directory of adminispconfig. I'm not able to access the login page. What should I do now?
    Last edited: Aug 3, 2005
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks like you had errors in a prior installation attempt and
    not extracted the installer tar.gz file again for this installtion attempt?

    If there is no uninstall script:


    then delete these two directorys manually:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    Then you can try to install again.
    You must extract the installer .tar.gz again!
  3. cjkeeme

    cjkeeme New Member


    I got it installed and have a login screen. Umm, shouldn't my u/p simply be my regular login? Is there a default u/p? I can't login.

    DISREGARD THIS. I found the default login.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    username: admin
    password: admin

    Installation manual:

    After you have answered the questions ISPConfig should be duly installed. If you indicated www as host and as the domain during the installation, you will find the ISPConfig interface under or Here you can login first with the user name admin and password
    . It is recommended to change the password immediately! This can be done under Tools

Share This Page