Trouble setting up bind on Fedora7

Discussion in 'Server Operation' started by jp8462, Nov 5, 2007.

  1. jp8462

    jp8462 New Member

    I am trying to set up bind using the perfect server config on the site. When I go to start named I get the following response
    [[email protected] named]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/etc/named.d' failed: file not found

    /etc/named.conf:3: parsing failed
    [FAILED]
    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in line 3 of /etc/named.conf?
     
  3. jp8462

    jp8462 New Member

    problems

    here is the bind.conf


    options {
    directory "/etc/named.conf";
    };

    controls { inet 127.0.0.1 allow { localhost; } keys { rndc-key; };
    };

    key "rndc-key" {
    algorithm hmac-md5;
    secret "put_code_here" ; # to make a secret code, use:
    }; # % mmencode
    # foobarsecret
    # Zm9vYmFyc2VjcmV0

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "/etc/named.d/localhost.rev";
    };



    Thanks
     
  4. jp8462

    jp8462 New Member

    problems

    I meant named.conf
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    directory "/var/named";
    instead.
     

Share This Page