Trouble installing Ubuntu Server on a raid.

Discussion in 'Installation/Configuration' started by LuniTux, Apr 17, 2013.

  1. LuniTux

    LuniTux New Member


    I have a new server ( computer that I want to install Ubuntu Server 10.04.4 on. The problem is, this server has a raid in it. The raid is setup as RAID 1. I tried to install the server but came to an option stating:

    [!] Detect disks
    One or more drives containing Serial ATA RAID configurations have been found. Do
    you wish to activate these RAID devices?
    Activate Serial ATA RAID devices?
    <Go Back>                                                            <Yes> <No>
    If I choose <Yes> I am brought to another screen with multiple options:

    [!!] Partition disks
    Configure iSCSI Volumes
    Undo changes to partitions
    Finish partitioning and write changes to disk
    <Go Back>
    I checked the iSCSI option but it wants an IP address for the drives? The drives are connected to the computer so there should not be an IP address for them.

    Undo changes appears to just cause the install to hang up.

    Finally, if I try to "Finish partitioning and write changes to disk" I get an error:

    [!!] Partition disks
    No root file system is defined. Please correct this from the partitioning menu.
    The next thing I tried was to find drivers that might fix the problem.

    I downloaded the drivers from the Adaptec website but when I try installing using the new instructions included with the driver after using CTRL+ALT+F2,

    mkdir /AACRAID
    mount -t vfat /dev/sdc1 /mnt
    cp /mnt/aacraid-2.6.32-38*.ko /AACRAID/
    umount /mnt
    cp -f /AACRAID/aacraid-2.6.32-38-generic.ko /lib/modules/2.6.32-38-generic/kernel/drivers/scsi/aacraid/aacraid.ko
    insmod /lib/modules/2.6.32-38-generic/kernel/drivers/scsi/aacraid/aacraid.ko
    but I get an error when I try to run "insmod /lib/modules/2.6.32-38-generic/kernel/drivers/scsi/aacraid/aacraid.ko" stating:

    insmod: error inserting '/lib/modules/2.6.32-38-generic/kernel/drivers/scsi/aacraid/aacraid.ko': -1 No such device

    I have looked everywhere I can think of but can not find a solution. Any help would be appreciated.

  2. LuniTux

    LuniTux New Member

    Progress... I think.

    I booted up a live cd (Desktop Edition) just to see if it would recognize the raid and found that it shows both drives as


    I thought that the RAID would only show one drive. I tried to install in gave me a similar "No root file system is defined" error
  3. wlee1970

    wlee1970 New Member

    Try this

    See if this does it for you. If you are running Ubuntu, or debian.

    One question since raid acts more then one, do you have it setup to read as 1 raid that doesn't act more then one.

    Try to figure it in the adaptec software to the raid and find out which one would work for you better.


Share This Page