Trouble Installing suphp-0.7.1

Discussion in 'Installation/Configuration' started by LinuxPete, Dec 21, 2010.

  1. LinuxPete

    LinuxPete Member HowtoForge Supporter

    Hi,
    I'm working my way through "The Perfect Server Fedora 13 86_64" and am stuck at step 15 "Installing mod_php, mod_fcgi/PHP5, And suPHP".
    When I do the yum install on the various packages I get an error:

    Error unpacking rpm package apr-devel-1.3.9-3.fc13.x86_64
    error: unpacking of archive failed on file /usr/bin/apr-1-config: cpio: rename

    I tried the whole command line again but w/o errors. When I tried to to the configure on suphp, i get an error:

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
    build directory, or an apr-config file.

    I've tried rpm -ql httpd | grep apr to see if it is a part of the apache package I installled.

    Any ideas of what is happening or what I missed?

    thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. LinuxPete

    LinuxPete Member HowtoForge Supporter

    I've got it to work by starting from the top. I had to do this about 3-4 times.
    One of the times I had to start over because the machine just would not come up after the first reboot.

    This may be more of a problem with my hardware than the fedora 13 dist.

    I will use fedora 14 in the near future.
    Thanks
     

Share This Page