Translation HowTo

Discussion in 'Tips/Tricks/Mods' started by SupuS, Aug 28, 2006.

  1. digicon

    digicon New Member

    hi supus, i have a question on tranlating

    am new at ispconfig, now i have translate Isp config in japanese from english, i have already change all en.lng files by the direction from this forums, (i make jp.lng files )
    but the problem now i am facing is ,
    1. after completing translation including changing the charshet of config.inc.php(i changed it to UTF-8) , when i add client and login to that client management by browser, then nothing can be seen in browser. (firefox)
    2.if i login by using Internet Explorer, the management tools doesnt reloaded,
    its give a massege like
    Ordner werden geladen....
    Loading folders....

    is that anything probelm of my setting over tranlating? or the charshet i have choosed for ispconfig (UTF-8) is not appropiate for the translation of ispconfig.
    on the other hand, the distribution is centos 5.1 ,and running over the kernel
    2.6.18-53.1.14.el5xen.
    please give me some suggegsotion.
     
  2. SupuS

    SupuS Member HowtoForge Supporter

    Hi SCelik

    I tried set db to utf8 when installing on gentoo but ISPConfig seems to be incompatible with it so I have to use iso88591 with czech too (I didn't try iso88592). Czech special letters are on the end of the list.
     
  3. SCelik

    SCelik New Member

    But utf8 is neccesary for a software that has many languages :( Well, maybe in 3.x ? And it's good for a standard meta line for all languages? So we don't need to work on html files..
     
    Last edited: May 17, 2008
  4. Mike.G

    Mike.G New Member

    Hi, everyone,
    I had translated those languages files to Chinese Version.
    and I had changed the configuration files, and I used the UTF-8 as the encoding code, and
    when I open the browser access the login page, it show the Chinese version web page, I think it it successed, but when I login in the system, I found the whole system is english version stiill, why ? what's that happen?
    will i changed some options in control panel? but I had tried to found out what's that option, but i am failed, who can help me?
    and I had sent email to Till, and sent those language files to him,
    pls help me take a look.

    thanks very much, everyone.


    Mike.G
     
  5. Mike.G

    Mike.G New Member

    hello, guys,

    I am use UTF-8 TOO.
    after you login , you can see the correct menu(I mean after translate menu)?

    Mike.G


     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Hello Mike,

    please make sure that your files are named cn.lng, the part before the .lng must be 2 chars long, not longer. If this does not help, you will have to change the files to a specific locale, utf-8 is not tested with ISPConfig and I guess it might cause troubles.
     
  7. Mike.G

    Mike.G New Member

    Hi, Till,
    I had changed all files name from zh-cn to cn.but can't work too.

    I am not sure what's happen.

    but I think it may be not encoding issue.

    let me try to debug .

    thanks

    Mike.G
     
  8. altaibskt

    altaibskt New Member

    Hi there!

    i am new here, and i would love to trans ISPConfig to Arabic, but i do not have any plase to test and i would realy need to test it online because i have to change it from left to right and i need to do some staff with the encoding to fitt the arabic... so how can we fix this

    i have free time about one week from today... may be we can do it...
     
  9. Leszek

    Leszek New Member

    You'd have to install ISPConfig somewhere and edit the hosts file to use a local domain name (/etc/hosts file for Linux).
     
  10. servermonitoring

    servermonitoring New Member

    Great :cool:
     

Share This Page