Transferring Hard Drive to new System

Discussion in 'Installation/Configuration' started by latcarf, Jan 27, 2007.

  1. latcarf

    latcarf New Member

    full circle...

    Okay I tried debian... tried kubuntu... and didn't care for either. :-( So I am back to opensuse 10.2 and I still cannot access php pages.

    I went through the different links and tried the different methods discussed...

    httpd -t = Syntax OK

    apache2 error log
    Code:
    [Sun Feb 18 17:52:28 2007] [notice] Graceful restart requested, doing restart
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:28 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Sun Feb 18 17:52:29 2007] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Sun Feb 18 17:52:29 2007] [warn] long lost child came home! (pid 25354)
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    http://www.howtoforge.com/forums/showpost.php?p=60172&postcount=6 I am not sure where these fields in item 2. are added(?)

    I also tried this http://www.howtoforge.com/forums/showpost.php?p=60049&postcount=6

    I am pretty much stumped... :-(
     
  2. Jorem

    Jorem New Member

    I just read all the posts a bit. Why don't you take CentOS 4.4. I used Suse and Mandrake before and wanted something what worked better. I liked Debian but for some reason not that mutch. I finally worked with CentOS and I like it a lot.

    Just install using the Perfect Setup.

    Install Webmin on it if you need more control:
    wget http://switch.dl.sourceforge.net/sourceforge/webadmin/webmin-1.310-1.noarch.rpm

    rpm -ivh webmin-1.310-1.noarch.rpm

    And just setup the rest of the system using the perfect Perfect Setup :).
     
  3. latcarf

    latcarf New Member

    I am reluctant to try yet another setup... I forgot to mention before I tried Ubuntu also!

    I like opensuse and it seems to have been working fine for me in the past. My problem now is trying to use 10.2 and rendering PHP pages from my sites.

    I noticed in the Apache error log that when I have tried to access PHP pages the error
    Code:
    ... Directory index forbidden by Options directive: /srv/www/htdocs/
    is shown. I think that is telling me that somehow/somewhere a config file is pointing to /srv/www/htdocs/ and I do not believe it should be. I am not experienced enough to even begin knowing which config file to start looking at other than the Apache files.

    I don't think it is in any of the ISPConfig files since the sites I setup were placed where they need to be.

    Thanks again,
    Lance
     
  4. falko

    falko Super Moderator ISPConfig Developer

    That's the usual behaviour on SuSE systems. I guess you haven't created any web sites with ISPConfig yet?
     
  5. latcarf

    latcarf New Member

    I switched from FC to suse sometime back and started with 10.0 and have had no problems until now with 10.2. Yes, I have created 3 sites with ISPConfig.

    I have not loaded any of my pages yet though, using the default ISPConfig html until it is totally setup. I am trying to install Coppermine which is totally php and when I go to the web interface for install; my.domain/coppermine folder/install.php, I get the window that states "You have chosen to open install.php" and gives me a choice of Open with or Save to Disk. So I know it is finding it (php page), it is just not processing it the way it should.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    , and what's in Vhosts_ispconfig.conf?

    Take a look here: http://www.howtoforge.com/forums/showthread.php?t=9778&highlight=suse 10.2 php
     
  7. latcarf

    latcarf New Member

    I had been through that link before...

    Since I think this is related to ISPConfig I started a different thread here http://www.howtoforge.com/forums/showpost.php?p=61487&postcount=7

    I explained my reasoning why I moved it there and why I think it is ISPConfig there also. Meanwhile I have started a clean install of opensuse10.2 and ISPConfig again and will have to wait until I am done to dive you feedback on the runs.
     

Share This Page