Traffic quota exceeded

Discussion in 'Installation/Configuration' started by DaRKNeSS666NL, Sep 24, 2011.

  1. DaRKNeSS666NL

    DaRKNeSS666NL HowtoForge Supporter

    I have a site that's exceeded his quota. If you now go to the url of that site a other site on my server is displaying?

    Is it possible to redirect it to a warning page? Or to just show no site at all. Its a weird configuration in ISPC to just show a other page, even the admin is redirected to the other side. Or did I misconfigurate it my self?
    I have searched the forum and found out there is no such function in ISPC and I have to use vhost, but don't know exactly what to do.

    I can search for a solution ( and the working of vhost) but I thought I ask first here because I am thinking somebody already must have had that same problem.

    TIA
     
  2. falko

    falko Super Moderator

    I've added this to our bugtracker, so we will check that.
     
  3. JeffryL

    JeffryL New Member

    In the meantime you can put an index.html in /var/www. E.g.:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    <head>
        <title>Error</title>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
        <link rel="shortcut icon" href="/favicon.ico" />
        <meta name="robots" content="noindex" />
    	<style type="text/css"><!--
        body {
            color: #444444;
            background-color: #EEEEEE;
            font-family: 'Trebuchet MS', sans-serif;
            font-size: 80%;
        }
        h1 {}
        h2 { font-size: 1.2em; }
        #page{
            background-color: #FFFFFF;
            width: 60%;
            margin: 24px auto;
            padding: 12px;
        }
        #header{
            padding: 6px ;
            text-align: center;
        }
        .header{ background-color: #DF0101; color: #FFFFFF; }
        #content {
            padding: 4px 0 24px 0;
        }
        #footer {
            color: #666666;
            background: #f9f9f9;
            padding: 10px 20px;
            border-top: 5px #efefef solid;
            font-size: 0.8em;
            text-align: center;
        }
        #footer a {
            color: #999999;
        }
        --></style>
    </head>
    <body>
        <div id="page">
            <div id="header" class="header">
                <h1>Oops, you're not supposed to be here!</h1>
            </div>
            <div id="content">
                <h2>This is the default index page of the server</h2>
                <p>You probably ended up here because you directly approached the server, your website is misconfigured or you have exceeded the traffic limits.</p>
                <p>For questions or problems please contact <!--SUPPORT//-->support<!--SUPPORT//-->.</p>
            </div>
            <div id="footer">
                <p>Powered by <a href="http://www.ispconfig.org">ISPConfig</a></p>
            </div>
        </div>
    </body>
    </html>
     
  4. till

    till Super Moderator

    What you describe is the normal behaviour of apache when no default vhost exists. If apache gets a request for a non existing vhost (e.g. because it is disabled) then apache will show the first site on the same Ip address.

    You can add a default site which catcjes these requests by clicking on nwe website in ispconfig and use "000default.tld" as domain name.
     

Share This Page