Trace|track

Discussion in 'Tips/Tricks/Mods' started by jtheed, Mar 9, 2012.

  1. jtheed

    jtheed Member HowtoForge Supporter

    We had a PCI scan done on our server and it says that TRACE and TRACK are enabled. I found several answers on the Web but they do not seem to work. I have TraceEnabled Off in conf.d/security file. I tried adding the following to my Server Directives in ISPCONFIG3
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
    RewriteRule .* - [F]

    but you can still run a Trace. I have stopped and started apache2 and even reboot the box. Still Trace is enabled. I am testing it by using the following from another Linux Box.

    Telnet hostname 80
    TRACE / HTTP/1.0
    Host: hostname
    TestA: Hello
    TestB: World
    enter enter
    and I get a reply from the Server
    Type Apache
    Date Current Date
    Content Type ...
    Content Length etc...

    Is there a different way to make sure this service gets disabled?
     
  2. kwickcut

    kwickcut Member

    this may help u i used this on a machine for a friend i forge wear i found this hope it helps u.

    TRACE is enabled by default in an apache installation. There are two ways to remediate. The first can be used if you are running Apache 1.3.34, 2.0.55, or anything in the 2.2 release. Simply add the TraceEnable directive into your httpd.conf and set the value to Off.

    The second mechanism involves creating a mod_rewrite rule that will disable http methods, which is also quite popular and works with ANY version of apache that supports mod_rewrite. The directives below would need to be set, which are written assuming that this is the first time use for mod_rewrite.

    The first thing to do is make sure that mod_rewrite is loaded. If mod_rewrite.so is missing from your apache configuration but you have it installed, (and your install location is /usr/local/apache), then add the following statement to your httpd.conf:

    LoadModule rewrite_module "/usr/local/apache/modules/mod_rewrite.so"

    Then add the following as well to your httpd.conf file:

    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
    RewriteRule .* - [F]

    Restart apache, re-run the steps in the Validation section, and with either method, you should receive an HTTP 405-Method Not Allowed status code back.
     
  3. jtheed

    jtheed Member HowtoForge Supporter

    Thank you for the quick response, but that's the first article I found and it did not work for me.
     

Share This Page