TPS - Ubuntu 6.06 LTS Server - network configuration problem

Discussion in 'HOWTO-Related Questions' started by wctaelectronics, Apr 30, 2008.

  1. wctaelectronics

    wctaelectronics New Member


    I am pretty new to Ubuntu but am learning quite a bit. I am trying to set up a server to allow me to host a few different sites that I have for myself. I decided to use the HowTo: The Perfect Setup - Ubuntu 6.06 LTS Server

    Here is my problem:

    Everything works great all through the istallation and initial set up until I get to page 3 - step 5, Configure The Network

    This appears to be designed for a server that is connected directly to the modem using a static IP.

    Now, I do have a static IP but I am using a router so I can access the internet from several other computers in my home. So I have my router configured with the static IP and it then is set up to forward the necessary ports on to the server via the DHCP network.

    So... What would be different for me to be able to set up this system under these circumstances?

    OR is there a different HowTo that I should use for this setup?

    Thank you all in advance for any help you can offer.
  2. falko

    falko Super Moderator ISPConfig Developer

    No, it'S for a server behind a router, like in your setup. I guess you're using a different subnet or gateway.

    When your server is using DHCP, can you post the outputs of
    route -nee
  3. wctaelectronics

    wctaelectronics New Member

    Thank you so much for your willingness to help!

    Here is the information you wanted to see:

    This is what I get when I run ifconfig:
    eth0      Link encap:Ethernet  HWaddr 00:04:5A:5C:54:D5
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::204:5aff:fe5c:54d5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:123186 errors:0 dropped:0 overruns:0 frame:0
              TX packets:15945 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:9844588 (9.3 MiB)  TX bytes:2635114 (2.5 MiB)
              Interrupt:11 Base address:0x1400
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    and this is what I get when I run route -nee:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt   U     0      0        0 eth0     0     0      0         UG    0      0        0 eth0     0     0      0
    Thanks again for your help!
  4. falko

    falko Super Moderator ISPConfig Developer

    This means you must use IP addresses of the 192.168.2.x subnet instead of the 192.168.0.x subnet that I use in the tutorial (e.g. as the server's IP address, as the gateway, etc.).
  5. wctaelectronics

    wctaelectronics New Member

    OK that part works now. I was confused by the "static" part, I thought I was supposed to use my actual static IP address, but when I did I lost all connection to the server.

    But now this is working and I'm on to the next problem:

    I opened up the /etc/hosts file and edited it as you directed. This is what it looks like now:
    Code:       localhost.localdomain localhost wctaserver
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    But when I run hostname I get wctaserver and when I run hostname -f I get
    According to your instructions I should be getting for both.

    This brings up another question. I do not have a domain name yet for this server. (I intend to register one once I get this all figured out) Does this cause a problem? I have simply been using my IP address to connect to it.

    I really appreciate you taking all this time to help me, I can see that you are in high demand around here.

    I hope that I am not making a nuisance of myself, and if I am I apologize!

    Anyway, thanks again!
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    echo > /etc/hostname
    /etc/init.d/ start
    and try again.

    No, that's no problem. :)
  7. wctaelectronics

    wctaelectronics New Member

    Thank you very much Falko,

    I now have my server up and running with ISPConfig loaded on it and am starting into the process of learning how to use it properly!

    I know my journey has just begun! :D

    Thanks again for your help and for the great How To you wrote!

Share This Page