top command memory

Discussion in 'Kernel Questions' started by terryoleary1981, Oct 20, 2008.

  1. terryoleary1981

    terryoleary1981 New Member

    Hi all,

    I've got a test server running with ISPconfig and I've had a few people testing a website concurrently. The server isnt the best in the world but i've noticed it to almost collapse with just 3 or 4 people online. When I run the top command I get the following output:

    Code:
    [root@mail ~]# top
    top - 19:48:19 up 4 days,  5:29,  2 users,  load average: 3.29, 3.52, 3.63
    Tasks: 142 total,   3 running, 137 sleeping,   1 stopped,   1 zombie
    Cpu(s): 95.7%us,  3.7%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.7%si,  0.0%st
    Mem:    515172k total,   432876k used,    82296k free,    35284k buffers
    Swap:  1048568k total,    78752k used,   969816k free,   210468k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
     3374 gdm       20   0 75308 5988 3224 R 48.5  1.2   3350:32 gdmgreeter
    20947 apache    20   0 40868  13m 3692 S  5.6  2.7   1:55.42 httpd
    24694 apache    20   0 42920  14m 3300 S  5.0  3.0   0:16.04 httpd
    18457 apache    20   0 42900  15m 3684 R  3.7  3.0   1:51.94 httpd
    14214 apache    20   0 42436  15m 3652 S  3.0  3.0   0:43.03 httpd
    16953 apache    20   0 42900  15m 3660 S  2.7  3.0   1:54.01 httpd
    18496 apache    20   0 43520  16m 3804 S  2.7  3.2   1:53.51 httpd
    19826 apache    20   0 41360  13m 3500 S  2.7  2.8   0:28.16 httpd
    19840 apache    20   0 41360  13m 3604 S  2.7  2.8   0:28.92 httpd
    19926 apache    20   0 42900  15m 3628 S  2.7  3.0   1:50.13 httpd
    19960 apache    20   0 43156  15m 3708 S  2.7  3.1   1:47.57 httpd
    20984 apache    20   0 43448  15m 3392 S  2.7  3.1   0:24.72 httpd
    
    Apart for the CPU usage being high I dont understand the Mem information. My server has at least 256MB RAM installed, but by my calculation the total mem figure only comes to about 62-64MB? Have i set something incorrectly here?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    It seems your server is swapping a lot:

    Code:
    Swap:  1048568k total,    [B][COLOR="Red"]78752k used[/COLOR][/B],   969816k free,   210468k cached
     
  3. terryoleary1981

    terryoleary1981 New Member

    is that a bad thing? Like i said its only a webserver...... one other thing i've noticed is the gdm is using a lot of CPU, and i'm wondeirng if i need to have it running, i'm only accessing the server through putty, i've tried to terminate the process but it keeps restarting.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, because a hard drive is much slower than RAM. Therefore swapping slows down your server.

    Please uninstall the desktop.
     
  5. terryoleary1981

    terryoleary1981 New Member

    is there a straightforward command to uninstall gdm in fedora?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Not sure. You could search for GNOME or KDE packages like this:
    Code:
    yum search gnome
    yum search kde
    Instead of removing the desktop, you could disable it at startup. What's the output of
    Code:
    chkconfig --list
    ?
     
  7. martien

    martien New Member

    Lol, Lol, Lol... You don't have to uninstall gdm!!! You can stop it and if you don't need it and then activate it again. Just type
    Code:
    service gdm stop
    and remove gdm using chkconfig. When you need gdm then just type startx and everything shoud works. It's not necessary to uninstall the graphic manager if you have enough space. Why you are killing it?
    But it's also bad to have a lot of swap used, cause using your disk drive for swap is making it wears out.
    Edit: If you still want to uninstall it use:
    Code:
    yum remove gnome-desktop
    @falko, gdm is short for gnome desktop manager, for kde its called kdm
     
    Last edited: Nov 2, 2008
  8. Leszek

    Leszek New Member

    Fedora also has a nice setup script where You can easilly configure deamons started with the system. Execute the command "setup" and a text menu will appear. You'll have to look around and find the right submenu as I don't use Fedora and simply don't remember.
     

Share This Page