too many apache processes

Discussion in 'General' started by Jorem, Oct 9, 2012.

  1. Jorem

    Jorem New Member

    I have a problem on 2 new low load (only 1 testsite per server) Ubuntu 12.04 servers (Perfect Server Setup). After a few days I get a max clients error and after that Apache crashes.

    My current settings:
    <IfModule mpm_prefork_module>
    StartServers 3
    MinSpareServers 3
    MaxSpareServers 10
    MaxClients 150
    MaxRequestsPerChild 3000
    </IfModule>

    When I have higher settings here Apache crashes after a day.

    The rest of the system is fully responsive. After the crash I checked the running processes and I see a lot of "/usr/sbin/apache2 -k start" lines.

    It looks like the processes are not closed/terminated and endless processes are created.

    Can that be the cause for the Apache crash? What can I do about it?
     
  2. till

    till Super Moderator

    This can be related to a bug in vlogger that occurs only on Ubuntu 12.04. Update ISPConfig to version 3.0.4.6 to fix that.
     
  3. Jorem

    Jorem New Member

    I have the latest version on the server. Can I change vlogger by hand?
     
  4. till

    till Super Moderator

    If you have the latest version and have choosen to reconfigure services on update, then vlogger is already changed. Please post the file /etc/apache2/sites-enabled/000-ispconfig.conf so that I can check if the config has been changed correctly.
     
  5. Jorem

    Jorem New Member

    this is my config:

    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig

    <Directory /var/www/clients>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Do not allow access to the root file system of the server for security reasons
    <Directory />
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/conf>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    # Except of the following directories that contain website scripts
    <Directory /usr/share/phpmyadmin>
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/share/phpMyAdmin>
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /usr/share/squirrelmail>
    Order allow,deny
    Allow from all
    </Directory>

    # allow path to awstats and alias for awstats icons
    <Directory /usr/share/awstats>
    Order allow,deny
    Allow from all
    </Directory>

    Alias /awstats-icon "/usr/share/awstats/icon"

    *Removed the last 2 lines with the ip.
     
  6. till

    till Super Moderator

    Ok, seems as if you have not reconfigured services during update which caused that your configuration files were not be fixed. Chaneg the custm log line to:

    Code:
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/ispconfig/httpd" combined_ispconfig

    and restart apache.
     
  7. Jorem

    Jorem New Member

    I checked another server of a friend of mine who updated from 5 to 6 also, and on his server the line was changed after the update. I must have done something wrong during update. Changed the files by hand now like you advised.

    Thanks for your help Till.
     

Share This Page