Timing out when accessing control panel on 8080

Discussion in 'Installation/Configuration' started by Spawnsworth, Jun 8, 2018.

  1. Spawnsworth

    Spawnsworth Member

    Hi all,
    I've spent an awful lot of time tryin to get to the bottom of this. Basically my ISP Config panel has become pretty much constantly unavailable.

    When I hit the control panel URL at https://XX.XX.XX.XX:8080 I will just see the 'loading' icon in my browser. This continues until it eventually times out. I try some random sites on the server and they appear to be working. 100% certain that port 8080 is open.

    If I reboot the server then I can get to the control panel OK for about a minute. I have also tried disabling the *server.sh cron. Still the same problem.

    I have done an apt-get update && apt-get upgrade -y on this Ubuntu 16.04 server as well as updating ISP Config to the latest version so everything is bang up to date.

    I have had some strange problems with mariadb. Sometimes my root password will work and sometimes it won't. From all my efforts so far I think something is messed up with mariadb that is the problem. When I start or stop it using /etc/init.d/mysql start/stop it tends to hang and I don't trust it tbh. It's the latest mariadb 10.3.

    I also get a lot of the following errors but these seemed to have stopped for now:

    PHP Warning: mysqli_connect(): (HY000/2002): No such file or directory in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 246, referer: https://XX.XX.XX.XX:8080/login/


    Can anyone point me in the right direction here? THis wil a fully working server and I don't know what exactly has changed to cause the timeout issues. They are a real pain!

    Thanks
     
  2. Taleman

    Taleman Active Member HowtoForge Supporter

    Install the package mysqli_connect() comes in. It is php*mysql something. Maybe check /var/log/dpkg.log to see which pagkages have been removed, is this host was OK previously maybe something needed got removed.
     

Share This Page