Timeout When Attempting To Login

Discussion in 'Installation/Configuration' started by Zynismus, Jul 3, 2010.

  1. Zynismus

    Zynismus New Member

    I have just completed the install of ISPConfig 3. The only error I received during installation was from AMaViS. Error as follows:
    Code:
    hostname: Name or service not known
      The value of variable $myhostname is "", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's 
      network name!
    
    It seems to be that this error was due to my DNS settings having not yet propagated. These settings are now complete and propagated throughout the DNS system. However, I am unable to access the admin panel.

    When I attempt to visit the admin panel, it simply times out. I have absolutely no idea how to go about fixing this problem. Any help will be appreciate and please do not hesitate to ask for any additional information.

    iptables -L output:
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh 
    ACCEPT     all  --  anywhere             anywhere            
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ssh 
    ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:www 
    DROP       all  --  anywhere             anywhere            
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination         
    RETURN     all  --  anywhere             anywhere   
    Content of /etc/hosts (sanitized, but can be posted if needed):
    Code:
    127.0.0.1       localhost.localdomain   localhost
    123.123.123.123  servername.domain.TLD  servername
    
    My server's name is "Name" (with an uppercase "N").
    I am using Ubuntu 10.04 and have updated everything to the most recent versions (as of the time of this post).
     
    Last edited: Jul 3, 2010
  2. Zynismus

    Zynismus New Member

    Contents of ispconfig.vhost

    Code:
    user@domain:/etc/apache2/sites-available$ sudo vi ispconfig.vhost
    
    
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin webmaster@localhost
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
     
    Last edited: Jul 3, 2010
  3. Zynismus

    Zynismus New Member

    Contents of default

    Code:
    user@domain:/etc/apache2/sites-available$ sudo vi default
    
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
     
  4. Zynismus

    Zynismus New Member

    Contents of ispconfig.conf

    Code:
    user@domain:/etc/apache2/sites-enabled$ sudo vi 000-ispconfig.conf
    
    
    
    ################################################
    # ISPConfig Logfile configuration for vlogger
    ################################################
    
    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig
    
    <Directory /var/www/clients>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    # Do not allow access to the root file system of the server for security reasons
    <Directory />
           AllowOverride None
           Order Deny,Allow
           Deny from all
    </Directory>
    
    # Except of the following directories that contain website scripts
    <Directory /usr/share/phpmyadmin>
            Order allow,deny
            Allow from all
    </Directory>
    
    <Directory /usr/share/phpMyAdmin>
            Order allow,deny
            Allow from all
    </Directory>
    
    <Directory /usr/share/squirrelmail>
            Order allow,deny
            Allow from all
    </Directory>
    
     
  5. Zynismus

    Zynismus New Member

    Update

    Pointing the default site in /sites-available/ to the directory in which ISPConfig 3 is installed resulted in access to the admin panel. I am still unable to get access to the admin panel when the main site is active and the port is 8080.
     
: admin, hosts, timeout

Share This Page