Thunderbird email hot links to FireFox NOT working

Discussion in 'Desktop Operation' started by Owen_Townsend, Aug 23, 2008.

  1. Owen_Townsend

    Owen_Townsend New Member

    Thunderbird email hot links to FireFox NOT working
    Hope you can help with this since I cant get an answer on
    the GNU Thunderbird Forum. Somebody said create user.js &
    add following lines w location & name of firefox browser
    BUT it still does not work ?

    user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
    user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
    user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You mean when you click on a link in an email?
    What exactly is the problem? Does Firefox not start? Does it start, but not show the page? Do you see any errors in Firefox then?
     
  3. Owen_Townsend

    Owen_Townsend New Member

    thunderbird email hot links not working

    If I left click on a url link (within email text) - nothing happens
    If I right click a URL - I get a pop up menu & can 'copy' the url link
    - then switch to another window & paste the url (not as handy as a left click)
    If I click on an email adrs within email text - it does open a write email window

    As advised earlier I did add following line (+ https + ftp) to user.js
    user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
    I just now confirmed that I see these results as 'user set'
    when I check via --> edit preferences --> general --> config editor

    Other people using thunderbird on redhat say hot links work for them
    Is my problem related to fact I am running thunderbird on RHEL 5.2
    on 64 bit AMD Opteron - vs 32 bit versions ???

    Thanks for looking at this, Owen
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You are using a 32bit Thunderbird on a 64bit OS?

    Does /usr/bin/firefox exist?
     
  5. Owen_Townsend

    Owen_Townsend New Member

    thunderbird email hot links not working

    Yes /usr/bin/firefox exists
    --> which firefox --> /usr/bin/firefox

    Do you think it matters if I run 32 bit Thunderbird on my 64 bit AMD Opteron
    (other 32 bit programs work OK)
    I installed Thunderbird via --> yum install thunderbird
    How do I install the 64 bit version ?
    Should I remove 32 bit version 1st ?
    - removing would probably remove my adds to user.js
    & redirect mail directory to a file system with more space than /root
    - But I could redo those changes if I have to

    Owen
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I think yum should've automatically installed the 64bit version. Are you absolutely sure it's the 32bit version?
     
  7. Owen_Townsend

    Owen_Townsend New Member

    hot links not working

    Falko - Thunderbird is 64 bit
    which thunderbird --> /usr/bin/thunderbird (shell script)
    the shell script executes /usr/lib64/thunderbird-1.5.0.12/thunderbird-bin
    in lib64 & file ... confirms 64 bit

    I think the confusion re 32/64 bit came from me asking if my problem had
    anything to do with the fact that I was running on a 64 bit RHEL 5.1
    whereas my son & many others do not have the problem on 32 bit systems
    OR fact that I had to add thunderbird to my RHEL with yum install
    whereas thunderbird came with fedora ???

    Thanks, Owen
     
  8. falko

    falko Super Moderator ISPConfig Developer

    I don't know where the problem comes from, but I'd try to uninstall Thunderbird and install it again afterwards.
     

Share This Page