This site can’t be reached

Discussion in 'Installation/Configuration' started by Faique, Aug 10, 2018 at 4:04 PM.

  1. Faique

    Faique New Member

    I have this refused to connect issue now, after having first run updates for ISPConfig then trying to install SSL Certificates.
    I have since deleted the SSL files in the web folder, but that didnt fix it.
    Now I'm trying to restore the backups that the Update created, problem is I've noticed that the folders in /usr/local/ispconfig have ispconfig as owner or group so how do I then replace those files?
     
  2. Taleman

    Taleman Active Member HowtoForge Supporter

    Those files should be owned by root or ispconfig. do not change owners, group owners or permissions.
    If you want to restore the backup, the backed up files have the correct owners and permissions, unless they were messed up before the backup. Restore them, as root so the permissions and owners are preserved, and to the correct directory.
    Something like
    Code:
    cd /
    tar xzf /var/backup/ispconfig_hostname.something.tld_<date>/ispconfig_software.tar.gz
    If this did not help, I have misunderstood your question, sorry for that.
     
  3. Faique

    Faique New Member

    I think you have understood correctly, but this is what I have done in the meantime, which I fear contradicts your advise:
    1. unziped the backup file
    2. downloaded it to my local drive.
    3. added my user to the group ispconfig (Because I can't use FTP as root)
    4. changed permission on the 3 folders in /usr/local/ispconfig to 770 (so that group has write permission)
    5. uploaded and overwrote the folders in /usr/local/ispconfig with the back up folders
    And that's as far as I've gotten, still busy transferring, so don't know if it will work yet.
     
  4. Faique

    Faique New Member

    ok, so that didn't work, problem still persists, how do I restore the database dump file?, would that help?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    A guess that neither a restore of ISPConfig nor of the database will help here as neither ISPConfig nor the database is damaged. Please explain what exactly did you do with these ssl certs as that's what needs to be undone to fix the issue and which exact error you get when you do what.
     
  6. Faique

    Faique New Member

    As far as I can recall I did the following:
    1.So during the update I redid the SSL promted questions.
    2. I followed this tutorial https://www.howtoforge.com/tutorial/securing-ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/ up unti the command for postfix then abandoned it.
    3.I then also went into one of the sites and activated SSL and went to the SSL section and filled the details, keys, request and certificate fields with info from SSL section in Cpanel of the same domain on my old server. Then a chose the action create certificate and action-ed it.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, and now none of the sites and also the ispconfig UI is not reachable in the browser?
     
  8. Faique

    Faique New Member

    Yes, I'm trying to send you my Apache2 error log, there seems to be a lot of errors in there, but its too long to paste here and the upload file doesn't find it
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use? If it's Ubuntu or Debian, then the websites are enabled by a symlink in the folder

    /etc/apache2/sites-enabled/

    Delete the symlink (it contains the domain name) of the website where you enabled SSL for in that folder and restart apache. Then try if you can access ispconfig now.
     
  10. Faique

    Faique New Member

    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 411.
    [Fri Aug 10 12:19:08.050650 2018] [mpm_prefork:notice] [pid 9420] AH00169: caught SIGTERM, shutting down
    [Fri Aug 10 12:19:09.222101 2018] [ssl:warn] [pid 19986] AH01906: tribe1.tribalcs.co.za:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Aug 10 12:19:09.222224 2018] [ssl:warn] [pid 19986] AH01909: tribe1.tribalcs.co.za:8080:0 server certificate does NOT include an ID which matches the server name
    [Fri Aug 10 12:19:09.222450 2018] [ssl:error] [pid 19986] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=Tribal CS,OU=Tribe1,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / issuer: [email protected],CN=Tribal CS,OU=Tribe1,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / serial: E0DDA2BA39FC3D32 / notbefore: Aug 6 15:36:55 2018 GMT / notafter: Aug 3 15:36:55 2028 GMT]
    [Fri Aug 10 12:19:09.222471 2018] [ssl:error] [pid 19986] AH02604: Unable to configure certificate tribe1.tribalcs.co.za:8080:0 for stapling
    [Fri Aug 10 12:19:09.222520 2018] [suexec:notice] [pid 19986] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Aug 10 12:19:09.260446 2018] [:notice] [pid 19992] FastCGI: process manager initialized (pid 19992)
    [Fri Aug 10 12:19:09.359498 2018] [:error] [pid 19988] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Fri Aug 10 12:19:09.359704 2018] [:error] [pid 19988] python_init: Python executable found '/usr/bin/python'.
    [Fri Aug 10 12:19:09.359730 2018] [:error] [pid 19988] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Fri Aug 10 12:19:09.359803 2018] [:notice] [pid 19988] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Fri Aug 10 12:19:09.359822 2018] [:notice] [pid 19988] mod_python: using mutex_directory /tmp
    [Fri Aug 10 12:19:09.389498 2018] [ssl:warn] [pid 19988] AH01906: tribe1.tribalcs.co.za:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Aug 10 12:19:09.389550 2018] [ssl:warn] [pid 19988] AH01909: tribe1.tribalcs.co.za:8080:0 server certificate does NOT include an ID which matches the server name
    [Fri Aug 10 12:19:09.389789 2018] [ssl:error] [pid 19988] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=Tribal CS,OU=Tribe1,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / issuer: [email protected],CN=Tribal CS,OU=Tribe1,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / serial: E0DDA2BA39FC3D32 / notbefore: Aug 6 15:36:55 2018 GMT / notafter: Aug 3 15:36:55 2028 GMT]
    [Fri Aug 10 12:19:09.389812 2018] [ssl:error] [pid 19988] AH02604: Unable to configure certificate tribe1.tribalcs.co.za:8080:0 for stapling
    [Fri Aug 10 12:19:09.397328 2018] [mpm_prefork:notice] [pid 19988] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Fri Aug 10 12:19:09.397422 2018] [core:notice] [pid 19988] AH00094: Command line: '/usr/sbin/apache2'
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 3.
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 15.
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 16.
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 17.
    [Fri Aug 10 12:25:28.625227 2018] [fcgid:warn] [pid 19994] [client 105.228.128.82:64469] mod_fcgid: stderr: PHP Warning: mysqli_connect(): (HY000/2002): No such file or directory in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 78, referer: https://196.41.127.180:8080/index.php
    [Fri Aug 10 12:25:28.625298 2018] [fcgid:warn] [pid 19994] [client 105.228.128.82:64469] mod_fcgid: stderr: PHP Warning: mysqli_connect(): (HY000/2002): No such file or directory in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 84, referer: https://196.41.127.180:8080/index.php
    [Fri Aug 10 12:25:28.625312 2018] [fcgid:warn] [pid 19994] [client 105.228.128.82:64469] mod_fcgid: stderr: PHP Warning: mysqli_connect(): (HY000/2002): No such file or directory in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 84, referer: https://196.41.127.180:8080/index.php
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 19.
    [Fri Aug 10 12:25:42.402168 2018] [mpm_prefork:notice] [pid 19988] AH00169: caught SIGTERM, shutting down
    [Fri Aug 10 12:25:44.119430 2018] [ssl:warn] [pid 21928] AH01906: tribe1.tribalcs.co.za:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Aug 10 12:25:44.119532 2018] [ssl:warn] [pid 21928] AH01909: tribe1.tribalcs.co.za:8080:0 server certificate does NOT include an ID which matches the server name
    [Fri Aug 10 12:25:44.119794 2018] [ssl:error] [pid 21928] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=Tribal CS,OU=Tribal CS tribe1\\ ,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / issuer: [email protected],CN=Tribal CS,OU=Tribal CS tribe1\\ ,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / serial: 8F7F6BD15ED5276D / notbefore: Aug 10 10:25:10 2018 GMT / notafter: Aug 7 10:25:10 2028 GMT]
    [Fri Aug 10 12:25:44.119814 2018] [ssl:error] [pid 21928] AH02604: Unable to configure certificate tribe1.tribalcs.co.za:8080:0 for stapling
    [Fri Aug 10 12:25:44.119855 2018] [suexec:notice] [pid 21928] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Aug 10 12:25:44.155288 2018] [:notice] [pid 21933] FastCGI: process manager initialized (pid 21933)
    [Fri Aug 10 12:25:44.398409 2018] [:error] [pid 21930] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Fri Aug 10 12:25:44.398733 2018] [:error] [pid 21930] python_init: Python executable found '/usr/bin/python'.
    [Fri Aug 10 12:25:44.398749 2018] [:error] [pid 21930] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Fri Aug 10 12:25:44.399327 2018] [:notice] [pid 21930] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Fri Aug 10 12:25:44.399343 2018] [:notice] [pid 21930] mod_python: using mutex_directory /tmp
    [Fri Aug 10 12:25:44.511731 2018] [ssl:warn] [pid 21930] AH01906: tribe1.tribalcs.co.za:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Aug 10 12:25:44.511778 2018] [ssl:warn] [pid 21930] AH01909: tribe1.tribalcs.co.za:8080:0 server certificate does NOT include an ID which matches the server name
    [Fri Aug 10 12:25:44.512007 2018] [ssl:error] [pid 21930] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=Tribal CS,OU=Tribal CS tribe1\\ ,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / issuer: [email protected],CN=Tribal CS,OU=Tribal CS tribe1\\ ,O=Tribal CS,L=Meyerton,ST=Gauteng,C=ZA / serial: 8F7F6BD15ED5276D / notbefore: Aug 10 10:25:10 2018 GMT / notafter: Aug 7 10:25:10 2028 GMT]
    [Fri Aug 10 12:25:44.512026 2018] [ssl:error] [pid 21930] AH02604: Unable to configure certificate tribe1.tribalcs.co.za:8080:0 for stapling
    [Fri Aug 10 12:25:44.520278 2018] [mpm_prefork:notice] [pid 21930] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Fri Aug 10 12:25:44.520333 2018] [core:notice] [pid 21930] AH00094: Command line: '/usr/sbin/apache2'

    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 1. - ****THIS REPEATS MANY TIMES BUT I DELETED THEM TO MAKE SPACE****

    [Fri Aug 10 13:11:03.234080 2018] [mpm_prefork:notice] [pid 21930] AH00169: caught SIGTERM, shutting down
    [/CODE]
     
  11. Faique

    Faique New Member

    Ho do I
    Do I delete the symlink or follow symlink and delete target directory contents, I keep getting a 'no such file or directory' when I try and delete it
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    That error not relevant for your issue.

    Did you change something in the PHP config too? I wonder why you get these mysqli errors.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    you delete the symlink
     
  14. Faique

    Faique New Member

    So I think Its deleted, but I'm getting an error trying to restart apache:'
    sudo service apache2 restart
    Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.
     
  15. Faique

    Faique New Member

    I dont think so, no
     
  16. Faique

    Faique New Member

    So I fully removed the apache2 config files, sudo apt-get purge apache2
    and then reinstalled it in the usual way, sudo apt-get install apache2
    I then restarted Apache but still no luck
     
  17. Taleman

    Taleman Active Member HowtoForge Supporter

    Can you get shell access to you host?
    If not, can you switch to a new service provider that gives shell access?
     
  18. Faique

    Faique New Member

    I do have Shell Access, I have access as a sudo user, why?
     
  19. Taleman

    Taleman Active Member HowtoForge Supporter

    I read in #3 you used FTP to transfer the backup you restored. If you have shell access, why not just untar the backup? If you use FTP it may change file owners and permissions.
    I suggest starting over once again, and this time really, really NOT change file owners or permissions.
    If there are problems, they can be fixed.
     
  20. Faique

    Faique New Member

    I get your point, but what I don't get is that it was broken before I did that, I did that as part of the troubleshooting. Starting again can't be the only solution, I have 4 sites, users, databases, dns, ftp, etc set up already, that's a lot of work to redo everything again. Is there nothing else I could try?
     

Share This Page