This is %#@*&^$# embarrassing!

Discussion in 'Smalltalk' started by domino, Aug 21, 2005.

  1. domino

    domino New Member

    I ran a whois on all my 10 TLD's and this is what I got:

    Blacklist Status: Listed - Cached Today

    Now I know it wasn't my fault. My ISP was placed on the Blacklist :mad:. Looks like there's no way around this problem. Damn, no business sites until I get a dediacted IP and not in the same ISP.
     
  2. till

    till Super Moderator

    Thats very bad! :mad:

    Did only your dynamic IP got blacklisted or the mailserver of your ISP too? If it is only your dynamic IP, have you tried to configure postfix to route all outgoing mail trough the mailserver of your ISP?
     
  3. falko

    falko Super Moderator

    You could contact the blacklist maintainers and ask them to take you off the blacklist.
     
  4. domino

    domino New Member

    Well, I don't know how the blacklist proccess is. But ALL my domains are listed as blacklist. So I think my ISP's whole IP thing has been blacklisted. I ran a relay test on this server and there was no problem and my server does not relay.
     
  5. falko

    falko Super Moderator

    Where are they listed? On which blacklist?
     
  6. domino

    domino New Member

    When I run the queries on whois.sc, this is exactly what is outputted:


    Date Data: 2005-08-21
    Source: DNSBL.SORBS.NET
    Answer: 127.0.0.* DUL
    Information: http://www.dnsbl.us.sorbs.net/lookup.shtml

    It is against our policy to use any automation on our site, even though you have silver access. You may not run robots against our site. Any such use will be grounds for termination.
     
    Last edited: Aug 21, 2005
  7. till

    till Super Moderator

  8. domino

    domino New Member

    Tanks for pointing till. This is the only reason why my IP would be listed.

    Dynamic User/Host List Database (DUHL)

    Listing is performed manually after contact from netizens or ISPs indicating dynamically assigned space, or whenever SORBS admins notice the same, for example by receiving spam from such an address range.

    Note: This list should not list static address space, not even dialups. This is for any dynamically assigned space regardless of the method of connecting them to the Internet.

    And if this is the case, while the IP is listed in the blacklist db, mail might not arrive to it's destination because some email servers use sorbs.net blacklist db? I can't contact and complain to my ISP since I am on a residential account and not allowed to run any type of server :mad:. I guess i'll have to live with this until I upgrade. Which is another 4 months to the end of my contract. :rolleyes:
     
  9. falko

    falko Super Moderator

    From http://www.dnsbl.us.sorbs.net/faq/:

    Their mail sending form is here: http://www.dnsbl.us.sorbs.net/cgi-bin/mail
     
  10. domino

    domino New Member

    I'm afraid that will be a losing battle, but i'll try. My IP changes at least every 2 days. Another thing to consider is that other scums/clients with my ISP do spam, adding the block to be blacklisted again. Correct me if i'm wrong, but I think the only solution is to purchase a dedicated IP. So if it happens again, I can email them with the static IP.
     
  11. till

    till Super Moderator

    Have you thought about my solution posted above? Normally every DSL Provider has Mailservers that can be used as mailrelay from the clients. Why not configure your postfix to send all outgoing email trough this mailserver from your DSL Provider?
     
  12. domino

    domino New Member

    Actually I didn't think about it but if it will resolve this embarrassment, I can try it. I'm in Webmin now under Postfix Configuration --> General Options. There is a setting: What domain to use in outbound mail. I would enter my ISP mail server there?

    And also there is another setting in the Other General Options. it is labled: Send outgoing mail via host I would again enter my ISP mail server there?
     
  13. till

    till Super Moderator

    I think this setting will rewrite your outgoing email adresses, better leave it blank.

    Yes this looks like the right option, enter the relayserver of your provider here. Sorry, I'am not very familar with webmin :)
     
  14. domino

    domino New Member

    That's okay. Most real admins don't need webmin and I have heard horror stories about newbies using webmin and tashing there box :).

    I still don't understand how this will remove the IP address from the blacklist database though. I mean, once I use my ISP's smtp for outbound, will the IP be removed from the blacklist database?
     
  15. till

    till Super Moderator

    This will not remove your IP from the blacklist, but this is not nescessary any more because the IP of the mailserver of your provider is not blacklisted.
     
  16. domino

    domino New Member

    Ahh! I get it now. By using my ISP's smtp server, the mail server receiving my mail will not see it as blacklisted. Just a work around so ALL emails that originate from my domains are received. I just hope my friends dont tease me or stone me by running a whois on there domains and foinding out that the domains are blacklisted :D. I really hope only the IP address are blacklisted, and NOT the domain as well. As it is very hard to remove yourself from the database. Especially from sorbs.net
     
    Last edited: Aug 22, 2005
  17. domino

    domino New Member

    I have a bit of bad news :(

    I did another test and configured my email client (outook) to send thruogh my ISP smtp server and it works.
     
  18. falko

    falko Super Moderator

    You could also directly edit /etc/postfix/main.cf. Insert these lines:
    Code:
    relayhost = smtp.yourisp.com
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    Then create /etc/postfix/sasl_passwd with a line like this in it:
    Code:
    smtp.yourisp.com   smtp_user:smtp_password
    Afterwards do this:
    Code:
    chown root:root /etc/postfix/sasl_passwd
    chmod 600 /etc/postfix/sasl_passwd
    postmap /etc/postfix/sasl_passwd
    /etc/init.d/postfix restart
     
  19. domino

    domino New Member

    As for my ISP, they dont require a username and password. so creating a sasl_passwd isn't neccessary. However they dont allow relaying my from linux.domain.com server :(. Looks like i'll have to go back to direct send and hope people receive messages originating from my server.

    I haven't had any problems directly sending to gmail or yahoo, but I bet there are other servers out there that will label my emails as SPAM.
     
  20. DaRKNeSS666NL

    DaRKNeSS666NL HowtoForge Supporter

    I have the same problem If I am sending mail to some. I get the mesage that I am on a blacklist. It's a whole range of ip adresses from my isp.
    Going to try to get un listed.
    But for that to happen going to use my isp smtp server. I have some questions thoug.

    1 must I use smtp.myispdomain.nl or must I use the server, that I also have setup in outlook like netmail.myisp.nl?

    And if I send with my isp server witch mail address will the receiver see?
    The one I made in ISPConfig or the One I have with my ISP?

    TIA DaRKNeSS
     

Share This Page