There is no 'www' subdomain for domain.tld

Discussion in 'Installation/Configuration' started by 2ndmouse, Aug 19, 2007.

  1. 2ndmouse

    2ndmouse New Member

    Hi all

    After creating my web site in ISPConfig and setting up dns, I get the following, from internal and external browser:

    http to IP address goes to ispconfig's 'shared IP' page (this is correct, I think), so does http://domain.tld (this is not correct). However, http://www.domain.tld goes, correctly to the web site index page.

    When I check domain.tld using pingability.com's quick DNS check, it now returns no errors or warnings, but states "There is no 'www' subdomain for domain.tld" - I'm not sure how to correct this problem. I've tried creating a co-domain, but that makes no difference.

    Thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add a co-domain domain.tld with empty hostname to the website www.domain.tld
     
  3. 2ndmouse

    2ndmouse New Member

    Thanks, but I already have that co-domain in place: image attached
     

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    No, you have www.heffernans.net, but you must also add heffernans.net (without www)...
     
  5. 2ndmouse

    2ndmouse New Member

    I now have 'heffernans.net' and 'www.heffernans.net' as co-domains, but It hasn't made any difference. When I test heffernans.net, it still shows "There is no 'www' subdomain for heffernans.net".

    My co-domain setup now looks like the attached:
     

    Attached Files:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the co-domain www.heffernans.net ansd post a screenshot of the basis tab of this website.
     
  7. 2ndmouse

    2ndmouse New Member

    Co-domain deleted - Hope this is enough info - restrictions on image size prevents me from uploading the whole page:

    attached
     

    Attached Files:

  8. t-mug

    t-mug New Member

    Hi 2ndmouse,

    an IP address for a public website has to be public also. You're using a private one.
     
  9. 2ndmouse

    2ndmouse New Member

    Thanks T-mug, however, as you can see from the image below, I have the option of private and public in the drop-down menu. I've tried both configurations. Neither option makes any difference.

    Regards
     

    Attached Files:

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The internal IP address is correct if you are in a nAT enviroment behind a router.

    Does www.heffernans.net has an DNS A-Record that points to the external IP address of your router or is www.heffernans.net some kind of redirect?
     
  11. 2ndmouse

    2ndmouse New Member

    Yes I am in a nAT enviroment behind a router. My A records are as follows:
     

    Attached Files:

    • ns1.jpg
      ns1.jpg
      File size:
      27.6 KB
      Views:
      102
  12. falko

    falko Super Moderator ISPConfig Developer

    As far as I can see, there are no A records for neither heffernans.net nor www.heffernans.net:

    Code:
    server1:~# dig www.heffernans.net
    
    ; <<>> DiG 9.3.4 <<>> www.heffernans.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 36055
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.heffernans.net.            IN      A
    
    ;; Query time: 291 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Tue Aug 21 16:10:20 2007
    ;; MSG SIZE  rcvd: 36
    
    server1:~# dig heffernans.net
    
    ; <<>> DiG 9.3.4 <<>> heffernans.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 21114
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;heffernans.net.                        IN      A
    
    ;; Query time: 133 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Tue Aug 21 16:10:25 2007
    ;; MSG SIZE  rcvd: 32
    
    server1:~#
     

Share This Page