"There is already an A Record entry for this host in this zone." but there isn't

Discussion in 'Installation/Configuration' started by woleium, Feb 8, 2007.

  1. woleium

    woleium New Member

    AAARGH! Please help, helpful people! I have searched the forums for this but can't find anything.

    When i try to add an a record i get

    "There is already an A Record entry for this host in this zone."

    but there is no record in the /var/named/chroot/var/named/pri.domain.com file

    There was, but i deleted it and ispconfig seems to have gotten itself confused.

    How do i fix this?
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Empty the recycle bin, also the ones in DNS Manager. Wait a minute, then try again.
  3. woleium

    woleium New Member

    I tried that.

    I have already tried emptying both recycle bins, but it still doesn't work :(
  4. woleium

    woleium New Member

    ok, i dumped the config_db

    -- Dumping data for table `dns_a`
    LOCK TABLES `dns_a` WRITE;
    /*!40000 ALTER TABLE `dns_a` DISABLE KEYS */;
    INSERT INTO `dns_a` VALUES (1,1018,'www','XXX.XXX.XXX.XXX'),(2,1018,'www','XXX.XXX.XXX.XXX'),(3,1018,'www','XXX.XXX.XXX.XXX'),(10,1018,'www','XXX.XXX.XXX.XXX'),(11,1018,'www','XXX.XXX.XXX.XXX'),(13,1018,'test1',''),(20,1018,'test2','XXX.XXX.XXX.XXX');
    /*!40000 ALTER TABLE `dns_a` ENABLE KEYS */;
    The a record in question is the test1.
    I created test1.test.com site, but mistakenly set the ip to an internal one.
    I then deleted the A record in dns manager.
    I then changed the ip in the site manager (and ipsconfig hung on plageload at this point, and still does when i tell it to create dns & mx records.)

    Now i can't re-create the record, and there is no A record in the zone file.

    Should i delete the entry from the database, then recreate? Or is there something else that I need to do?
  5. georgew

    georgew New Member

    please respond to this problem

    The previous user asked several questions, and got no answer.

    I have a similar problem. This needs an answer, as destroying a customer's site is not the solution.

    Here is what I did...

    The customer wants me to set up email on my main email server for one of his domains. When he originally configured the domain it had options set to "local mailserver".

    I went into the options, and set it to external mail server, and hit save.

    I then went into the DNS zone manager and created the mail A record.

    I then notice I got the IP wrong, so I clicked on the IP, edited it, then hit save.

    After the save, I realize there was another error in the IP address. So I click the address, make the change, and hit save... Oops! this time I get an error message "There is already an A Record entry for this host in this zone".

    Now what?


    Well, I noted in the thread the recycle bin thing...
    Sure enough, there were not one, but two A records in the recycle bin for "mail"...

    Emptying the recycle bin fixed the problem.

    But wait one stinking minute!

    What do you mean "There is already an A Record"???!?!?!?

    It is sometimes normal to have more than one A record for a
    machine. This is how DNS based load spreading is done!

    Why don't we allow multiple A records for the same machine name?

    I agree that you should warn the user, in case he didn't mean to do it...
    but this is not a very good dns manager if it won't let a user to a
    legitimate thing like run 12 parallel web servers and to do DNS load
    spreading across them to handle a high-volume event. It's more
    cost effective than rigging up a load balancer for a one-of-a-kind
    event, and while it's not perfect, it works real well. Bind does a
    round-robin thing, and the load spreads well. ISPconfig should
    allow it!
    Last edited: Aug 9, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    It's in our bugtracker already.

Share This Page