The URL is not reachable!

Discussion in 'Installation/Configuration' started by Andesh, Dec 28, 2008.

  1. Andesh

    Andesh New Member


    I'm stuck at the end of the installation;
    Please enter the host name (e.g. www):www
    Please enter the domain (e.g.
    The URL is not reachable!

    To my (limited) understanding the domain is a FQDN.
    I think all the A and MX records are setup correctly.
    The box is setup as a default server in the router.

    I can telnet on port 25, I can access the website on port 80
    However I fail to access the site on port 81.

    Last edited: Dec 28, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure thet the domain responds to ping requests and then unpack and install ispconfig again.
  3. Andesh

    Andesh New Member

    Thanks till, that solved everything for me. Ispconfig is now up and running! :)
  4. megabitdragon

    megabitdragon New Member

    I have a similar problem with ISPconfig 3 SVN version.
    I can access the control panel using IP address on port 8080( but if I try to use it doesn't work.
    Do I have to add a new A record on my domain register before I can do this in order for this to function?

  5. falko

    falko Super Moderator ISPConfig Developer

    Does the DNS record for point to the correct server?
  6. megabitdragon

    megabitdragon New Member

    I am a newbie so I don't really know to answer your question.
    Can you set the DNS record for each individual host or for the entire domain? Is this done in control panel or on the domain registrar website?

    This is what I managed to do up to now.
    I added a website using the control panel:
    Now I can access the control panel using I think this means that the DNS record for the domain points to the right server.
    However I would like to access the control panel on but not on
    Is there any way to do this?

    Any help is appreciated.

  7. falko

    falko Super Moderator ISPConfig Developer

    You can check out the DNS record for as follows:
    To find out the name servers of, run
    dig ns
    Probably these are the name servers of your domain registrar, and you can then manage your DNS records from the registrar's web interface.
  8. Allen15

    Allen15 New Member

    I got to that same (original) error loop, where I couldn't figure out how to go further, but I'm not sure if I have the same setup?

    I apologize in advance if this is thread hijacking, but this is my first post, and first attempt at ISPConfig (and Ubuntu), and I am nearly at my wits end.

    I am mainly just trying to get a single website/webserver live, and followed the Ubuntu perfect server setup for 8.04, but couldn't get the server to respond or serve any web pages except if browsing to the IP address, not the name/URL. I then tried the same thing for 8.10, and am now repeating this problem.

    I thought if I installed ISPConfig, I could set up at least one virtual site, which would do what I needed, but I'm stuck with a failed install, where the hostname command returns the proper information, and I can locally ping the server, but outside of a local login (from a different machine), I can't ping by name, and the host is either unreachable for the hostname shown by the local command, or the request times out for the site URL that I am trying to get live.

    My DNS records were set up for the site that I am trying to bring up, and resolve to the proper IP address, but nothing I can do (so far) seems to get anything to respond at that address?

    Please Help?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server in a NAT enviroment behind a router?
  10. Allen15

    Allen15 New Member

    no, it is a dedicated box with a clean install according to the "Perfect Server" guide, and plugged directly into a live connection, with no intervening NAT firewall or similar. I would be more nervous about such a "naked" setup, except that there is nothing yet on this server, and it is supposed to be an interim web server while the main server is being re-built (later). Right now, it has only a fresh install. Do I need to put it behind a NAT box?
  11. Allen15

    Allen15 New Member

    It would almost seem as either it doesn't know it's own name (only from the outside), or my DNS host configuration is incorrect at

    The A record for the domain points to the public IP address, which I can browse by IP address and get the default page "It works!" just fine with, and the www CNAME is listed at the DNS host as being "@", which I thought would just redirect to the IP address in the "A" record. This same setup is working fine for the other web server, although that is running Windows Small Business Server 2003, not Linux.

    At this point, I'm not even sure how to tell if it is a DNS host configuration error, or a local DNS configuration problem on the Linux box?
  12. falko

    falko Super Moderator ISPConfig Developer

  13. Allen15

    Allen15 New Member

    No, but gave me (mostly) green lights, so I think that the external DNS is setup properly. I figure that this has to be something really basic and so basic that it is flying under everyone's radar because they naturally do it, and take it for granted.

    What I did/have done from start to present (and the part about installing clean has been repeated multiple times now), was to:
    - get a registered domain name eg. "", with, and customize the DNS to point to my static IP address that I have available for this.

    - wait 2 days for it to propagate and verify with "ping" and "ping", and while I don't get any packets returned yet, it resolves to my static IP (Good, now I can go plug something into that network cable, and continue)

    - build a dedicated machine from scratch and do a clean install on new hardware, following the "Perfect Server" how-to for Ubuntu 8.10 (actually I started with Mandriva 2009, and when that didn't work, I wiped and reloaded with Ubuntu Hardy Heron, and after getting to the same roadblock, I wiped and reloaded <now 5 times> with Ubuntu 8.10). The Ubuntu 8.10 installation is the one that I have so far gotten the furthest, and with the least amount of errors, but still, I haven't yet succeeded... BTW, I did get completely through the Server How-To, with no errors, and thought I was in good shape until after I tried installing ISPConfig and had that bomb out, so I don't really know if the problem was with my server setup, or with my ISPConfig install.

    - install ISPConfig according to the instructions on their website

    - get to the repeatable error message about not being able to resolve my host/URL is unreachable, cancel installation, rinse, and repeat...

    I'd even consider the Enterprise support package, but if it turns out that my problems aren't with ISPConfig, Enterprise support may be costly and still ineffective? That, and I really do want to learn what the h3@# I'm doing too ;)
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Can you ping the domain name form a external computer?
  15. Allen15

    Allen15 New Member

    pinging externally will resolve properly to the correct IP address, but doesn't respond, ie. no packets returned. I don't know if ufw is even set up to respond to ICMP, though, or if following those instructions (the Perfect Server How-To) will enable or disable ufw either. I haven't done anything other than what was there.

    I'm thinking it's time to wipe and reload (again)... I'll at least get good at that part?
  16. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/resolv.conf, and what's the output of
    iptables -L
    ? Did you disable AppArmor?
  17. Allen15

    Allen15 New Member

    my /etc/resolv.conf only has my ISP's primary and secondary DNS servers listed (what is supposed to be here?)
    iptables -L gives this response:
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    and again, just like before, I have no idea what is supposed to be here, so I can only hope that this is good or at least useful...

    Yes, of course I disabled apparmor -- it was one of the steps in the instructions :)

    UPDATE FOLLOWS: I have been able to get past that error message of the subject of this thread, specifically, by leaving the hostname blank and putting my IP address in the next response, although it still didn't produce a working ISPConfig installation, it just allowed me to get further the last time :( At this time, I am sure that my problems will become off-topic to this thread, and I should probably start a new thread for proper nettiquette, etc.

    Again, if someone has the "URL is not reachable" error near the end of an ISPConfig installation, try leaving your hostname blank, and putting your IP address into the next response... Hope this helps someone.

    Off to my next wipe/reload... Grrrr...

Share This Page