The repository 'http://packages.prosody.im/debian stretch Release' does no longer have a Release

Discussion in 'ISPConfig 3 Priority Support' started by nmazza, Jun 19, 2021.

  1. nmazza

    nmazza Member HowtoForge Supporter

    Hello,
    apt-get update in Debian 9 stretch

    [email protected]:~# apt-get update
    Hit:1 http://mirrors.linode.com/debian stretch-updates InRelease
    Ign:2 http://ftp.us.debian.org/debian stretch InRelease
    Hit:3 http://security.debian.org/debian-security stretch/updates InRelease
    Hit:4 http://ftp.us.debian.org/debian stretch Release
    Ign:6 http://packages.prosody.im/debian stretch InRelease
    Err:7 http://packages.prosody.im/debian stretch Release
    410 Gone [IP: 2001:41c9:1:424::35 80]
    Reading package lists... Done
    E: The repository 'http://packages.prosody.im/debian stretch Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    [email protected]:~#

    I all of my Debian 9 Servers

    Thanks
    Nestor Mazza
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Last edited: Jun 19, 2021
    Th0m likes this.
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    By the way, XMPP isn't supported by ISPConfig anymore (at least officialy...)
     
  4. nmazza

    nmazza Member HowtoForge Supporter

    But, I'm only security and packages up to date ...
    my source list look as is

    # /etc/apt/sources.list

    # deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main
    #deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main
    ##deb http://mirrors.linode.com/debian stretch main
    ##deb-src http://mirrors.linode.com/debian stretch main
    ##deb http://mirrors.linode.com/debian-security stretch/updates main
    ##deb-src http://mirrors.linode.com/debian-security stretch/updates main

    deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
    deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free

    deb http://security.debian.org/debian-security stretch/updates main contrib non-free
    deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

    # stretch-updates, previously known as 'volatile'
    deb http://mirrors.linode.com/debian stretch-updates main
    deb-src http://mirrors.linode.com/debian stretch-updates main

    and, I don't know about prosody repository
    the apt-get update search in prosody
    What's the wright way to solve this ?
    Thanks again
    Nestor Mazza
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Since apt-get update tries to fetch the Release file from prosody.im that repository must be in apt configuration. Since it is not in file /etc/apt/sources.list, it likely is in one of the files in directory /etc/apt/sources.list.d/ .
    It seems to me you have not stated what problem you want to solve. In #1 you merely posted the apt-get update results, I merely responded that indeed prosody.im (no longer) supports Debian 9 release. In #4 you claim the not working repository is not in your hosts apt configuration, but it must be since apt tries to access it.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Comment out the prosody repository in the sources list to avoid the error. As @Taleman stated, it's most likely in a file in sources.list.d dierctory.
     
  7. nmazza

    nmazza Member HowtoForge Supporter

Share This Page