The Perfect SpamSnake - Ubuntu 8.04 LTS - Page 02 - Installing Perl Modules

Discussion in 'HOWTO-Related Questions' started by denbert, Dec 19, 2008.

  1. denbert

    denbert New Member

    Hi there,

    I'm planning to put the spamsnake in front of my M$ Exchange 2003 server and therefore I've stated on this SpamSnake installation.

    I'm getting stuck in this:

    1.11 Install Perl Modules(Pre-requisites)

    I'm getting this when i try this command:

    cpan> install Mail::SPF


    Running make test
    Make had some problems, maybe interrupted? Won't test
    Running make install
    Make had some problems, maybe interrupted? Won't install


    I've also tried via webmin without any luck.

    Anyone who can point me in the right direction?
     
  2. falko

    falko Super Moderator

    Try this:
    Code:
    apt-get install libmail-spf-query-perl
     
  3. denbert

    denbert New Member

    I'm having a new challenge when i try to install postfix:

    6 Setting up Postfix

    Code:
    apt-get install postfix postfix-pcre postfix-mysql postfix-ldap cabextract lha unrar razor pyzor spamassassin
    Giving me this:

    Package lha is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package lha has no installation candidate

    7.3 Razor Configuration

    Code:
    razor-admin -home=/var/lib/MailScanner/.razor -register
    Giving me this:

    gandalf:~# razor-admin -home=/var/lib/MailScanner/.razor -register
    Error 202 while performing register, aborting.


    I'm installing on a Debian Etch server
     
    Last edited: Dec 20, 2008
  4. falko

    falko Super Moderator

    Leave out the lha package.

    Run the command again. Sometimes it needs to be run multiple times before it succeeds.
     
  5. denbert

    denbert New Member

    Yeps, I'd also removed the unrar package from the install as this also made an error.

    Did't twice, and bingo received this:

    Register successful. Identity stored in /var/lib/MailScanner/.razor/identity-

    Thanks, I'll go on setting up the SpamSnake on Debian Etch
     
  6. denbert

    denbert New Member

    Hi again,

    New issue:

    7.4 DCC Setup and Configuration


    Installing dcc gives me this problem:

    gandalf:~# dpkg -i dcc-common_1.3.42-5_i386.deb
    (Reading database ... 53306 files and directories currently installed.)
    Preparing to replace dcc-common 1.3.42-5 (using dcc-common_1.3.42-5_i386.deb) ...
    Unpacking replacement dcc-common ...
    dpkg: dependency problems prevent configuration of dcc-common:
    dcc-common depends on libc6 (>= 2.7-1); however:
    Version of libc6 on system is 2.3.6.ds1-13etch8.
    dpkg: error processing dcc-common (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    dcc-common


    8 Configuring MailScanner and ClamAV


    Installing ClamAV gives me this:

    gandalf:~# apt-get install clamav clamav-daemon
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    clamav: Depends: libclamav2 (>= 0.90.1dfsg) but it is not going to be installed
    Depends: clamav-freshclam but it is not going to be installed or
    clamav-data
    clamav-daemon: Depends: libclamav2 (>= 0.90.1dfsg) but it is not going to be installed
    Depends: clamav-base (>= 0.90.1dfsg-4etch16) but it is not going to be installed
    Depends: clamav-freshclam but it is not going to be installed or
    clamav-data
    dcc-common: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch8 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



    I'm aware of the standard Debian (Etch) being very conservative in using new packages, is there a way to force the use the newest stable packages in the source.list?
     
    Last edited: Dec 21, 2008
  7. falko

    falko Super Moderator

    What's in /etc/apt/sources.list?
     
  8. denbert

    denbert New Member

    My sources.list

    Code:
    # deb cdrom:[Debian GNU/Linux 4.0 r3 _Etch_ - Official i386 NETINST Binary-1 20$
    
    # deb cdrom:[Debian GNU/Linux 4.0 r3 _Etch_ - Official i386 NETINST Binary-1 20$
    
    deb http://ftp.dkuug.dk/debian/ etch main
    deb-src http://ftp.dkuug.dk/debian/ etch main
    
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    
    # Webmin entry by denbert
    deb http://download.webmin.com/download/repository sarge contrib
    But I've decided to use the christmas holidays on this, and therefore I'll wipe the Debian "Etch" box, and install a clean Ubuntu 8.04 LTS and then follow the howto - I think this will remove all my problems, as normally your howto's are the best on the internet :)
     
  9. falko

    falko Super Moderator

    Looks ok (except for the sarge Webmin line). Did you have other repositories in that file previously? That would explain the dependency problems.
     
  10. denbert

    denbert New Member

    First of all, Merry Christmas to you all.

    As mentioned earlier in the thread, I've decided to wipe the Debian Etch and install Ubuntu 8.04 LTS - and yes, the howto worked like a charm.

    I'm not a power administrator, but an autodidact dude, who loves the idea of Linux (especially Debian, though I started years ago with Redhat 5.1), and therefore I have an understanding problem with this:

    9.10 Integrate SQL Blacklist/Whitelist (optional)

    1. Edit the MySQL connection values within the CreateList subroutine of SQLBlackWhiteList.pm to match the values you entered previous into MailWatch.pm. Both files should contain the same values. (Look for the following lines in SQLBlackWhiteList.pm and enter your own data.)

    Where and which file do i need to edit?
     
  11. falko

    falko Super Moderator

    I wish the same to you. :)

    I did not write the tutorial, so I don't know where they are located, but you can search for them like this:
    Code:
    updatedb
    locate SQLBlackWhiteList.pm
    locate MailWatch.pm
     
  12. denbert

    denbert New Member

    Hi again,

    Found a strange detail here:

    9.12 SpamAssassin

    Add these lines to the top of spam.assassin.prefs.conf:

    pyzor_options --homedir /var/lib/MailScanner/
    razor_config /var/lib/MailScanner/.razor/razor-agent.conf

    Comment out the following:
    Code:
    #bayes_auto_expire 0
    but later we need to check this:

    9.13 Move the Bayesian Databases and set-up permissions (skip this if you don't use bayes)


    Make sure that "bayes_auto_expire 0" is not commented out in spam.assassin.prefs.conf:

    Code:
    bayes_auto_expire 0
    which statement is correct?
     
  13. falko

    falko Super Moderator

    Not sure as I've not written that tutorial, but maybe bayes_auto_expire 0 and #bayes_auto_expire 0 are the same (if 0 is the default value). I think I'd try bayes_auto_expire 0.
     

Share This Page