The Perfect Setup - Ubuntu 6.06 LTS Server

Discussion in 'HOWTO-Related Questions' started by tommytomato, Jun 9, 2007.

  1. tommytomato

    tommytomato New Member

    Yes that's the correct IP, when I'm not home, I turn off the computer in question.

    Code:
    ~# ls -la /home/tommytomato
    ls: /home/tommytomato: No such file or directory
    So it says tommy is not there, but when I try to add it in I get this

    I added tommytomato to the system via this command

    Code:
    useradd -d /home/tommytomato -g users tommytomato
    I can only hang around for half hour and then I have to go to work, your welcome to ping the server now

    TT
     
  2. falko

    falko Super Moderator ISPConfig Developer

    IS that computer behind a router? If so, did you forward port 25 from your router to that computer? Does your ISP maybe block port 25?
    Please create the directory like this:
    Code:
    mkdir /home/tommytomato
    chown tommytomato:users /home/tommytomato
     
  3. tommytomato

    tommytomato New Member

    Code:
    mkdir /home/tommytomato
    chown tommytomato:users /home/tommytomato
    That is done. NO my ISP doesn't block port 25

    The port 25 is open and pointing to the PC in question

    I sent mail to the tommy account and it has made the Maildir

    Not able to conntect to recive mail.
    same message as before

    TT
     
    Last edited: Jun 13, 2007
  4. tommytomato

    tommytomato New Member

    Would it be the ports on the so called PC :confused:

    correct me if I'm wrong, I have read that Ubuntu only has certain ports open and blocks all the rest.

    I tried using other mail clients from with in my network to contect to the PC in question, the PC recives mail ok ,but I'm not able to contect to the PC in question to retive the mail :confused:

    I'm not a big fan of iptables, is there a command line firewall gui that can bring up the firewall, all other ports are open on my router

    I'm not sure, but i have ask if my ISP blocks port 25, I dont know if you can view this link :confused:

    http://support.westnet.com.au/articleRedirect.asp?aid=1213|

    TT
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Is the rockinghamgateway.com computer in the same local network as your own computer? If so, it's possible that your router doesn't support loopbacks.
     
  6. tommytomato

    tommytomato New Member

    yes the PC in quetion is in the same network

    What do you mean by loop backs ?

    a Few years ago, when I got into Linux I was using fedore core, a mate had setup a email server, I was able to contect to it via another pc, so it did work.

    I'm running a NB1300 plus 4 port router.

    TT
     
  7. falko

    falko Super Moderator ISPConfig Developer

    That means that if you request rockinghamgateway.com from a computer in your LAN, the requests passes your router and then goes back into your LAN, because rockinghamgateway.com is in your LAN. Some routers don't support this.

    Did you open port 25 in your router's firewall?
     
  8. tommytomato

    tommytomato New Member

    Yes I did add the port 25 to the router firewall,
    [​IMG]

    I also have edited the hosts file on my GUI box so I can view my domains
    /etc/hosts

    has 192.168.1.100 www.rockinghamgateway.com
    192.168.1.100 rockinghamgateway.com

    TT
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you change that to
    Code:
    192.168.1.100 www.rockinghamgateway.com rockinghamgateway.com
    ?
     
  10. tommytomato

    tommytomato New Member

    Yep I've done that

    I've got this far on the mail side of things

    Code:
    Connected to rockinghamgateway.com
    Escape character is '^]'.
    220 rockinghamgateway.com ESMTP Postfix (Ubuntu)
    ehlo rockinghamgateway.com
    250-rockinghamgateway.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    quit
    221 Bye
    Connection closed by foreign host.
    So I spose its working, how ever I haven't been able to contect to it using a GUI email client from another PC other than the Server.

    Got another question

    Apache 2 root directory for putting site files is /var/www :confused:

    how come I cant view any files apart from my index.html file :confused:

    Code:
    [email protected]:/var/www# ls -al
    total 316
    drwxr-xr-x 30 root root   4096 2007-06-18 21:18 .
    drwxr-xr-x 15 root root   4096 2007-06-18 20:45 ..
    drwxr-xr-x  7 root root   4096 2007-06-18 21:17 4x4
    and so on

    I'm not using ispconf, php not working, how can i turn it on to view my pages

    TT
     
    Last edited: Jun 18, 2007
  11. tommytomato

    tommytomato New Member

    I did a bit of a search, didn't really find how to fix, only found out how to out put the apache stuff

    Code:
    [email protected]:/var/www# ls -la /etc/apache2/mods-available
    total 184
    drwxr-xr-x 2 root root 4096 2007-06-18 20:35 .
    drwxr-xr-x 8 root root 4096 2007-06-18 21:28 ..
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 actions.load
    -rw-r--r-- 1 root root   60 2006-07-27 02:01 asis.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 auth_anon.load
    -rw-r--r-- 1 root root   68 2006-07-27 02:01 auth_dbm.load
    -rw-r--r-- 1 root root   74 2006-07-27 02:01 auth_digest.load
    -rw-r--r-- 1 root root  130 2006-07-27 02:01 auth_ldap.load
    -rw-r--r-- 1 root root   62 2006-07-27 02:01 cache.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 cern_meta.load
    -rw-r--r-- 1 root root   61 2006-07-27 02:01 cgid.conf
    -rw-r--r-- 1 root root   60 2006-07-27 02:01 cgid.load
    -rw-r--r-- 1 root root   58 2006-07-27 02:01 cgi.load
    -rw-r--r-- 1 root root   37 2006-07-27 02:01 dav_fs.conf
    -rw-r--r-- 1 root root   64 2006-07-27 02:01 dav_fs.load
    -rw-r--r-- 1 root root   58 2006-07-27 02:01 dav.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 deflate.load
    -rw-r--r-- 1 root root   72 2006-07-27 02:01 disk_cache.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 expires.load
    -rw-r--r-- 1 root root   72 2006-07-27 02:01 ext_filter.load
    -rw-r--r-- 1 root root   72 2006-07-27 02:01 file_cache.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 headers.load
    -rw-r--r-- 1 root root   60 2006-07-27 02:01 imap.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 include.load
    -rw-r--r-- 1 root root   60 2006-07-27 02:01 info.load
    -rw-r--r-- 1 root root   60 2006-07-27 02:01 ldap.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 mem_cache.load
    -rw-r--r-- 1 root root   85 2006-07-27 02:01 mime_magic.conf
    -rw-r--r-- 1 root root   72 2006-07-27 02:01 mime_magic.load
    -rw-r--r-- 1 root root  135 2007-06-18 20:35 php5.conf
    -rw-r--r-- 1 root root   59 2007-05-23 04:23 php5.load
    -rw-r--r-- 1 root root  840 2006-07-27 02:01 proxy.conf
    -rw-r--r-- 1 root root   78 2006-07-27 02:01 proxy_connect.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 proxy_ftp.load
    -rw-r--r-- 1 root root   72 2006-07-27 02:01 proxy_http.load
    -rw-r--r-- 1 root root  316 2006-07-27 02:01 proxy.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 rewrite.load
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 speling.load
    -rw-r--r-- 1 root root 3545 2006-07-27 02:01 ssl.conf
    -rw-r--r-- 1 root root   58 2006-07-27 02:01 ssl.load
    -rw-r--r-- 1 root root   64 2006-07-27 02:01 suexec.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 unique_id.load
    -rw-r--r-- 1 root root  244 2006-07-27 02:01 userdir.conf
    -rw-r--r-- 1 root root   66 2006-07-27 02:01 userdir.load
    -rw-r--r-- 1 root root   70 2006-07-27 02:01 usertrack.load
    -rw-r--r-- 1 root root   74 2006-07-27 02:01 vhost_alias.load
    [email protected]:/var/www# ls -la /etc/apache2/mods-enabled
    total 8
    drwxr-xr-x 2 root root 4096 2007-06-18 20:35 .
    drwxr-xr-x 8 root root 4096 2007-06-18 21:28 ..
    lrwxrwxrwx 1 root root   36 2007-06-18 20:20 cgi.load -> /etc/apache2/mods-available/cgi.load
    lrwxrwxrwx 1 root root   40 2007-06-18 20:33 include.load -> /etc/apache2/mods-available/include.load
    lrwxrwxrwx 1 root root   37 2007-06-18 20:30 php5.conf -> /etc/apache2/mods-available/php5.conf
    lrwxrwxrwx 1 root root   37 2007-06-18 20:30 php5.load -> /etc/apache2/mods-available/php5.load
    lrwxrwxrwx 1 root root   40 2007-06-18 20:33 rewrite.load -> /etc/apache2/mods-available/rewrite.load
    lrwxrwxrwx 1 root root   36 2007-06-18 20:33 ssl.conf -> /etc/apache2/mods-available/ssl.conf
    lrwxrwxrwx 1 root root   36 2007-06-18 20:33 ssl.load -> /etc/apache2/mods-available/ssl.load
    lrwxrwxrwx 1 root root   39 2007-06-18 20:33 suexec.load -> /etc/apache2/mods-available/suexec.load
    lrwxrwxrwx 1 root root   40 2007-06-18 20:20 userdir.conf -> /etc/apache2/mods-available/userdir.conf
    lrwxrwxrwx 1 root root   40 2007-06-18 20:20 userdir.load -> /etc/apache2/mods-available/userdir.load
    [email protected]:/var/www# 
    
    
    TT
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Looks good. :)

    What's the output of
    Code:
    netstat -tap
    ? Are the ports 25 and 110 open in your firewall?

    Did you upload any files to that directory?

    In the Perfect Setup, there's a section about disabling PHP that you must not follow if you don't want to use ISPConfig. So if you've followed it, please undo these steps now.
     
  13. tommytomato

    tommytomato New Member

    I see so your saying to uncomment those php lines :confused:

    Code:
    [...]
    #application/x-httpd-php                                phtml pht php
    #application/x-httpd-php-source                 phps
    #application/x-httpd-php3                       php3
    #application/x-httpd-php3-preprocessed          php3p
    #application/x-httpd-php4                       php4
    [...]
    TT
     
  14. falko

    falko Super Moderator ISPConfig Developer

  15. tommytomato

    tommytomato New Member

    thanks mate

    Funny thing as happend

    after trying to work out iptables for ports, i was able to open ports, stuff knows how, but i can now send my mail from my GUI email client to my rockinghamgateway account, the server recives the mail ok

    can log into hotmail and send mail to rockinghamgateway account and it gets it ok,

    but when trying to send mail using the rockinghamgateway account
    I get this message from my GUI eamil client
    I've tried the pasword i use, but it dont seem to be working

    any other ideas please.

    TT
     
  16. tommytomato

    tommytomato New Member

    Here are my log's in image form

    image 1 all the logs together, did i miss any :confused:

    [​IMG]
    Image 2
    when reciving mail from GUI client from another computer other than the server ( if that makes sence ) :rolleyes:
    [​IMG]
     
  17. tommytomato

    tommytomato New Member

    Here is the error :confused: I'm not sure as to why it throws up the password box all the time, let alone let me send mail from the rockinghamgateway mail account, if that makes sence :rolleyes:

    [​IMG]

    when clicking on the images they come up alittle out of wack, click on it again to view better image.
    TT
     
    Last edited: Jun 24, 2007
  18. tommytomato

    tommytomato New Member

    Any reason to why i cant send mail from the rockinghamgateway.com email account, keeps coming up with smtp password box :confused:

    I have some more log images with the ports open from the router, if thats any help

    TT
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Either you use the wrong username and password for SMTP authentification or your SASL daemon is not configured correctly. Please compare your sasl configuration with the configuration described in the perfect setup guides.
     
  20. tommytomato

    tommytomato New Member

    ok thanks I'll look into it tonight after work

    I get one message on boot

    is that normal ?

    TT
     

Share This Page