The Perfect Setup: SuSE 9.3

Discussion in 'HOWTO-Related Questions' started by ct2193, Mar 28, 2006.

  1. ct2193

    ct2193 New Member

    I'm attempting to build a SuSE 9.3 system via the "Perfect Setup" document and I've come into a problem configuring Quotas.

    I'm at the part:

    -=-=-=-
    touch /aquota.user /aquota.group
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug
    -=-=-=-

    The first time I ran this, quotacheck -avugm returned the message "quotafile was probably truncated".

    And the line quotaon -avug returned "quota format not supported in kernel".

    I attempted to repeat the entire quota section and the line quotacheck -avugm said nothing more about truncated files. So I assume this part is
    ok.

    The line quotaon -avug still returns the message about "quota format not supported in kernel". I'm not really sure as to why. I have not loaded anything custom, as everything has been installed per the "Perfect Setup" documentation.

    Any suggestions?

    -=-

    I'm also interested in a "Perfect Setup" specifically for RedHat 9 and/or RedHat Enterprise Linux 4 (RHEL4). Any information on these versions?
     
    Last edited: Mar 29, 2006
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  3. ct2193

    ct2193 New Member

    Still having quota problems

    I looket at http://www.howtoforge.com/forums/showthread.php?t=3083 and still have problems.

    -=-
    touch /aquota.user /aquota.group
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avug

    then i get the message "quotacheck: Cannot remount filesystem mounted on / read-only so counted values might not be right. Please stop all programs writing to filesystem or use -m flag to force checking.

    (didn't get this message before)

    then I ran

    quotaon -avug

    and got the message

    quotaon: using //aquota.group on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //aquota.user on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.

    -=-
    here's my fstab

    /dev/hda2 / reiserfs acl,user_xattr,usrquota,grpquota 1 1
    /dev/hda1 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    sysfs /sys sysfs noauto 0 0
    /dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0


    Not sure what the problem is.

    I've redone the entire "Perfect Setup" and the "how-to" dies here again.
     
  4. ct2193

    ct2193 New Member

    also...

    also tried

    modprobe quota_v1

    FATAL: Could not load /lib/modules/2.6.11.4-20a-default/modules.dep: No such file or directory

    modprobe quota_v2

    FATAL: Could not load /lib/modules/2.6.11.4-20a-default/modules.dep: No such file or directory

    quotaon -avug

    quotaon: using //aquota.group on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //aquota.user on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You're using reiserfs. Quota doesn't work on reiserfs - you should have used ext3 instead.
     
  6. ct2193

    ct2193 New Member

    Quotas... again!

    OK. I reinstalled SuSE 9.3, being sure to use EXT3 (instead of ReiserFS)

    This time, running:

    touch /aquota.user /aquota.group
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avug

    Seemingly worked fine. Then I ran:

    quotaon -avug

    and got the message

    quotaon: using //aquota.group on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //aquota.user on /dev/hda2 [/]: No such process
    quotaon: Quota format not supported in kernel.

    Don't know what the problem is. I tried "modprobe quota_v1" and v2. Both say "could not load /lib/modules/2.6.11.4-20a-default/modules.dep No such file or folder"

    I rechecked all the previous steps from the how-to document. Everything appears to have been completed as well as properly spelled.

    Any more ideas?
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please run
    Code:
    echo quota_v1 >> /etc/modules
    echo quota_v2 >> /etc/modules
    and reboot the system. Does it work then?
     
  8. ct2193

    ct2193 New Member

    Postfix postconf

    OK. I'm now to the postconf part of Postfix. Thus far (with much thanks) I've gotten here with no further problems. I would like clairification as to which parts are your "put your data here" and which parts are system phrases / config strings. The section I am in question of is below.

    -=-

    postconf -e 'mydomain = example.com'
    postconf -e 'myhostname = server1.$mydomain'
    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
    postconf -e 'inet_interfaces = all'
    postconf -e 'alias_maps = hash:/etc/aliases'
    postconf -e 'smtpd_tls_auth_only = no'
    postconf -e 'smtp_use_tls = yes'
    postconf -e 'smtpd_use_tls = yes'
    postconf -e 'smtp_tls_note_starttls_offer = yes'
    postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
    postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
    postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
    postconf -e 'smtpd_tls_loglevel = 1'
    postconf -e 'smtpd_tls_received_header = yes'
    postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
    postconf -e 'tls_random_source = dev:/dev/urandom'

    -=-
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Code:
    postconf -e 'mydomain = example.com'
    postconf -e 'myhostname = server1.$mydomain'
    You must replace this with your own data.


    Code:
     postconf -e 'smtpd_sasl_local_domain ='
     postconf -e 'smtpd_sasl_auth_enable = yes'
     postconf -e 'smtpd_sasl_security_options = noanonymous'
     postconf -e 'broken_sasl_auth_clients = yes'
     postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
     postconf -e 'inet_interfaces = all'
     postconf -e 'alias_maps = hash:/etc/aliases'
     postconf -e 'smtpd_tls_auth_only = no'
     postconf -e 'smtp_use_tls = yes'
     postconf -e 'smtpd_use_tls = yes'
     postconf -e 'smtp_tls_note_starttls_offer = yes'
     postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
     postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
     postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
     postconf -e 'smtpd_tls_loglevel = 1'
     postconf -e 'smtpd_tls_received_header = yes'
     postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
     postconf -e 'tls_random_source = dev:/dev/urandom'
    You can copy and paste this part. :)
     
  10. ct2193

    ct2193 New Member

    index.pl

    OK. Finally back to working on install.

    I got through most of the Apache/PHP5 section and just before the Proftpd section, I'm doing the commands:

    SuSEconfig
    /etc/init.d/apache2 start

    Restarting apache yields an error saying index.pl is either misspelled or refers to a module not installed.

    Do I need to remove index.pl from the httpd.conf file, or am I missing a step?

    The documentation said to comment out the line application/x-perl pl pm from the mime.types file.
     
    Last edited: Apr 17, 2006
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the exact error message?
    Anything in your Apache's error log?
     
  12. ct2193

    ct2193 New Member

    ISPconfig

    OK. I found remaining problems with the initial setup.

    Now I'm into ISPconfig and having difficulties.

    I got to the point of ./setup and it ran for a long time. Now I get a message about how it "stops here".

    checking for working mmap... yes
    checking for _LARGEFILE_SOURCE value needed for large files... 1
    checking for fseeko... yes
    checking whether snprintf correctly terminates long strings... yes
    checking pthread.h usability... yes
    checking pthread.h presence... yes
    checking for pthread.h... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for zlib installation... /usr
    configure: error: Please install zlib and zlib-devel packages
    ERROR: Could not configure ClamAV
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 794: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!


    I noticed something about zlib and ClamAV and such, but I don't really know why. i also see that "The PHP binary coming with ISPConfig does not work properly on your system!" As far as I know I followed the Suse 9.3 Perfect Setup all the way. Is this a problem with my initial setup, or has ISPconfig changed since the Perfect Setup documentation?
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must install zlib and zlib-devel. Run
    Code:
    yast
    and search for the appropriate packages.
     

Share This Page