The Perfect Setup - CentOS 4.4

Discussion in 'HOWTO-Related Questions' started by ghostrider.002, May 19, 2007.

  1. ghostrider.002

    ghostrider.002 New Member

    I need a little help.

    I followed this tutorial and all went smoothly until I got to step 10
    http://www.howtoforge.com/perfect_setup_centos_4.4_p5

    10 Postfix With SMTP-AUTH And TLS

    I installed:
    yum install cyrus-sasl cyrus-sasl-devel cyrus-sasl-gssapi cyrus-sasl-md5 cyrus-sasl-plain postfix dovecot

    This went ok.

    but when i went to the next step of running these commands listed below it indicated that "bash: postconf: command not found"

    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
    postconf -e 'inet_interfaces = all'
    postconf -e 'mynetworks = 127.0.0.0/8'

    I even tried /sbin/postconf -e 'smtpd_sasl_local_domain ='
    with the same results.

    so i stopped here.
    Can anyone help me out here?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    It seems Postfix isn't installed. Did you get any error messages when you ran the yum install... command?
    What's the output of
    Code:
    which postfix
    and
    Code:
    updatedb
    locate postconf
    ?
     
  3. ghostrider.002

    ghostrider.002 New Member

    Thanks for replying and i apologize for the delay in getting back. I found that I had to run these commands as, 'usr/sbin/xxxxxx'. I wasn't sure why but as i went to postfix home page and was reading the documentation there I believe it indicated that it or part of it was installed there. but after running these commands in this syntax it went ok.

    There were also other software that i had to install in this fashion. but since the beginning of the tutorial where it stated to run,' yum update' all install commands had to be started with,'/sbin/xxxx'

    Even now. with the exception of yum xxxx and i one or two more.

    And when I did get it figured out I went to install IspConfig.
    upon running ./setup it indicated that I was running CentOS 4.5 (found out by visiting CentOS home page that by typing yum update the OS gets updated to version 4.5)and it refused to install, so i opened the dist.txt file for IspConfig and copied the CentOS 4.4 section and pasted it below the 4.4 section and adjusted the version to 4.5 and it went well.

    It is up and runng fine. It isn't a production server but one that I am using for School and self education. I appreciate your help. But I am wondering why I have to use /sbin/xxx or even /usr/sbin/xxx

    Could there be a PATH problem?

    Thanks for your time.
     
    Last edited: May 25, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Your PATH variable doesn't seem to contain /sbin and /usr/sbin. What's the output of
    Code:
    echo $PATH
    ?
     
  5. ghostrider.002

    ghostrider.002 New Member

    Here is the output of 'echo $PATH'

    [email protected]:~> echo $PATH
    /opt/kde3/bin:/home/joseph/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/ games:/opt/gnome/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/us r/lib/qt3/bin


    Thanks again
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That's the output of the user joseph. But you ran the above commands (postconf ,etc.) as root, didn't (you should have)?
    So please post the output of
    Code:
    echo $PATH
    for the root user.
     
  7. ghostrider.002

    ghostrider.002 New Member

    Here you go.

    Didn't realize that, and yes I ran everything as root for the tutorial.

    [email protected]:~> su
    Password:
    ghost-10:/home/joseph # echo $PATH
    /opt/kde3/bin:/home/joseph/bin:/usr/local/bin:/usr/bin:/sbin:/usr/X11R6/bin:/usr/sbin:/bin:/usr/games:/opt/gnome/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/lib/qt3/bin
     
  8. falko

    falko Super Moderator ISPConfig Developer

    But /sbin and /usr/sbin are both in root's PATH... Are you absolutely sure you ran the commands as root?
     

Share This Page