The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server) - Page4-DNS Server

Discussion in 'Installation/Configuration' started by Linocks, May 12, 2008.

  1. Linocks

    Linocks New Member

    The DNS won't start in the above installation process. It starts after the installation of bind9 but won't start after I run the commands to run BIND Chrooted.:confused: Please see attached file.
     
  2. Linocks

    Linocks New Member

    Below are the :

    Contents of /etc/default/bind9

    OPTIONS="-u bind -t /var/lib/named"
    # Set RESOLVCONF=no to not run resolvconf
    RESOLVCONF=yes

    AND the :


    Contents of /etc/default/syslogd


    #
    # Top configuration file for syslogd
    #

    #
    # Full documentation of possible arguments are found in the manpage
    # syslogd(8).
    #

    #
    # For remote UDP logging use SYSLOGD="-r"
    #
    SYSLOGD="-a /var/lib/named/dev/log"
     
  3. Rocky

    Rocky New Member

    Did you disable apparmor? If not, try the following:
    Disable AppArmor
    /etc/init.d/apparmor stop
    update-rc.d -f apparmor remove

    After that, restart bind. If it works, then you're good to go, if not, then try redoing the following steps:

    Create the necessary directories under /var/lib:
    mkdir -p /var/lib/named/etc
    mkdir /var/lib/named/dev
    mkdir -p /var/lib/named/var/cache/bind
    mkdir -p /var/lib/named/var/run/bind/run

    Then move the config directory from /etc to /var/lib/named/etc:
    mv /etc/bind /var/lib/named/etc

    Create a symlink to the new config directory from the old location (to avoid problems when bind gets updated in the future):
    ln -s /var/lib/named/etc/bind /etc/bind

    Make null and random devices, and fix permissions of the directories:
    mknod /var/lib/named/dev/null c 1 3
    mknod /var/lib/named/dev/random c 1 8
    chmod 666 /var/lib/named/dev/null /var/lib/named/dev/random
    chown -R bind:bind /var/lib/named/var/*
    chown -R bind:bind /var/lib/named/etc/bind

    After that, restart sysklogd and bind.
     
  4. Linocks

    Linocks New Member

    Thanks! It worked after I removed 'apparmor'. :eek: :eek:

    I guess it comes down to RFQ or (RFI - 'Read the F**&$ng Instructions).

    My "handy" assistant assured me that all the instructions had been followed. I guess "... if you want something doing properly you should do it yourself!"
     

Share This Page