The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10) w/ISPConfig

Discussion in 'HOWTO-Related Questions' started by giganet, Dec 24, 2008.

  1. giganet

    giganet New Member

    Hello HTF group...:D
    I am following the HTF Tutorial beyond the part detailing installation of Ubuntu 7.10: http://www.howtoforge.com/perfect_server_ubuntu7.10
    Presently I am having trouble when Sending OR Receiving Email from this server.
    I receive the following error from ThunderBird which I configured to use TLS and have setup the SMTP to authenticate using a valid Email User usr & pwd for the mentioned mail server.

    When Checking Email (ThunderBird Client)
    1)
    Code:
    Sending of password did not succeed. Mail server mail.my-domain.net responded teporary problem, please try again later.
    
    When Attempting to Send Email (ThunderBird Client)
    2)
    Code:
    ThunderBird continuously prompts for password
    
    When I cancel on password prompt I rececive the following error when trying to send Email.
    2 cont.)
    Code:
    Sending of message failed.   The message could not be sent because the connecting SMTP server mail.my-domain.net failed.  The server may be unavailable or refusing SMTP connections.   Please verify that your SMTP server setting is correct and try again, or else contact your network adminsitrator.
    To check SMTP connectivity I ran: 'telnet localhost 25'
    I receive the following:

    'Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 my-domain.net ESMTP Postfix (Ubuntu)'

    Then when I run the following: 'ehlo'

    The server returns: '501 Syntax: EHLO hostname'

    I have sent Emails from other servers and don't receive any bounce-backs or failure notices.
    I have been going back through settings but can't locate an answer yet, where might my errors be?
    I have tried recreating the SSL cert following the instructions on this same tutorial 4 times now while still receiving the same error.

    Thank you
    Regards
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in /var/log/mail.log?

    You must run
    Code:
    ehlo localhost
    in telnet, not just
    Code:
    ehlo
     
  3. giganet

    giganet New Member

    Thank you very much Falko

    I ran cat /var/log/mail.log and yes it did seem to want to continue printing errors before I finally ran 'ctrl-c', but here is a sampling of the errs from mail.log file:

    INFO UPDATE A/1: My error in the post last night, yes I did run 'ehlo localhost' and all was good after running that command.

    Code:
    Dec 24 07:34:12 my-domain postfix/qmgr[30658]: B8614359631B: from=<[EMAIL="[email protected]"][email protected][/EMAIL]>, size=2240, nrcpt=1 (queue active)
     
    Dec 24 07:30:08 my-domain postfix/error[13300]: 2956535958E2: to=<[EMAIL="[email protected]"][email protected][/EMAIL]>, relay=none, delay=309052, delays=308996/57/0/0.01, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=construtel.com.br type=MX: Host not found, try again)
    
    Anyhow, I just this morning decided that beings I screwed up initially by following the 'Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)'
    That I should start all over but using the tutorial 'The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10)'

    So when I get to section '11 Quota' I am at a wall when running the following comand(s).

    Code:
    touch /quota.user
    I receive this err: touch: cannot touch `/quota.user': Permission denied

    INFO UPDATE A/2: Falko I wanted to let you know that I am running as 'root su' when I receive the errors above while trying to 'touch' quota.
    I am betting this has everything to with what ever was changed when folowing the virtual tutorial?
    What will I need to do to get past this error?

    INFO UPDATE A/3: I have been looking over the first tutorial I attempted using which if I would of red tells me it was intended for deb sarge, should I go back through that tutorial and remove files such as: mysql-virtual_mailbox_limit_maps.cf, virtusertable~, mysql-virtual_domains.cf, mysql-virtual_transports.cf, virtusertable.db, mysql-virtual_email2email.cf, mysql-virtual_forwardings.cf, mysql-virtual_mailboxes.cf

    Located in: /etc/postfix

    Not to mention other files created that don't pertain to the UBUNTU 7.10 Perect Server tutorial?

    Thank you Falko
    Regards

    Best wishes for everyone
     
    Last edited: Dec 25, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    You must be root when you run this command:
    Code:
    sudo su
    touch /quota.user
    (or run
    Code:
    sudo touch /quota.user
    )
     
  5. giganet

    giganet New Member

    Thank you Falko

    Yes I am logged in as 'root' when receiving the err:confused:.
    Code:
    root@my-domain:/home/bender# sudo touch /quota.user
    touch: cannot touch `/quota.user': Permission denied
    Best Regards
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you disable AppArmor?
    What's the output of
    Code:
    ls -la /
    ?
     
  7. giganet

    giganet New Member

    Thank you Falko

    Hmm, I did some extra searching the net last night and found a handy group of commands that pertains to 'quota'.

    After running 'quotaoff /' I was able to proceed onto completion of the Ubuntu Gutsy Gibbon (Ubuntu 7.10 w/ISPConfig) tutorial.

    At this point this is the condition of functionality:

    1) When I try to send Email from this server I am perpetually prompted for the SMTP server password which is for the web_admin email account.
    If I cancel the send process TBird returns the err;
    Code:
    Sending of message failed. The message could not be sent because connecting to SMTP server mail.my-domain.net failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMPT server setting is correct and try again, or else contact your Network Administrator.
    In TBird I have configured the SMTP to use this server mail.my-domain.net using the web_admin usr/pwd for TLS and have enabled 'Use Secure Connection' with the TLS RADIO enabled.
    After settings are made I restart TBird but still get same result.

    2) Likewise when I attempt to receive Email I am prepetually prompted for the password and what's wierd is I am being prompted by TBird to accept a cert from another one of my servers even though I have double checked my POP settings for the .NET account I am working with presently??

    I have deleted ALL SSL certs in TBird and restarted it to be faced with the same event.

    3) I can send Email to this Email server from an outside server and recieve no undelivered messages at the outside server yet I am unable to retreive the Email on the .NET server due to the password looping issue defined above.

    From the CLI I am able to connect to the SMTP server running:
    'telnet localhost 25'
    And upon connection I run 'ehlo localhost' and all is well.
    After 'quit' I try 'telnet localhost pop3' and receive:

    Code:
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    +OK Hello there.
    Then 'quit' all seems good there.

    main.cf output:
    Code:
    # Source: .NET main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
     
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    #Do not en-able when using with ISPConfig.
    #home_mailbox = Maildir/
    # Uncomment the next line to generate "delayed mail" warnings
    delay_warning_time = 30m
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    myhostname = my-domain.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = my-domain.net, localhost.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    ## mydestination = /etc/postfix/local-host-names
    ## transport_maps = hash:/etc/postfix/transport
    ## relay_domains = hash:/etc/postfix/relay-host-names
    

    master.cf output
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_enforce_tls=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,rejec
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
            -o smtp_fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    
    POST EDIT: I fogot to add this finding, last night when I exited PuTTY I received the 'You have new mail in /var/mail/my-server'
    Below are the contents of that mail:
    Code:
    From [email protected]  Thu Dec 25 21:45:54 2008
    Return-Path: <[email protected]>
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: from localhost (localhost.localdomain [127.0.0.1])
            by my-server.net (Postfix) with ESMTP id 03F4835941F7
            for <[email protected]>; Thu, 25 Dec 2008 03:18:14 -0800 (PST)
    X-Virus-Scanned: Debian amavisd-new at my-server.net
    Received: from my-server.net ([127.0.0.1])
            by localhost (my-server.net [127.0.0.1]) (amavisd-new, port 10024)
            with ESMTP id TmSayPUCcAtC for <[email protected]>;
            Thu, 25 Dec 2008 03:18:03 -0800 (PST)
    Received: by my-server.net (Postfix, from userid 114)
            id 102F535941F6; Thu, 25 Dec 2008 03:18:02 -0800 (PST)
    From: [email protected] (Cron Daemon)
    To: [email protected]
    Subject: Cron <amavis@my-server> test -e /usr/sbin/amavisd-new-cronjob && /usr/sbin/amavisd-new-cronjob sa-sync
    Content-Type: text/plain; charset=UTF-8
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/var/lib/amavis>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=amavis>
    Message-Id: <[email protected]>
    Date: Thu, 25 Dec 2008 03:18:02 -0800 (PST)
    
    config: unparseable chars in 'if you are running SA 3.0.0 or higher, you already have antidrug and this file': '3.0.0'
    

    Output from '/var/log/mail.log'
    Code:
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 55F2F1C882A5: removed
    Dec 26 07:46:21 my-domain postfix/pickup[9956]: 2AF301C8819B: uid=10073 from=<web44_anzatowndog>
    Dec 26 07:46:21 my-domain postfix/cleanup[8059]: 2AF301C8819B: message-id=<[email protected]>
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 2AF301C8819B: from=<[email protected]>, size=412, nrcpt=1 (queue active)
    Dec 26 07:46:21 my-domain postfix/pickup[9956]: 3A89C1C882A5: uid=10058 from=<web44_janeb>
    Dec 26 07:46:21 my-domain postfix/cleanup[8067]: 3A89C1C882A5: message-id=<[email protected]>
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 3A89C1C882A5: from=<[email protected]>, size=393, nrcpt=1 (queue active)
    Dec 26 07:46:21 my-domain postfix/smtp[772]: 2AF301C8819B: to=<[email protected]>, relay=none, delay=0.11, delays=0.03/0/0.08/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=localhost.localdomain type=AAAA: Host not found)
    Dec 26 07:46:21 my-domain postfix/cleanup[10780]: 403771C882CE: message-id=<[email protected]>
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 403771C882CE: from=<>, size=2388, nrcpt=1 (queue active)
    Dec 26 07:46:21 my-domain postfix/bounce[8403]: 2AF301C8819B: sender non-delivery notification: 403771C882CE
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 2AF301C8819B: removed
    Dec 26 07:46:21 my-domain postfix/smtp[8402]: 3A89C1C882A5: to=<[email protected]>, relay=none, delay=0.09, delays=0.04/0/0.05/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=localhost.localdomain type=AAAA: Host not found)
    Dec 26 07:46:21 my-domain postfix/cleanup[8059]: 48F501C8819B: message-id=<[email protected]>
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 48F501C8819B: from=<>, size=2357, nrcpt=1 (queue active)
    Dec 26 07:46:21 my-domain postfix/bounce[6498]: 3A89C1C882A5: sender non-delivery notification: 48F501C8819B
    Dec 26 07:46:21 my-domain postfix/qmgr[14646]: 3A89C1C882A5: removed
    Dec 26 07:46:23 my-domain postfix/local[16313]: 60B121C882E8: to=<[email protected]>, relay=local, delay=182, delays=0.01/170/0/13, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Dec 26 07:46:23 my-domain postfix/qmgr[14646]: 60B121C882E8: removed
    Dec 26 07:46:23 my-domain postfix/pickup[9956]: ACC571C882A5: uid=10063 from=<web44_wstrn>
    Dec 26 07:46:23 my-domain postfix/cleanup[8067]: ACC571C882A5: message-id=<[email protected]>
    Dec 26 07:46:23 my-domain postfix/qmgr[14646]: ACC571C882A5: from=<[email protected]>, size=392, nrcpt=1 (queue active)
    Dec 26 07:46:23 my-domain postfix/smtp[8402]: ACC571C882A5: to=<[email protected]>, relay=none, delay=0.1, delays=0.05/0/0.06/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=localhost.localdomain type=AAAA: Host not found)
    Dec 26 07:46:23 my-domain postfix/cleanup[10780]: BC5B41C882D7: message-id=<[email protected]>
    Dec 26 07:46:23 my-domain postfix/qmgr[14646]: BC5B41C882D7: from=<>, size=2356, nrcpt=1 (queue active)
    Dec 26 07:46:23 my-domain postfix/bounce[8403]: ACC571C882A5: sender non-delivery notification: BC5B41C882D7
    Dec 26 07:46:23 my-domain postfix/qmgr[14646]: ACC571C882A5: removed
    Dec 26 07:46:24 my-domain postfix/local[17768]: 396C31C8826E: to=<[email protected]>, relay=local, delay=36, delays=0/24/0/12, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Dec 26 07:46:24 my-domain postfix/qmgr[14646]: 396C31C8826E: removed
    Dec 26 07:46:24 my-domain postfix/pickup[9956]: 9A73D1C8826E: uid=10025 from=<web44_webmin>
    Dec 26 07:46:24 my-domain postfix/cleanup[8059]: 9A73D1C8826E: message-id=<[email protected]>
    Dec 26 07:46:24 my-domain postfix/qmgr[14646]: 9A73D1C8826E: from=<[email protected]>, size=408, nrcpt=1 (queue active)
    Dec 26 07:46:24 my-domain postf
    

    Thanking you in advance for your help and time Falko :)

    Best Regards
     
    Last edited: Dec 27, 2008
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?

    Does sending and receiving work when you switch off secure connections?
     
  9. giganet

    giganet New Member

    Hello Falko thank you...

    MySQL db find : Falko, I logged into my .COM server which is also configured running ISPConfig PostFix, Courier, etc, using TLS authentication.
    What I found was that the .COM server when logged into MyPHPAdmin DOES NOT have a Mail db, rather it only has the ISPConfig db and it's Email system works fine.

    When logged into my .NET server using MyPHPAdmin I find that in addition to the ISPConfig db the .NET server also has a Mail db
    too which I created when I wrongly chose to follow the Debian based Tutorial at first which did not support ISPConfig!

    I am not sure but I feel rather confident that this is the chief cause of the issue I have been dealing with??
    Would you suggest I delete the Mail db from my .NET server beings this server also runs ISPConfig which should make TLS based POP3 & SMTP authentication function properly then- At least it seams that way to me (my desperation to get my client Email service restored).

    The output of '/etc/hosts'
    Code:
    127.0.0.1       localhost.localdomain localhost
    65.197.209.3    giganetwireless.net     Bender
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    I then logged into another server and saw an immediate difference!
    on the first line at the end it also defined the FQD for that server so I changed this new server to be as follows now:
    Code:
    127.0.0.1       localhost.localdomain localhost giganetwireless.net
    65.197.209.3    giganetwireless.net     Bender
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    After this I ran '/etc/init.d/networking restart'

    TO disable secure I set 'smtpd_use_tls = no'
    AND
    'smtpd_tls_auth_only = no'
    AND
    'smtpd_sasl_auth_enable = no'

    Then I ran '/etc/init.d/postfix restart'

    After making the above changes to the server I reconfigured TBird not to use TLS in both POP & SMTP.
    I am still unable to send or receive from this server however...

    Thank you Falko

    Regards
     
    Last edited: Dec 28, 2008
  10. falko

    falko Super Moderator ISPConfig Developer

    Please change this line:
    Code:
    ::1 ip6-localhost ip6-loopback
    so that it looks as follows:
    Code:
    ::1 ip6-localhost ip6-loopback localhost.localdomain
     
  11. giganet

    giganet New Member

    Thank you Falko

    I am going to delete the second db, I mentioned last night.

    I edited my .NET server hosts file to look as:
    '127.0.0.1 localhost.localdomain localhost giganetwireless.net
    65.197.209.3 giganetwireless.net Bender
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback localhost.localdomain
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts'

    After doing this I ran '/etc/inist.d/postfix restart' but I still get the same results, login failure for send/receive Email.

    Can I ask why I would need the IPV6 line on this server when it does not exist on my .COM server which functions fine?

    My .COM server hosts file appears as follows:
    '127.0.0.1 localhost.localdomain localhost giganetwireless.com
    65.197.209.2 giganetwireless.com Leela
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts'

    Wouldn't having the additional MySQL db as I mentioned cause this issue?
    My .COM server only has one MySQL db that caters to ISPConfig.
    While my .NET server has a Mail db and an ISPConfig db

    THanking you in advance for your help and time Falko...

    Regards
     
    Last edited: Dec 28, 2008
  12. falko

    falko Super Moderator ISPConfig Developer

    You set up the "Virtual Postfix" tutorial on the .net server, right? Please undo that stuff.
     
  13. giganet

    giganet New Member

    Hello Falko, thank you...

    I went back and removed all files, dirs and changes from the "Virtual Postfix" Tutorial.

    After this I picked up on the "The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10)" at page 3 and continued through this Tutorial to the end.

    After completing this Tutorial and reconfiguring TBird to use TLS for the test account on this .NET server TBird donwloaded 25 pieces of EMail which I sent from one of my .COM accounts over last weekend.
    POP3 Authorization Update: I am able to successfully authenticate POP3 in TBird on the .NET server


    However I have the following issues when tying to Send & Receive of Email at the .NET account.

    1) From a .COM Email account I just sent a test Email to the .NET server. The .COM account reveived a Delayed Mail (still being retried) Email notice?

    2) When I attempt to send Email from the .NET server eventually TBird returns the following error.
    Code:
    Sending of message failed. The message could not be sent because connecting to SMTP server mail.giganetwireless.net failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP setting is correct and try again, or else contact your network administrator.
    When I run the command(s):
    Code:
    telnet localhost 25
    OR

    Code:
    telnet giganetwireless.net 25
    All looks good with the following:
    '250-giganetwireless.net
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN'


    When I run:
    'telnet localhost pop3'
    OR
    'telnet giganetwireless.net pop3'

    The server returns:
    'Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    +OK Hello there.'

    After I type: 'quit'
    '+OK Better luck next time.'

    In TBird I have deleted ALL SSL certs and then restart the Email Client.

    Also I have validated the SMTP settings for the .NET account to use: TLS, Username & Password.
    In the username field I populated it with the username of the .NET test account.

    Here is a sampling of the output of: 'cat /var/log/mail.log'
    Code:
    Dec 29 15:33:51 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:34:38 giganetwireless postfix/smtpd[4318]: connect from unknown[212.12.255.157]
    Dec 29 15:34:51 giganetwireless postfix/trivial-rewrite[4337]: fatal: open database /etc/postfix/transport.                                                  db: No such file or directory
    Dec 29 15:34:51 giganetwireless postfix/smtpd[4336]: connect from localhost.localdomain[127.0.0.1]
    Dec 29 15:34:52 giganetwireless postfix/master[4281]: warning: process /usr/lib/postfix/trivial-rewrite pid                                                   4337 exit status 1
    Dec 29 15:34:52 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:34:58 giganetwireless postfix/smtpd[4336]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 29 15:35:37 giganetwireless postfix/smtpd[4336]: connect from rv-out-0708.google.com[209.85.198.249]
    Dec 29 15:35:52 giganetwireless postfix/trivial-rewrite[4359]: fatal: open database /etc/postfix/transport.                                                  db: No such file or directory
    Dec 29 15:35:53 giganetwireless postfix/master[4281]: warning: process /usr/lib/postfix/trivial-rewrite pid                                                   4359 exit status 1
    Dec 29 15:35:53 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:36:53 giganetwireless postfix/trivial-rewrite[4372]: fatal: open database /etc/postfix/transport.                                                  db: No such file or directory
    Dec 29 15:36:54 giganetwireless postfix/master[4281]: warning: process /usr/lib/postfix/trivial-rewrite pid                                                   4372 exit status 1
    Dec 29 15:36:54 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:37:14 giganetwireless postfix/smtpd[4379]: connect from smtp76.mansellgroup.net[67.90.143.76]
    Dec 29 15:37:14 giganetwireless postfix/smtpd[4379]: lost connection after HELO from smtp76.mansellgroup.ne                                                  t[67.90.143.76]
    Dec 29 15:37:14 giganetwireless postfix/smtpd[4379]: disconnect from smtp76.mansellgroup.net[67.90.143.76]
    Dec 29 15:37:31 giganetwireless postfix/smtpd[4379]: connect from pc-43-115-241-201.cm.vtr.net[201.241.115.                                                  43]
    Dec 29 15:37:54 giganetwireless postfix/trivial-rewrite[4393]: fatal: open database /etc/postfix/transport.                                                  db: No such file or directory
    Dec 29 15:37:55 giganetwireless postfix/master[4281]: warning: process /usr/lib/postfix/trivial-rewrite pid                                                   4393 exit status 1
    Dec 29 15:37:55 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:38:03 giganetwireless postfix/smtpd[4396]: connect from 201-213-51-230.net.prima.net.ar[201.213.5                                                  1.230]
    Dec 29 15:38:30 giganetwireless postfix[4403]: fatal: usage: postfix [-c config_dir] [-Dv] command
    Dec 29 15:38:55 giganetwireless postfix/trivial-rewrite[4410]: fatal: open database /etc/postfix/transport.                                                  db: No such file or directory
    Dec 29 15:38:56 giganetwireless postfix/master[4281]: warning: process /usr/lib/postfix/trivial-rewrite pid                                                   4410 exit status 1
    Dec 29 15:38:56 giganetwireless postfix/master[4281]: warning: /usr/lib/postfix/trivial-rewrite: bad comman                                                  d startup -- throttling
    Dec 29 15:39:06 giganetwireless postfix/smtpd[4423]: connect from hermes.fuom.br[200.149.221.226]
    Dec 29 15:39:12 giganetwireless postfix/smtpd[4426]: connect from 201-213-51-230.net.prima.net.ar[201.213.5                                                  1.230]
    Dec 29 15:39:12 giganetwireless postfix/smtpd[4426]: lost connection after CONNECT from 201-213-51-230.net.                                                  prima.net.ar[201.213.51.230]
    Dec 29 15:39:12 giganetwireless postfix/smtpd[4426]: disconnect from 201-213-51-230.net.prima.net.ar[201.21                                                  3.51.230]
    Dec 29 15:39:14 giganetwireless postfix/smtpd[4426]: connect from 201-213-51-230.net.prima.net.ar[201.213.5                                                  1.230]
    

    Here are the output(s) of:
    'hostname'
    giganetwireless.net

    &&

    'hostname -f'
    localhost.localdomain


    The content of '/etc/hosts'
    Code:
    127.0.0.1       localhost.localdomain localhost giganetwireless.net
    65.197.209.3    giganetwireless.net     Bender
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback localhost.localdomain
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    

    Once again Falko I thank you in advance for your help :)

    Regards
     
    Last edited: Dec 30, 2008
  14. falko

    falko Super Moderator ISPConfig Developer

    Does mail.giganetwireless.net exist and point to the correct server?

    What's in /etc/postfix/main.cf on the .net server?
     
  15. giganet

    giganet New Member

    Thank you Falko...

    Yes the DNS records for 'mail.giganetwireless.net' exist in DNSExit and are pointing to 65.197.209.3, a MX record also exists in ISPconfig too.
    Using a remote ping application I am able to ping 'mail.giganetwireless.net' successfully.

    The contents of /etc/postfix/main.cf:

    Code:
    # Source: .NET main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
     
    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    #Do not en-able when using with ISPConfig.
    #home_mailbox = Maildir/
    # Uncomment the next line to generate "delayed mail" warnings
    delay_warning_time = 30m
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    myhostname = giganetwireless.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = giganetwireless.net, localhost.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    transport_maps = hash:/etc/postfix/transport
    mailman_destination_recipient_limit = 1
    ## relay_domains = hash:/etc/postfix/relay-host-names
    [\code]
     
    I am not sure what happened after re-doing this Tutorial but all of the hosted web-sites are inaccessible now.
    So far I have tried to restart 'bind9' & 'ispconfig_server' trying to resolve this but still no luck...
     
    ISPConfig is accessible by browser though at the .NET server...
     
    Thank You Falko
     
    Regards
     
    Last edited: Dec 31, 2008
  16. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/postfix
    , and what's in /etc/postfix/transport?
     
  17. giganet

    giganet New Member

    Thank you Falko...

    Services Monitoring Info Falko I thought I would share this additional info with you;
    I use the MikroTik Dude to monitor my network, when I look at the monitoring stats for the .NET server the services 'ping, dns & POP3' are all UP while 'http & smtp' are in an UNKNOWN state.


    The output of 'ls -la /etc/postfix':
    Code:
    total 128
    drwxr-xr-x   4 root root  4096 2008-12-30 15:05 .
    drwxr-xr-x 101 root root 12288 2008-12-30 18:14 ..
    -rw-r--r--   1 root root   373 2008-12-22 20:23 dynamicmaps.cf
    -rw-r--r--   1 root root   416 2008-12-29 18:27 local-host-names
    -rw-r--r--   1 root root   416 2008-12-29 18:27 local-host-names~
    -rw-r--r--   1 root root  2052 2008-12-29 13:53 main.cf
    -rw-r--r--   1 root root  1817 2007-11-02 07:46 main.cf.orig
    -rw-r--r--   1 root root  4034 2008-12-25 19:08 master.cf
    -rw-r--r--   1 root root 18116 2007-10-05 18:19 postfix-files
    -rwxr-xr-x   1 root root  7121 2007-10-05 18:19 postfix-script
    -rwxr-xr-x   1 root root 22197 2007-10-05 18:19 post-install
    -rw-r--r--   1 root root     0 2008-12-25 17:31 quota
    drwxr-xr-x   2 root root  4096 2008-12-29 14:08 sasl
    drwxr-xr-x   2 root root  4096 2008-12-29 15:31 ssl
    -rw-r--r--   1 root root     0 2008-12-25 17:31 .users
    -rw-r--r--   1 root root  6152 2008-12-29 18:27 virtusertable
    -rw-r--r--   1 root root  6152 2008-12-29 18:27 virtusertable~
    -rw-r--r--   1 root root 12288 2008-12-29 18:27 virtusertable.db
    

    The contents of '/etc/postfix/transport':
    Hmm, I used 'vi' and it opened a "NEW" file :eek:...?


    Regards Falko
     
    Last edited: Jan 1, 2009
  18. falko

    falko Super Moderator ISPConfig Developer

    The file doesn't exist. Please remove the line
    Code:
    transport_maps = hash:/etc/postfix/transport
    from /etc/postfix/main.cf and restart Postfix.
     
  19. giganet

    giganet New Member

    Thank you once again Falko!

    I am bookmarking all of my posts for later use as reference.

    Happy New Year Falko

    Best Regards
     

Share This Page