The perfect Server Ubuntu 8.04 -- got STUCK

Discussion in 'Installation/Configuration' started by jlaudz, Oct 31, 2008.

  1. jlaudz

    jlaudz New Member

    hello All, Im pretty new to Ubuntu though been using the ubuntu desktop more than a year and mostly openoffice, so now I decided to try UBUNTU server edition 8.04. found an old PIII 866 MHz which now my host hardware. everything on board just added power supply, HD and memory.

    I have read "The Perfect Server ...." ver 8.04 and follow direction except I selected all the option instead of installing it one by one.

    http://www.howtoforge.com/perfect-server-ubuntu8.04-lts-p3

    I got stuck on step 7: /etc/init.d/networking restart resulting an Error regarding eth0.
    eth0: error while getting interface flags: no such devices... failed eth0... somthing like that.

    I found solution from other forum of which recommended to edit /etc/udev/rules.d/70-persistent-net.rules of which I did.

    I pass that process (I think) but when I got into the next one /etc/hosts...
    then

    hostname
    hostname -f

    I'm not getting same value, and hostname -f actually an error: lookup fail.

    pls help... I'm stuck, spend lot of hours last night looking for solution. Is this problem related to above, because I edited ...-net.rules???

    thanks in advance

    jlaudz@yahoo.com
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to reboot the system?
     
  3. jlaudz

    jlaudz New Member

    Hi, and thanks for the reply...
    Yes, I rebooted multiple times, even tried to complete this under user with sudo instead of root account... no success.:confused:

    I also can ping other PCs on my lan and other intrnet sites.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/network/interfaces? Do you remember how it looked before you changed it?
    Does the system have one or more than one network interfaces?
     
  5. jlaudz

    jlaudz New Member

    hi, I can remember exacty but it look something like this...

    #PCI **something here *** (8139too)
    SUBSYSTEM== ** somehere like TYPE, ATTR, MAC address...then**, NAME=="eth0"

    #PCI **something here *** (e100)
    SUBSYSTEM== ** somehere like TYPE, ATTR, MAC address...then**, NAME=="eth1"

    I deleted first #PCI & SUBSYSTEM line and change NAME== from eth1 to eth0 on the second group to look like this:

    #PCI **something here *** (e100)
    SUBSYSTEM== ** somehere like TYPE, ATTR, MAC address...then**, NAME=="eth0" <--- change from eth1
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That looks strange. What's in /etc/network/interfaces now?
     
  7. jlaudz

    jlaudz New Member

    Hi falko, I decided to restart installation from start, and do manual installation just like on the procedure. I sucesfully finish install, but I cant seem to access the server.

    using a LAN connected PC, I can ping server1 using the IP address but I can not ping it using server1.example.com or www.example.com or simply example.com.

    I can also ping any website from the server1, but I can not ping any PC connected to my LAN, even using the IP address.

    I can connect to server1 using putty but with using IP address not hostname.

    FYI, my other PC is a vista connected wireless, and my workgroup is "HOME" how this affects my connection? any idea how to fix this???
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. jlaudz

    jlaudz New Member

    falko, technically i can do that to all of my PC, but I forgot to tell that theres other PC/laptop (guest) that not uder my control of which also connect to my home network.

    Is theres a way to configure the server instead to accomplish this??? what are the steps?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You'd have to set up an internal DNS server and make the client PCs use that DNS server as the primary one.
     

Share This Page