The Perfect Server - Ubuntu 18.04 sudden Gmail issue

Discussion in 'Installation/Configuration' started by Tastiger, Mar 5, 2020.

  1. Tastiger

    Tastiger Member

    Sorry if this has been covered before.
    The last couple of days I have started to get Undelivered Mail Returned to Sender from Gmail.
    The text of the undelivered email is as follows:
    Help!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if your IPv6 address has no PTR record. Add the PTR record (probably in the control panel of your server hosting provider).
     
  3. Tastiger

    Tastiger Member

    OK, I thought I did have it set, as this problem only started in the last day or so, can you advise where to check and how to add the record for IPv6?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Contact the datacenter or internet access provider that assigned you this IP. The record needs to be set on their DNS server.
     
  5. Tastiger

    Tastiger Member

    I noticed somewhere else in the forums that what you have suggested does not apply if I have a static IP - is this correct?
     
  6. Steini86

    Steini86 Active Member

    Where?
    What suggestion? Adding a PTR record? This is 'always' needed in order to send mails to gmail
    A static IP is perfect for mail servers.

    Looks like you are mixing things up.
    A / AAAA record: For a given domain gives the IPv4/IPv6 (To be set with the domain registrar)
    PTR: For a given IPv4/IPv6 gives the domain name (To be set where your IP belongs to)

    If your mail server connects to Google, they want to know who you are. From the connection they have the sender IP, so they look up the PTR for that IP to get the domain name of the sending server.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No, a PTR is always needed. Contact the datacenter and ask them to set it if they don't provide you with a console to set it yourself.
     
  8. Tastiger

    Tastiger Member

    Till's reply was
    Contact the datacenter or internet access provider that assigned you this IP. The record needs to be set on their DNS server.
    Because I have 3 domains do I need to request that all 3 are set on their DNS?
    I admit I am lost as Gmail is not making things "user friendly" in this case
     
    Last edited: Mar 9, 2020
  9. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    You have to set the PTR to the hostname of your server, and make sure the hostname of Postfix is configured to the hostname of your server aswell. Also, you didn't hide your domains in the screenshots, but it seems like you tried to, so you might want to delete those screenshots.

    I advise you to learn some more about email. You will have to understand the basics before running your own mailserver.
     
  10. Steini86

    Steini86 Active Member

    No. As I wrote before, there are two different things.

    a) Domain Name -> IP
    This is your DNS settings of A and AAAA record.
    It has to be done by the owner of the domain

    b) IP -> Domain Name
    This has to be done by the owner of the IP

    The IP is owned by the company where you are renting your server. In their interface you have to set the PTR record

    You need to make one entry per IP, so that is one IPv4 entry and one IPv6 entry.

    Google is very clear. It does not have to be "user" friendly, because if you administrate a mail server, you are not a user but an admin.


    The problem is:
    Your mail domain is mail.polyXYZ.org.au and the IP 110.141.196.2XX. When you connect to the google mail server they look who is the owner of that IP and they get:
    Code:
    # host 110.141.196.xxx                                                                                                       
    xxx.196.141.110.in-addr.arpa domain name pointer cpe-110-141-196-xxx.vic.asp.telstra.net
    That is the standard setting of your hoster. And then they tell you that this is not the Server that is supposed to send mails.
     
    Last edited: Mar 9, 2020
  11. Tastiger

    Tastiger Member

    I am not renting their server, it is my own server on a static IP so there is no interface on their server to edit and there have been no issues with Gmail until a couple of days ago
     
  12. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    If you have it cohosted you should still be able to set up a PTR record. This is necessary for not only gmail but a lot of email providers - My servers do a SPF check aswell.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    It's your own server but someone (company / ISP) must provide the internet access to this server and must have assigned you this IP. And that's the one that you must contact to set the correct IPv6 reverse record.
     
  14. Tastiger

    Tastiger Member

    I helpful reply would have been more use to me than suggesting I understand email - I have had no issues running my mailserver for the past 10 years with no issues until this Gmail issue appeared, which is why I have asked for advice - is this not what the forums are for - asking for advice?
     
  15. Steini86

    Steini86 Active Member

    You have to ask the owner of that IP to set the PTR record.

    However, I think there is another problem. You do not have an IPv6 address and Google claims there is a problem with your IPv6.
    Code:
    dig mail.polyXYZ.org.au|grep IN|grep A
    ;mail.polyXYZ.org.au.    IN    A
    mail.polyXYZ.org.au. 2821    IN    A    110.141.196.xxx
    Seems like somewhere on the connection is IPv6 but you do not support it. Try disabling IPv6 in your postfix:
    Code:
    postconf inet_protocols
    # If result is "all", then:
    postconf inet_protocols=ipv4
    service postfix restart
     
    Tastiger likes this.
  16. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    I did give you a answer to your question and along with that I gave you some advice, with a good intention :)
     
  17. Steini86

    Steini86 Active Member

    So, I did the work for you and searched for your provider and PTR records (was not to difficult, you could have done that yourself). First result:
    https://crowdsupport.telstra.com.au/t5/Home-Broadband/Reverse-DNS-on-our-Static-IP/td-p/849093
    They write:
    So: You can host websites. And you can use mail as long as(!) the receiver does not require you to have a PTR record (these will increase in the future).
    Try by disabling IPv6 (my previous post). Otherwise look for someone who can provide you an IPv4/IPv6 address and supports PTR
     
  18. Tastiger

    Tastiger Member

    Thanks,
    Giving that a try and see where it goes from there, otherwise may have to look at a business connection
     
    Steini86 likes this.

Share This Page