The Perfect Server - Fedora 7: no route to host

Discussion in 'HOWTO-Related Questions' started by v2k, Sep 4, 2007.

  1. v2k

    v2k New Member

    Firstly, I'd just like to say thanks for this HOWTO, it's excellent.

    I followed this guide through to setup my F7 server. The web server: apache/php/mysql works great and without any issues.

    I decided I needed to support mail and ftp, so I went back to the guide and went through the setup for postfix and proftpd.

    I think both are failing for the same reason. They both seem to fail with "No route to host". I'm behind a router. Both ports 21 and 25 are forwarded to the server; as 80 is for the web server.

    # ftp localhost
    => works fine

    # ftp mydomainname
    => no route to host

    If I attempt to ftp to the server remotely, it times out and returns 'connection closed by remote host'.

    With sendmail, the maillog contains a couple errors:
    sendmail[5646]: l83LtcrQ005646: l83LtcrR005646: DSN: User unknown
    postfix/smtp[5815]: connect to[xx.xx.xx.145]: No route to host (port 25)
    This is my /etc/hosts file :
    Code:       localhost.localdomain   localhost server1
    ::1     localhost.localdomain   localhost
  2. v2k

    v2k New Member

    I tried disabling the software firewall:
    # /etc/init.d/iptables save
    # /etc/init.d/iptables stop
    This solved my ftp issue!

    Mailing [email protected], I get this:
    Sep  3 16:13:49 server1 postfix/local[6360]: DB3F231B02C3: to=<[email protected]>, relay=local, delay=0.05, delays=0.04/0/0/0, dsn=2.0.0, status=sent (delivered to maildir)
    Sep  3 16:13:49 server1 postfix/qmgr[5745]: DB3F231B02C3: removed
    Sep  3 16:13:49 server1 postfix/smtpd[6353]: disconnect from localhost.localdomain[]
    But mail still says I have no mail.
    Last edited: Sep 4, 2007
  3. v2k

    v2k New Member

    It looks like mail is working, it's just that "mail" returns no local mail.
  4. v2k

    v2k New Member

    mail says I have no mail; even though I can see files in my /Mailbox.

    Also, I can send mail, but receiving does not work. If I try to send mail to my domain, it bounces with:
    PERM_FAILURE: SMTP Error (state 13): 554 5.7.1 <[email protected]>: Relay access denied
  5. falko

    falko Super Moderator ISPConfig Developer

    How did you configure your email accounts?
  6. v2k

    v2k New Member

    I guess I have not setup any email accounts. Do I just do this via postfix? I just followed the guide, I'm no linux guru. I did not install ISPConfig and did not intend to. (maybe it would make my life easier)

    Is there a guide I should follow to do this? I guess I need to add a MX record to the dns as well?
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page