The Perfect Server - Fedora 12 x86_64 [ISPConfig 3] - Content Encoding Error

Discussion in 'HOWTO-Related Questions' started by Gryphon1962, Jan 25, 2010.

  1. Gryphon1962

    Gryphon1962 New Member

    The Perfect Server - Fedora 12 x86_64 [ISPConfig 3] - Content Encoding Error

    After following the great installation instructions, I get an error when I try to launch ISPConfig by typing http://myserver.mydomain.com:8080.

    In Firefox 3.5.6 I get:

    "Content Encoding Error

    The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    * Please contact the website owners to inform them of this problem."​

    In Chrome I get:

    "Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error."​

    Any help will be GREATLY appreciated.

    Thanks in advance for your assistance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your Apache error log?
     
  3. Gryphon1962

    Gryphon1962 New Member

    There are a few of the following, but none indicating the IP addresses from which I've tried to launch ISPConfig.

    [Tue Jan 26 21:53:11 2010] [error] [client 192.168.1.254] Directory index forbidden by Options directive: /var/www/html/
    [Tue Jan 26 21:55:05 2010] [error] [client 192.168.1.254] Directory index forbidden by Options directive: /var/www/html/

    I just tried to launch it again to see if it would place a new entry in the error_log file, but it did not.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is it possible that another service is already using port 8080? What's the output of
    Code:
    netstat -tap
    ?
     
  5. Gryphon1962

    Gryphon1962 New Member

    Here's the output of netstat -tap:

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:10024 *:* LISTEN 1476/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 1585/master
    tcp 0 0 *:mysql *:* LISTEN 1335/mysqld
    tcp 0 0 *:46890 *:* LISTEN 978/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 927/rpcbind
    tcp 0 0 *:ndmp *:* LISTEN 1812/perl
    tcp 0 0 *:ftp *:* LISTEN 1625/pure-ftpd (SER
    tcp 0 0 gryphon.thegryphongr:domain *:* LISTEN 1364/mydns
    tcp 0 0 localhost:domain *:* LISTEN 1364/mydns
    tcp 0 0 localhost:ipp *:* LISTEN 1021/cupsd
    tcp 0 0 *:smtp *:* LISTEN 1585/master
    tcp 0 0 gryphon.thegryphongro:55640 gy-in-f96.1e100.net:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:55644 gy-in-f96.1e100.net:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:37414 gy-in-f156.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:47877 a96-17-106-106.deploy.:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:37413 gy-in-f156.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:47212 a72-246-25-35.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:33986 gy-in-f149.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 localhost:39592 localhost:domain TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:44517 a96-17-106-152.deploy.:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:36600 gx-in-f101.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:36815 a72-246-25-19.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:34486 gy-in-f19.1e100.net:https ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:49499 a96-17-106-115.deploy.:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:50932 gy-in-f100.1e100.net:https ESTABLISHED 2703/google-chrome
    tcp 0 0 localhost:ndmp localhost:38220 ESTABLISHED 17330/perl
    tcp 0 0 gryphon.thegryphongro:60509 gy-in-f105.1e100.net:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:42030 a72-246-25-67.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:34004 gy-in-f149.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:50619 reserved-98.euroclick.:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:47173 a72-246-25-35.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:34065 gy-in-f149.1e100.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 localhost:38220 localhost:ndmp ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:59288 gy-in-f103.1e100.net:https ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:33840 gx-in-f97.1e100.net:https ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:52999 mpr4.ngd.vip.ac4.yahoo:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:33157 vwrp1.rhv.xpc-mii.net:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:32820 140.211.167.41:http ESTABLISHED 1597/abrtd
    tcp 0 0 localhost:52794 localhost:ftp TIME_WAIT -
    tcp 0 0 localhost:60549 localhost:http TIME_WAIT -
    tcp 0 0 localhost:60450 localhost:http CLOSE_WAIT 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:42090 a72-246-25-67.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:53744 http4.howtoforge.com:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:57267 72.32.153.176:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:50866 208.71.123.131:http ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:56898 gy-in-f95.1e100.net:https ESTABLISHED 2703/google-chrome
    tcp 0 0 gryphon.thegryphongro:55636 gy-in-f96.1e100.net:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:52992 mpr4.ngd.vip.ac4.yahoo:http TIME_WAIT -
    tcp 0 0 gryphon.thegryphongro:47921 a72-246-25-16.deploy.a:http ESTABLISHED 2703/google-chrome
    tcp 0 0 localhost:60449 localhost:http CLOSE_WAIT 2703/google-chrome
    tcp 0 0 *:imaps *:* LISTEN 1496/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1508/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 1502/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 1489/couriertcpd
    tcp 0 0 *:sunrpc *:* LISTEN 927/rpcbind
    tcp 0 0 *:webcache *:* LISTEN 1615/httpd
    tcp 0 0 *:http *:* LISTEN 1615/httpd
    tcp 0 0 *:ftp *:* LISTEN 1625/pure-ftpd (SER
    tcp 0 0 localhost6:domain *:* LISTEN 1364/mydns
    tcp 0 0 localhost6:ipp *:* LISTEN 1021/cupsd
    tcp 0 0 *:smtp *:* LISTEN 1585/master
    tcp 0 0 *:https *:* LISTEN 1615/httpd
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There is an apache listening on port 8080. But maybe you access the wrong server. Please use the internal IP address of the server in the browser instead of the hostname like this:

    http://192.168.1.123:8080
     
  7. Gryphon1962

    Gryphon1962 New Member

    Same result from using IP address.

    BTW, when I use Webmin to look at the virtual hosts configured in Apache, the host listening on 8080 lists the ISPConfig directory (/var/www/ispconfig/) as the document root for that Virtual Server.
     
  8. Gryphon1962

    Gryphon1962 New Member

    Any ideas?

    ANYONE?

    ANYONE?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately I have no idea what the problem is... :(
     
  10. omega13a

    omega13a New Member

    I'm having the same exact problem except I'm using CentOS 5... Any help will be greatly appreciated...

    Edit: Just to see if this was a sever configuration problem or not, I created a test PHP file: http://peeves.fedtrek.com:8080/phpinfo.php . As you can see the test file doesn't give any encoding error so my guess is that its something in ISPConfig itself...
     
    Last edited: Feb 20, 2010
  11. merisor

    merisor New Member

    I had the same problem the other day and I solved it by checking into php.ini that the parameter
    Code:
    display_errors = Off
    .
    After that, I restarted apache it worked.
    Anyway, the weird thing was that using a console web browser from the server (eg. links) the page rendered ok, even before modifying php.ini ,with the exception of calling some deprecated functions...
    Hope it helps,
    M.
     
  12. Gryphon1962

    Gryphon1962 New Member

    thanks for the suggestion. I tried that, but still have the same problem.
     
  13. corpus

    corpus New Member

    Gzip

    Hello to all
    same problem to me
    running a Joomla site got the same error
    Fix
    Set Gzip Page Compression to Off

    or open configuration.php file in your server and change
    Code:
            public $gzip = '1';
    to
    Code:
            public $gzip = '0';
    try to find the solution to have gzip
    i'll post again
    Thanks

    THE SOLUTION IS
    make sure than in
    /etc/php5/cgi/php.ini and /etc/php5/apache2/php.ini the zlib compression is On

    zlib.output_compression = On

    restart apache and is ok
     
    Last edited: Aug 7, 2011

Share This Page