The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 2]

Discussion in 'Installation/Configuration' started by Bikkies, Jun 14, 2009.

  1. Bikkies

    Bikkies New Member

    Journalled File Systems & Journalled Quotas

    Following the 100% spot on guide by Falko (follow step by step & you can't fail) http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig2 I come to the following on page 3 -
    Code:
    quotacheck -avugm
    When I run this I get the following warning -
    Code:
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    How does one switch to journaled quota?
     
    Last edited: Jun 15, 2009
  2. Bikkies

    Bikkies New Member

    G'day Falko
    Is there no answer to this?
    From searching Google, etc it seems that many folks would like to implement this but no one can provide any real answers.
    Closest I have come so far is post #12 by palo_m @ http://www.uluga.ubuntuforums.org/showthread.php?p=7077864

    Would it be correct to assume then that something like this should go in /etc/fstab ?
    Code:
    /dev/hda1    /     ext3    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsold   0   1
    palo_m mentions that
    It seems as though we are using the old format here as he mentions that the new format is for if the filenames are aquota.user & aquota.group
    If in new format then fstab should read
    Code:
    /dev/hda1    /     ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0   0   1
    Note the differences - aquota.user instead of quota.user, aquota.group instead of quota.group, vfsv0 instead of vfsold

    Unfortunately I haven't got a test machine handy at the moment & was wondering if anyone can verify.

    Thx in advance
     
    Last edited: Jun 15, 2009
  3. falko

    falko Super Moderator

    I think I have to test this...
     
  4. Bikkies

    Bikkies New Member

    Thanks Falko, would have tried & tested myself but won't have a test box available for a few weeks & I am now intrigued. Have heard about journalled systems for years but not much info. Glad I was able to find one post that might point in the right direction.
     
  5. Bikkies

    Bikkies New Member

    p.s.- is there a way to change the subject for this topic to
    might make more sense to those searching.
    didn't think about this when I created the topic.
     
  6. pineapple

    pineapple New Member

    can't mount with aquota.user/aquota.group

    Hello

    I have tried to implement this after getting the journaled quota message while running quotacheck but after making the changes to fstab I get the response from mount: / not mounted already, or bad option. I have tried a couple of different variations but cannot mount until reverting back to the usrquota,grpquota entry.

    Has anyone had any luck with this and could share their fstab entry?
     
  7. Bikkies

    Bikkies New Member

    Waiting to hear from Falko.
    I should have a test box in about a week to play with.

    I believe the reason why you are getting the error is because you will find quota.user & quota.group probably in the / directory which is the old format that is mentioned above.
    Try
    Code:
    locate quota.user quota.group aquota.user aquota.group
    You should get a response like this if yours is in old format
    Code:
    /quota.group
    /quota.user
    I am unsure as to whether it matters that much as they are only filenames (not much documentation on this matter)

    If you only have quota.user & quota.group (so called old format) then you could try the entry below in your fstab (making sure it suits your partitioning scheme)
    Code:
    /dev/hda1    /     ext3    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsold   0   1
    @ pineapple, please advise how you go if you try it out before I get a chance.

    I take no responsibility for any of the code I have provided as it is NOT tested yet.
     
    Last edited: Jun 23, 2009
  8. pineapple

    pineapple New Member

    close, but ...

    Bikkies

    You are quite right - quota.user and quota.group are in /. So are aquota.user and aquota.group.

    I tried your suggestions but get the usual mount errors.

    Of interest, when I run the quotaon -avug command, I get:

    quotaon: using //aquota.user on /dev/sda1 [/]: Device or resource busy

    I'm on a Virtual Dedicated Server setup - would this make any difference?
     
  9. pineapple

    pineapple New Member

    Done!

    Just an update - managed to get it to work by removing the old quota files.

    I get a warning that aquota.group and aquota.user were probably truncated but it completes the check successfully.

    Thanks for your help.
     
  10. falko

    falko Super Moderator

  11. Bikkies

    Bikkies New Member

    Thx pineapple for posting your results. Been on a break & first chance I have had to chase this up.
    Just finished building another server & was able to implement journalled quotas successfully.
    Thanks to Falko for writing up a tutorial to cover this subject that is pretty obscure elsewhere.
    All round, a good group effort!
     
  12. iniwidi

    iniwidi New Member

    ISPCONFIG Quota for file system type simfs

    Hello,

    I have problem with quota in file system type simfs, my os debian 5.0 and ispconfig 3

    hosting:~# mount
    /dev/simfs on / type simfs (rw)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid)
    proc on /proc type proc (rw,nosuid,nodev,noexec)
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec)

    and when i used this command :

    hosting:~# mount -o remount /
    mount: permission denied

    I set /etc/fstab

    proc /proc proc defaults 0 0
    /dev/simfs / simfs errors=remount-ro,usrquota,grpquota 0 1
    none /dev/pts devpts rw 0 0

    thx for help me..
     
  13. falko

    falko Super Moderator

    Is this a virtual machine or a physical system?
     

Share This Page