The Perfect Server, clamd.amavisd not working!

Discussion in 'Installation/Configuration' started by ionbasa, Jan 24, 2013.

  1. ionbasa

    ionbasa New Member

    Hello all,
    I am following this guide here: http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-nginx-dovecot-ispconfig-3-p4

    On page 4 I have to run the following comands:
    Code:
    sa-update
    chkconfig --levels 235 amavisd on
    chkconfig --del clamd
    chkconfig --levels 235 clamd.amavisd on
    /usr/bin/freshclam
    /etc/init.d/amavisd start
    /etc/init.d/clamd.amavisd start
    but when trying to run "chkconfig --levels 235 clamd.amavisd on"
    I get the following error:
    error reading information on service clamd.amavisd: No such file or directory.

    Any ideas?

    Also in the page 3 it requires:
    Code:
    rpm --import https://fedoraproject.org/static/0608B895.txt
    wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-7.noarch.rpm
    rpm -ivh epel-release-6-7.noarch.rpm
    but "epel-release-6-7.noarch.rpm" does not exist on the fedora server,so I had to install the newer 6-8 version. would this have cause my problems with "clamd.amavisd"?

    Thank you.
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /etc/init.d/
    ?

    Did
    Code:
    yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql
    show any errors?
     
  3. ionbasa

    ionbasa New Member

    Sorry for not posting earlier.
    I figured out the problem.
    When I had to add the repos I accidentally messed up typing the URL :eek:. Now I just fixed it.
     

Share This Page