The Perfect Server CentOS: DNS and Webmail Problems

Discussion in 'HOWTO-Related Questions' started by RoganSarine, Oct 2, 2010.

  1. RoganSarine

    RoganSarine New Member

    The Perfect Server CentOS: DNS Problems

    Hey guys,

    I was wondering if anyone could solve my DNS?

    These were working before my VPS host decided to mess with the quota (so I ran out of space briefly)... And I havn't gotten them to work since.

    http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-3-p4

    The DNS basically won't resolve. The IP works fine, but www.example.com doesn't return anything. I can't figure out why.

    Any suggestions? Anything I can post?

    This is what intodns shows:
    http://www.intodns.com/overmined.com
     
    Last edited: Oct 3, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you sure your nameservers are running and lsitening on port 53 (TCP and UDP)?
     
  3. RoganSarine

    RoganSarine New Member

    I'm pretty sure, but I don't recall how to check.

    The ports are open though.

    Yeah, named.conf says they are listening on port 53
     
    Last edited: Oct 4, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    netstat -uap
    ?
     
  5. RoganSarine

    RoganSarine New Member

    Code:
    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             Stat                              e       PID/Program name
    tcp        0      0 localhost.localdomain:10024 *:*                         LIST                              EN      2030/amavisd (maste
    tcp        0      0 localhost.localdomain:10025 *:*                         LIST                              EN      3119/master
    tcp        0      0 *:mysql                     *:*                         LIST                              EN      1659/mysqld
    tcp        0      0 *:pop3                      *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 localhost.local:dyna-access *:*                         LIST                              EN      1381/clamd
    tcp        0      0 *:imap                      *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 localhost.localdomai:domain *:*                         LIST                              EN      3462/named
    tcp        0      0 *:ftp                       *:*                         LIST                              EN      3243/pure-ftpd (SER
    tcp        0      0 localhost.localdomain:rndc  *:*                         LIST                              EN      3462/named
    tcp        0      0 *:smtp                      *:*                         LIST                              EN      3119/master
    tcp        0      0 *:imaps                     *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 *:pop3s                     *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 *:pop3                      *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 *:imap                      *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 *:webcache                  *:*                         LIST                              EN      26150/httpd
    tcp        0      0 *:http                      *:*                         LIST                              EN      26150/httpd
    tcp        0      0 *:tproxy                    *:*                         LIST                              EN      26150/httpd
    tcp        0      0 localhost6.localdoma:domain *:*                         LIST                              EN      3462/named
    tcp        0      0 *:ftp                       *:*                         LIST                              EN      3243/pure-ftpd (SER
    tcp        0      0 *:ssh                       *:*                         LIST                              EN      32461/sshd
    tcp        0      0 localhost6.localdomain:rndc *:*                         LIST                              EN      3462/named
    tcp        0      0 *:imaps                     *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 *:pop3s                     *:*                         LIST                              EN      1705/dovecot
    tcp        0      0 server1.mydomain.com:http  ::ffff:174.1.213.:mc-gt-srv TIME                              _WAIT   -
    tcp        0   1600 server1.mydomain.com:ssh   ::ffff:174.1.213:cgn-config ESTA   
    Code:
    netstat -uap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    udp        0      0 localhost.locald:domain     *:*                                     3462/named
    udp        0      0 localhost6.local:domain     *:*                                     3462/named
    
    At this point, I'm just curious because I managed to get my hands on a free DirectAdmin license, but still...
     
  6. falko

    falko Super Moderator ISPConfig Developer

    BIND is listening on localhost only. You must configure it to listen on all interfaces. What's in your named.conf?
     
  7. RoganSarine

    RoganSarine New Member

    I've probably broken everything trying to fix this... I think I added those 3 listen ports recently just seeing if it would do anything.

    Code:
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    options {
            listen-on port 53 { 127.0.0.1; };
            listen-on port 53 { 199.19.226.110; };
            listen-on port 53 { 205.185.120.79; };
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named/chroot/var/named";
            dump-file       "/var/named/chroot/var/named/data/cache_dump.db";
            statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
            allow-query     { localhost; };
            allow-recursion { recurseallow; };
    };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    zone "." IN {
            type hint;
            file "named.root";
    };
    include "/var/named/chroot/etc/named.conf.local";
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Remove
    Code:
            listen-on port 53 { 127.0.0.1; };
            listen-on port 53 { 199.19.226.110; };
            listen-on port 53 { 205.185.120.79; };
            listen-on-v6 port 53 { ::1; };
    and restart BIND.
     
  9. RoganSarine

    RoganSarine New Member

    Code:
    /var/named/chroot/var/named//pri.ns1.overmined.com:10: ignoring out-of-zone data (localhost.example.com)
    ...[B]This is repeated for my entire DNS entry[/B]
    zone ns1.example.com/IN: has no NS records
    _default/ns1.example.com/IN: bad zone
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Why do you have a zone for ns1.overmined.com? You should have a zone for overmined.com (which includes records for ns1.overmined.com), but not for ns1.overmined.com.
     

Share This Page