The Perfect Server - CentOS 6.5 x86_64 FTP does not work

Discussion in 'HOWTO-Related Questions' started by galdorf, Jun 24, 2014.

  1. galdorf

    galdorf New Member

    I have followed The Perfect Server - CentOS 6.5 x86_64 (Apache2, MySQL, PHP, PureFTPD, Postfix, Dovecot and ISPConfig 3)

    and can't get the ftp to authenticate im sure there is a step missing like creating the database for PureFTPD but im kind of new so not sure.
    Response: 530 Login authentication failed
    Error: Critical error
    Error: Could not connect to server
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no step missing, at least if you havent left out anything from the guide. If the pure-ftpd database would be mising, then you wont be able to open the ispconfig interface at all as its the same database that ispconfig uses.

    the most likely reason for yur problem is that you did not use the full ftp username, which consist of the prefix and the actual user. take a look at the ftp user list in ispconfig to see the full username.
  3. galdorf

    galdorf New Member

    Oh i see the prefix in ftp-user, so if prefix is default and user name angryjoe the ftp username should be defaultangryjoe and password typed password?
    Last edited: Jun 25, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    yes. The prefix is required as ftp usernames have to be unique over the whole server and not just for the dmain. If you dont host any clients, then you can disable prefixes under System > interface config in ispconfig.

Share This Page