The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3] - PURE-FTPD

Discussion in 'HOWTO-Related Questions' started by epretorious, Jan 13, 2012.

  1. epretorious

    epretorious New Member HowtoForge Supporter

    After performing Step 16 ("Install PureFTPd") of "The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]" SSH access works, but FTP access does not...

    Code:
    [justine@sunflower ~]$ ssh 192.168.0.11 ls -al /opt
    justine@192.168.0.11's password: 
    total 8
    drwxr-xr-x.  2 root root 4096 Sep 23 04:47 .
    dr-xr-xr-x. 25 root root 4096 Jan 12 22:07 ..
    
    [justine@sunflower ~]$ ftp 192.168.0.11
    Connected to 192.168.0.11.
    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 22:24. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    500 This security scheme is not implemented
    Name (192.168.0.11:justine): 
    331 User justine OK. Password required
    Password:
    530 Login authentication failed
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> quit
    221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
    221 Logout.
    I've checked the system log file for clues, but there are none:

    Code:
    [eric@ispconfig-1 suphp-0.7.1]$ sudo tail -f /var/log/messages 
    ...
    Jan 12 22:24:16 ispconfig-1 pure-ftpd: (?@192.168.0.20) [INFO] New connection from 192.168.0.20
    Jan 12 22:24:29 ispconfig-1 pure-ftpd: (?@192.168.0.20) [WARNING] Authentication failed for user [justine]
    Jan 12 22:24:35 ispconfig-1 pure-ftpd: (?@192.168.0.20) [INFO] Logout.
    
    Any ideas what might be causing this?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must install ISPConfig and create an FTP account through ISPConfig.
     
  3. epretorious

    epretorious New Member HowtoForge Supporter

    Thanks, Falko. I'll test this tonight.
     
  4. epretorious

    epretorious New Member HowtoForge Supporter

    It took me a while, but I finally found the FTP User tab (Sites -> FTP User) and then it took me a while longer, but I finally understand ISPConfig's methodology/requirements for FTP user accounts: FTP user accounts must be created by prepending the client name with some other string of characters. :mad:

    I understand and appreciate the feature to allow multiple FTP accounts per ISPConfig client but feel that the requiring that the FTP account not be the same as the client name is just one more thing for clients to remember.
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can disable the username prefix fo ftp, shell and database users under System > Interface config.
     
  6. epretorious

    epretorious New Member HowtoForge Supporter

    Thanks, Till. This is exactly what I needed+wanted!
     

Share This Page