The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3] - AMAVISD

Discussion in 'HOWTO-Related Questions' started by epretorious, Jan 18, 2012.

  1. epretorious

    epretorious New Member

    There appears to be a detail missing in Step 14 ("Install Amavisd-new, SpamAssassin And ClamAV") of "The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]":

    1. When performing Step 14, the Amavisd init.d script (/etc/init.d/amavisd) complained...
    Code:
    [[email protected] ~]$ sudo /etc/init.d/amavisd start
    Starting amavisd:   The value of variable $myhostname is "ispconfig-1", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in amavisd.conf, or fix what uname(3) provides as a host's network name!
                                                               [[COLOR="Red"]FAILED[/COLOR]]
    2. This prevented mail delivery and lead to lots of these errors (in /var/log/maillog)...
    Code:
    Jan 17 20:01:39 ispconfig-1 postfix/smtp[1819]: 08F1D62443: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=59398, delays=59397/0.06/0.04/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 17 20:01:39 ispconfig-1 postfix/smtp[2020]: A3611624B2: to=<[email protected]>, relay=none, delay=337, delays=337/0.07/0.04/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 17 20:01:39 ispconfig-1 postfix/error[2031]: D0044624B7: to=<[email protected]>, relay=none, delay=337, delays=337/0.14/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 17 20:02:02 ispconfig-1 postfix/error[2031]: BEF54624C7: to=<[email protected]>, relay=none, delay=0.16, delays=0.14/0/0/0.02, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 17 20:03:51 ispconfig-1 postfix/error[2119]: 41080624C9: to=<[email protected]>, relay=none, delay=41, delays=40/0.02/0/0.03, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jan 17 20:06:39 ispconfig-1 postfix/smtp[2271]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jan 17 20:06:39 ispconfig-1 postfix/smtp[2272]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
     
  2. epretorious

    epretorious New Member

    Editing /etc/amavisd/amavisd.conf (i.e., Setting $myhostname to the FQHN of the MX) resolves this:
    Code:
    [[email protected] ~]$ hostname  -f
    ispconfig-1.example.com
    
    [[email protected] ~]$ grep \$myhostname /etc/amavisd/amavisd.conf
    $myhostname = 'ispconfig-1.example.com';  # must be a fully-qualified domain name!
     

Share This Page