The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3]

Discussion in 'Suggest HOWTO' started by rewards, Dec 1, 2011.

  1. rewards

    rewards New Member


    I have have tried to install ISPConfig 3 on a Centos The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3] at this page, on a freshly installed Centos 6.0 64bit and I found some problem and they are;

    1- At page 3, 7 Enable Additional Repositories And Install Some Software, the import command does not work and here the error message;

    [root@server1 ~]# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Security-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Testing-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag: key 1 import failed.

    also this command does not work eaither.
    rpm --import

    [root@server1 ~]# rpm --import
    error: key 1 import failed.
    [root@server1 ~]#

    The webmail gets installed and can be accessed at this page, I found two problems here and they are;
    1- I cannot access the site using
    2- I can access the site using IP address but when I try to login with user name falko and password falko I get error message saying "ERROR
    Unknown user or password incorrect."

    On this page you have a typo problem,, for 15 Installing Apache2 With mod_php, mod_fcgi/PHP5, And suPHP and the command;

    yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-eaccelerator php-mbstring php-mcrypt php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel

    the mssql-php perhaps should be mysql-php. The yum gives problem when it reaches to that line.
  2. falko

    falko Super Moderator ISPConfig Developer

    Seems as if the keys were imported before, so you can ignore this.

    Does point to

    You must create an email account in ISPConfig first and then log in with the email address and the password.

    No, no typo. I install php-mysql and php-mssql. If the command doesn't work for you, there's something wrong with your setup.
  3. rewards

    rewards New Member


    The point to I did as instruction by putting server1 in /etc/hosts file. I don't know what else needs to be done? I still can access only by IP address only. In ISPConfig, I clicked Email, added domain called, Domain, spamfilter not enabled. Then, I added a mailbox for falko, real name Falko, email [email protected], password falko, Quata 10MB, sent copy to is blank, spamfilter not enabled, Enable Receiving box is checked, Disable IMAP and Disable POP3 boxes are unchecked and saved it. I still get Unknown user or password incorrect error message when I tried to login. Thank you for reply in advanced.
  4. falko

    falko Super Moderator ISPConfig Developer

    You must log in with the full email address, not just the local part, so the username would be [email protected].

    Modify your client PC's host file and add a record for or set up a local DNS server that resolves
  5. rewards

    rewards New Member

    Hi Falko,

    You deserve a gold medal. Thank you for your responses. Now Falko can login to I still had problem installing php-mssql and I hope it would not be a big deal to have that. The message was;

    [root@server1 ~]# yum install php-mssql
    Loaded plugins: fastestmirror, presto, priorities, refresh-packagekit
    Loading mirror speeds from cached hostfile
    * base:
    * epel:
    * extras:
    * rpmforge:
    * updates:
    1070 packages excluded due to repository priority protections
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
    --> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
    --> Processing Dependency: for package: php-mssql-5.3.3-1.el6.x86_64
    --> Running transaction check
    ---> Package freetds.x86_64 0:0.91-1.el6 set to be updated
    ---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
    --> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-mssql-5.3.3-1.el6.x86_64 (epel)
    Requires: php-pdo >= 5.3.3
    Installed: php-pdo-5.3.2-6.el6_0.1.x86_64 (@updates)
    php-pdo = 5.3.2-6.el6_0.1
    Available: php-pdo-5.3.2-6.el6.x86_64 (base)
    php-pdo = 5.3.2-6.el6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [root@server1 ~]#

    The server I am assuming is running well. The ISPConfig, the phpMyAdmin and webmail are working and I can access them. I had few questions. I tried to send an email to my yahoo mail address from webmail and I did not receive any mail from falko user. Does it mean I have to add domain information in postfix? I am ready to install the web-script I have and I am still unclear which folder is the web folder to upload the script? Do you know which folder is web folder by default under ISPConfig? In order for this server to fully be functional as a home server which can be appreciable on the Internet, do I have to do anything else? I have the domain already from godaddy. I have to mention that I bought ISPConfig manual and the focus of this manual is how to install the ISPConfig on a single server or multiple mirror servers focusing more on the Debian and Ubuntu servers etc and does not say that much beyond the installation. I mean after the successful installation of ISPConfig and uploading the web script and successful installation of the web-script, do I have to do further more configurations? Thank you again.
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you enable and configure all repositories exactly as shown in the tutorial?

    Any errors in your mail log? Also please check if your server is blaclisted:

    You must create an FTP user for the website and then log in with an FTP client such as FileZilla. You should then see a web folder. This is where you must upload your stuff.
  7. rewards

    rewards New Member

    Hi Falko

    Yes I did exactly as the tutorial not once but several times and every time I did a fresh install and started from scratch. I have lots of log files in /var/log folders as shown below. Which one is the accurate log file to check.

    [root@server1 log]# ls
    anaconda.log audit dmesg lastlog ppp tallylog yum.log
    anaconda.program.log boot.log dmesg.old maillog prelink wpa_supplicant.log btmp gdm messages pureftpd.log wtmp
    anaconda.syslog clamav httpd mysqld.log rkhunter Xorg.0.log
    anaconda.xlog ConsoleKit ispconfig ntpstats secure Xorg.0.log.old
    anaconda.yum.log cron ispconfig_install.log pm-powersave.log spooler Xorg.9.log

    Yes the IP address of my ISP was in the black listed website you sent me I created a FTP user called falko with password falko in the ISPConfig. When I tried to FTP using Filezilla with falko user I get the following error message;

    Status: Connecting to
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 50 allowed.
    Response: 220-Local time is now 16:16. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER falko
    Response: 331 User falko OK. Password required
    Command: PASS *****
    Response: 530 Login authentication failed
    Error: Critical error
    Error: Could not connect to server
  8. falko

    falko Super Moderator ISPConfig Developer

    It's /var/log/maillog.

    Do you use a dynamic IP? In that case you should set up relaying:

    Are you sure that falko is the correct username? You can find the correct username in the FTP user listview in ISPConfig.

Share This Page