The perfect Server CentOS 5.5 64.....DNS offline

Discussion in 'Installation/Configuration' started by mrshaheer2000, Apr 1, 2011.

  1. mrshaheer2000

    mrshaheer2000 New Member

    Hi to all

    I have successfully installed CentOS 5.5 64bit and ISPConfig 3 by following the tutorial The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3]

    currently I am getting following error while restarting bind

    /etc/init.d/named restart

    Error in named configuration:
    /etc/named.conf:5: unknown option 'DNS'

    (I have done nothing other then this tutorial)


    I am fix up since 3 days..
    Please advice me how to solve this problem..

    shaheer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Post the file /etc/named.conf
     
  3. mrshaheer2000

    mrshaheer2000 New Member

    Dear Till

    here below is my named.conf file

    Code:
    
    GNU nano 1.3.12                File: /etc/named.conf                                                             Modified
    
            statistics-file
    "/var/named/chroot/var/named/data/named_stats.txt";
            memstatistics-file
    "/var/named/chroot/var/named/data/named_mem_stats.txt";
            allow-query     { localhost; };
            recursion yes;
    };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    zone "." IN {
            type hint;
            file "named.root";
    };
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8)
    DNS
    // server as a caching only nameserver (as a localhost DNS resolver
    only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration
    files.
    //
    options {
            listen-on port 53 { 127.0.0.1; };
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named/chroot/var/named";
            dump-file
    "/var/named/chroot/var/named/data/cache_dump.db";
    
    
    (ISPconfig3 also showing DNS service off line)

    I hope it will help you to help me :)
     
  4. mrshaheer2000

    mrshaheer2000 New Member

    Dear Till

    I need your help please reply.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    Code:
    cat /etc/named.conf
    ?

    In your previous post your named.conf looks as if it's formatted wrong, but I'm not sure if it really is or if something went wrong when you pasted it here.
     
  6. mrshaheer2000

    mrshaheer2000 New Member

    Dear Falko

    thanks for your reply

    Please find below the output you asked.


    Code:
    [root@rizserver ~]# cat /etc/named.conf
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8)
    DNS
    // server as a caching only nameserver (as a localhost DNS resolver
    only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration
    files.
    //
    options {
            listen-on port 53 { 127.0.0.1; };
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named/chroot/var/named";
            dump-file
    "/var/named/chroot/var/named/data/cache_dump.db";
            statistics-file
    "/var/named/chroot/var/named/data/named_stats.txt";
            memstatistics-file
    "/var/named/chroot/var/named/data/named_mem_stats.txt";
            allow-query     { localhost; };
            recursion yes;
    };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    zone "." IN {
            type hint;
            file "named.root";
    };
    include "/var/named/chroot/etc/named.conf.local";
    [root@rizserver ~]#
    
    
     
  7. mrshaheer2000

    mrshaheer2000 New Member

    Dear Falko

    I am desperately waiting for your reply

    I need your help

    :(
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Code:
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8)
    [COLOR="Red"]DNS[/COLOR]
    // server as a caching only nameserver (as a localhost DNS resolver
    [COLOR="Red"]only).[/COLOR]
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration
    [COLOR="Red"]files.[/COLOR]
    //
    
    Please make sure that the strings that I marked in red don't use a new line - they must all go in the previous line.
     
  9. mrshaheer2000

    mrshaheer2000 New Member

    Dear Falko

    I have changed the file as you advice but still DNS service is not start

    here is output of my file

    Code:
    [root@rizserver ~]# cat /etc/named.conf
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    options {
            listen-on port 53 { 127.0.0.1; };
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named/chroot/var/named";
            dump-file
    "/var/named/chroot/var/named/data/cache_dump.db";
            statistics-file
    "/var/named/chroot/var/named/data/named_stats.txt";
            memstatistics-file
    "/var/named/chroot/var/named/data/named_mem_stats.txt";
            allow-query     { localhost; };
            recursion yes;
    };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    zone "." IN {
            type hint;
            file "named.root";
    };
    include "/var/named/chroot/etc/named.conf.local";
    [root@rizserver ~]#
    
     
  10. mrshaheer2000

    mrshaheer2000 New Member

    Dear Falko

    Thanks you very much

    It is solve when I restart my computer

    Thanks, Thanks Thanks,

    You Rock Falko.

    :)
     
  11. soldier

    soldier New Member

    There was a similar problem. created the named.conf file with the
    specified code in the directory / var / named / chroot / etc / but
    The DNS issue fails.

    BIND installed according to instructions http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-3-p5

    in the directory / var / named / chroot / etc has created a file named.conf specified in the
    How content. in the same directory the file file named.conf.local is registered in the following:

    zone "localhost" {
    type master;
    file "var/named/chroot/etc/domain.local";
    };

    zone "0.0.127.in-addr.arpa." {
    type master;
    file "var/named/chroot/etc/127.0.0.rev";
    };

    in the directory / var / named / chroot / etc has created a files

    domain.local

    $TTL 3h
    @ IN SOA localhost. root.localhost.
    1 1d 12h 1w 3h

    domain.local. IN NS localhost.

    domain A 127.0.0.1
    serv1 A 127.0.0.1

    127.0.0.rev
    $TTL 604800
    @ IN SOA localhost. root.localhost. 1 1d 12h 1w 3h

    @ IN NS localhost

    129 PTR localhost.
    53 PTR serv.localhost.

    when you start getting the following BIND:
    [root@localhost ~]# /etc/init.d/named restart
    Останавливается named: [ OK ]
    Запускается named:
    Ошибка в конфигурации named: :
    zone localhost/IN: loading master file var/named/chroot/etc/domain.local: file not found
    _default/localhost/IN: file not found
    zone 0.0.127.in-addr.arpa/IN: loading master file var/named/chroot/etc/127.0.0.rev: file not found
    _default/0.0.127.in-addr.arpa./IN: file not found
    [ СБОЙ ]
    tell me what's the problem?
     
    Last edited: Apr 11, 2011
  12. falko

    falko Super Moderator ISPConfig Developer

    Can you replace the line
    Code:
    include "/var/named/chroot/etc/named.conf.local";
    with
    Code:
    include "/var/named/chroot/var/named/named.local";
    in /var/named/chroot/etc/named.conf and restart BIND?
     
  13. soldier

    soldier New Member

    Thanks, solved the problem yourself. There were errors in the
    configuration files. and not set access rights
    the file named.conf. bind now works fine
     

Share This Page